aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2013-01-30 01:50:42 +0000
committerXin LI <delphij@FreeBSD.org>2013-01-30 01:50:42 +0000
commita107fbed69a03df163dbde0f7701ec889b010885 (patch)
tree9a3c97788ea989e94568aee73b46f83a61c0ae17 /www
parent62f582e043680e90b067a6f636bcaa30880847fe (diff)
downloadports-a107fbed69a03df163dbde0f7701ec889b010885.tar.gz
ports-a107fbed69a03df163dbde0f7701ec889b010885.zip
Update to 3.5.1. While I'm there, also change russian to use gzipped tarball,
make the port to use OptionsNG and fix installation permissions. PR: ports/175525 [1], ports/175632 [2], ports/175679 [3] Submitted by: Takefu <takefu airport fm> [1], Mihail Timofeev <miha_hard mail ru> [2], delphij [3] Approved by: maintainer, 9267096@gmail.com [1][2], ychsiao [1][3] Security: 559e00b7-6a4d-11e2-b6b0-10bf48230856
Notes
Notes: svn path=/head/; revision=311195
Diffstat (limited to 'www')
-rw-r--r--www/wordpress/Makefile15
-rw-r--r--www/wordpress/distinfo4
-rw-r--r--www/wordpress/files/pkg-install.in14
-rw-r--r--www/wordpress/files/pkg-message.in (renamed from www/wordpress/pkg-message)2
4 files changed, 26 insertions, 9 deletions
diff --git a/www/wordpress/Makefile b/www/wordpress/Makefile
index c97f00d4b27d..031ab69d209d 100644
--- a/www/wordpress/Makefile
+++ b/www/wordpress/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: wordpress
-# Date created: 2004-07-29
-# Whom: Elvis Chiang <elvis@sslab.cs.ccu.edu.tw>
-#
+# Created by: Elvis Chiang <elvis@sslab.cs.ccu.edu.tw>
# $FreeBSD$
-#
PORTNAME= wordpress
-PORTVERSION= 3.5
+PORTVERSION= 3.5.1
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= http://wordpress.org/
@@ -14,6 +10,9 @@ MASTER_SITES= http://wordpress.org/
MAINTAINER= ychsiao@ychsiao.org
COMMENT= A state-of-the-art semantic personal publishing platform
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/license.txt
+
CONFLICTS_INSTALL= de-wordpress-3.* ja-wordpress-3.* ru-wordpress-3.*
NO_BUILD= yes
@@ -21,6 +20,9 @@ USE_PHP= curl gd mysql pcre tokenizer xml zip
WANT_PHP_WEB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
+SUB_FILES= pkg-message pkg-install
+SUB_LIST= CHGRP="${CHGRP}" CHOWN="${CHOWN}" CHMOD="${CHMOD}"\
+ FIND="${FIND}" WWWGRP="${WWWGRP}" WWWOWN="${WWWOWN}"
PLIST= ${WRKDIR}/pkg-plist
PORTDOCS= license.txt readme.html
@@ -49,6 +51,7 @@ do-install:
.endif
post-install:
+ @${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/www/wordpress/distinfo b/www/wordpress/distinfo
index d34cb91b74fa..6f6694a71f19 100644
--- a/www/wordpress/distinfo
+++ b/www/wordpress/distinfo
@@ -1,2 +1,2 @@
-SHA256 (wordpress-3.5.tar.gz) = def1d094dbd3fcc52208d4e63ae4c31901dfd97e9b4cd619b7d017fd342972ab
-SIZE (wordpress-3.5.tar.gz) = 5009441
+SHA256 (wordpress-3.5.1.tar.gz) = f7d627bc886eac75aae22e526acdbdea244a12a92f02e6084ba5193d4b0d7a97
+SIZE (wordpress-3.5.1.tar.gz) = 5012722
diff --git a/www/wordpress/files/pkg-install.in b/www/wordpress/files/pkg-install.in
new file mode 100644
index 000000000000..4d3943f8ffa6
--- /dev/null
+++ b/www/wordpress/files/pkg-install.in
@@ -0,0 +1,14 @@
+#!/bin/sh
+# $FreeBSD$
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+ POST-INSTALL)
+ %%CHOWN%% -R %%WWWOWN%% %%WWWDIR%%/wp-content
+ %%FIND%% %%WWWDIR%% -type d -print | xargs %%CHGRP%% %%WWWGRP%%
+ %%FIND%% %%WWWDIR%% -type d -print | xargs %%CHMOD%% g+w
+ ;;
+ *)
+ ;;
+esac
diff --git a/www/wordpress/pkg-message b/www/wordpress/files/pkg-message.in
index 0fcaa079166e..a3c01e1be0d6 100644
--- a/www/wordpress/pkg-message
+++ b/www/wordpress/files/pkg-message.in
@@ -1,6 +1,6 @@
**** NOTE ****
Before the first use of WordPress, copy wp-config-sample.php to wp-config.php
-in ${WWWDIR} and modify it to fit your MySQL.
+in %%WWWDIR%% and modify it to fit your MySQL.
Maybe you need 'mysqladmin create wordpress' first.
If you are upgrading from 1.x or 2.x to 3.x, please run
http://your.site/wordpress/wp-admin/upgrade.php to upgrade to WordPress 3.x