aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorOlivier Duchateau <olivierd@FreeBSD.org>2013-01-23 19:17:33 +0000
committerOlivier Duchateau <olivierd@FreeBSD.org>2013-01-23 19:17:33 +0000
commitaf54201b3f23546b96189cd59bf642fdb4ae1759 (patch)
tree7dff6dba627bf8d24fa7c4f19fdc519f69945057 /www
parent13d1ff4b890a59022475a575ce06fc01c0adaab4 (diff)
downloadports-af54201b3f23546b96189cd59bf642fdb4ae1759.tar.gz
ports-af54201b3f23546b96189cd59bf642fdb4ae1759.zip
- Update to 0.4.5
- Trim Makefile header - Use USE_PKGCONFIG - Adjust dependencies in USE_XFCE - Add patch, which replaces Debian's bugzilla by FreshPorts Approved by: rene, miwi (mentors, implicit)
Notes
Notes: svn path=/head/; revision=310885
Diffstat (limited to 'www')
-rw-r--r--www/xfce4-smartbookmark-plugin/Makefile15
-rw-r--r--www/xfce4-smartbookmark-plugin/distinfo4
-rw-r--r--www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c28
-rw-r--r--www/xfce4-smartbookmark-plugin/pkg-plist18
4 files changed, 48 insertions, 17 deletions
diff --git a/www/xfce4-smartbookmark-plugin/Makefile b/www/xfce4-smartbookmark-plugin/Makefile
index 1211cf386ccc..4da57131e6ab 100644
--- a/www/xfce4-smartbookmark-plugin/Makefile
+++ b/www/xfce4-smartbookmark-plugin/Makefile
@@ -1,27 +1,24 @@
-# New ports collection makefile for: xfce4-smartbookmark-plugin
-# Date created: 28 Januar 2007
-# Whom: Martin Wilke (miwi@FreeBSD.org)
-#
+# Created by: Martin Wilke (miwi@FreeBSD.org)
# $FreeBSD$
#
PORTNAME= xfce4-smartbookmark-plugin
-PORTVERSION= 0.4.4
-PORTREVISION= 2
+PORTVERSION= 0.4.5
CATEGORIES= www xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/panel-plugins/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
-COMMENT= A bookmark plugin for the Xfce panel
+COMMENT= Query search engines from the Xfce panel
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-USE_GNOME= gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv libgui panel
+USE_GNOME= gtk20 intltool intlhack
+USE_PKGCONFIG= build
+USE_XFCE= configenv libexo libmenu libutil panel
USE_XORG= ice
.include <bsd.port.mk>
diff --git a/www/xfce4-smartbookmark-plugin/distinfo b/www/xfce4-smartbookmark-plugin/distinfo
index a344593825d6..c369efc25824 100644
--- a/www/xfce4-smartbookmark-plugin/distinfo
+++ b/www/xfce4-smartbookmark-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/xfce4-smartbookmark-plugin-0.4.4.tar.bz2) = 6c77e8fee0ec4dcee7aa34d94377e068a522b1ea650823422f2f5cca8126f2ed
-SIZE (xfce4/xfce4-smartbookmark-plugin-0.4.4.tar.bz2) = 293094
+SHA256 (xfce4/xfce4-smartbookmark-plugin-0.4.5.tar.bz2) = 6aa4269a5f4b7a3332d3c491efbbbd0a9ff0031a0005fee780346863bcf4f886
+SIZE (xfce4/xfce4-smartbookmark-plugin-0.4.5.tar.bz2) = 271402
diff --git a/www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c b/www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c
new file mode 100644
index 000000000000..278a91811b5a
--- /dev/null
+++ b/www/xfce4-smartbookmark-plugin/files/patch-src__smartbookmark.c
@@ -0,0 +1,28 @@
+--- ./src/smartbookmark.c.orig 2013-01-03 21:18:38.000000000 +0000
++++ ./src/smartbookmark.c 2013-01-21 20:08:22.000000000 +0000
+@@ -183,9 +183,9 @@
+ box = gtk_vbox_new(FALSE, 0);
+
+ /* default options */
+- search->url = "http://bugs.debian.org/";
+- search->label_text = "BTS";
+- search->size = 5;
++ search->url = "http://www.freshports.org/search.php?query=";
++ search->label_text = "FreshPorts";
++ search->size = 12;
+ search->hide_label = FALSE;
+ /* read config file options */
+ filename = xfce_panel_plugin_save_location(plugin, TRUE);
+@@ -255,9 +255,9 @@
+ if( (rcfile = xfce_rc_simple_open(filename, TRUE) ))
+ {
+ xfce_rc_set_group(rcfile, NULL);
+- search->url = g_strdup(xfce_rc_read_entry(rcfile,"url","http://bugs.debian.org/"));
+- search->label_text = g_strdup(xfce_rc_read_entry(rcfile,"value","DBS"));
+- search->size = xfce_rc_read_int_entry(rcfile, "size", 5);
++ search->url = g_strdup(xfce_rc_read_entry(rcfile,"url","http://www.freshports.org/search.php?query="));
++ search->label_text = g_strdup(xfce_rc_read_entry(rcfile,"value","FreshPorts"));
++ search->size = xfce_rc_read_int_entry(rcfile, "size", 12);
+ search->hide_label = xfce_rc_read_bool_entry(rcfile, "hidelabel", FALSE);
+ }
+ }
diff --git a/www/xfce4-smartbookmark-plugin/pkg-plist b/www/xfce4-smartbookmark-plugin/pkg-plist
index a14e93eb7c5d..1ebcdf381531 100644
--- a/www/xfce4-smartbookmark-plugin/pkg-plist
+++ b/www/xfce4-smartbookmark-plugin/pkg-plist
@@ -1,6 +1,6 @@
-lib/xfce4/panel-plugins/libsmartbookmark.a
-lib/xfce4/panel-plugins/libsmartbookmark.la
-lib/xfce4/panel-plugins/libsmartbookmark.so
+lib/xfce4/panel/plugins/libsmartbookmark.la
+lib/xfce4/panel/plugins/libsmartbookmark.so
+share/locale/ar/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ast/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ca/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/cs/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
@@ -17,6 +17,8 @@ share/locale/hu/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/id/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/it/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ja/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/ko/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
+share/locale/lt/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/lv/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/nl/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/pl/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
@@ -33,8 +35,10 @@ share/locale/ur/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/ur_PK/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/zh_CN/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
share/locale/zh_TW/LC_MESSAGES/xfce4-smartbookmark-plugin.mo
-share/xfce4/panel-plugins/smartbookmark.desktop
-@dirrmtry share/xfce4/panel-plugins
+share/xfce4/panel/plugins/smartbookmark.desktop
+@dirrmtry share/xfce4/panel/plugins
+@dirrmtry share/xfce4/panel
+@dirrmtry share/xfce4
@dirrmtry share/locale/ur_PK/LC_MESSAGES
@dirrmtry share/locale/ur_PK
@dirrmtry share/locale/ur/LC_MESSAGES
@@ -43,4 +47,6 @@ share/xfce4/panel-plugins/smartbookmark.desktop
@dirrmtry share/locale/ug
@dirrmtry share/locale/ast/LC_MESSAGES
@dirrmtry share/locale/ast
-@dirrmtry lib/xfce4/panel-plugins
+@dirrmtry lib/xfce4/panel/plugins
+@dirrmtry lib/xfce4/panel
+@dirrmtry lib/xfce4