aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2013-01-28 11:13:38 +0000
committerRenato Botelho <garga@FreeBSD.org>2013-01-28 11:13:38 +0000
commitda51663cfb0ca88cdcb3c091c9a87595ddfae81a (patch)
treec0056c78f9ec871926de1d657286e7509c5d01e4 /www
parent1cc04ea31d67667a1dcbd618ae484a4516171fe4 (diff)
downloadports-da51663cfb0ca88cdcb3c091c9a87595ddfae81a.tar.gz
ports-da51663cfb0ca88cdcb3c091c9a87595ddfae81a.zip
- Update to 2.12.0.3 [1]
- Use USE_PKGCONFIG - Devel tarball is available at sourceforge, so use it and remove instructions for manual download PR: ports/175526 [1] Submitted by: Marcello Coutinho <marcellocoutinho@gmail.com> [1]
Notes
Notes: svn path=/head/; revision=311114
Diffstat (limited to 'www')
-rw-r--r--www/dansguardian-devel/Makefile11
-rw-r--r--www/dansguardian-devel/distinfo4
-rw-r--r--www/dansguardian-devel/files/patch-src__ConnectionHandler.cpp14
-rw-r--r--www/dansguardian-devel/files/patch-src__OptionContainer.cpp11
4 files changed, 30 insertions, 10 deletions
diff --git a/www/dansguardian-devel/Makefile b/www/dansguardian-devel/Makefile
index 9e2d09029115..644d5eefcd54 100644
--- a/www/dansguardian-devel/Makefile
+++ b/www/dansguardian-devel/Makefile
@@ -2,9 +2,9 @@
# $FreeBSD$
PORTNAME= dansguardian
-PORTVERSION= 2.12.0.2
+PORTVERSION= 2.12.0.3
CATEGORIES= www
-MASTER_SITES= # empty, see below
+MASTER_SITES= SF/dansguardian
MAINTAINER= garga@FreeBSD.org
COMMENT= A fast, feature-rich web content filter for Squid proxy servers
@@ -13,7 +13,7 @@ RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid
LIB_DEPENDS+= pcre:${PORTSDIR}/devel/pcre
USE_RC_SUBR= dansguardian
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= yes
USE_BZIP2= yes
CONFLICTS= dansguardian-2.10.*
@@ -114,11 +114,6 @@ PLIST_SUB+= EMAILCONF="@comment "
CONFIGURE_ARGS+= --with-dgdebug
.endif
-# User needs to manually download the distfile
-.if !(exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})) && !defined(PACKAGE_BUILDING)
-IGNORE= commercial source download is restricted. Please visit and read ${DG_URL} and download ${DISTNAME}${EXTRACT_SUFX} into ${DISTDIR} before running make
-.endif
-
post-patch:
.if empty(PORT_OPTIONS:MDOCS)
@${REINPLACE_CMD} -e '/install-data-am/ s|install-dist_docDATA||' \
diff --git a/www/dansguardian-devel/distinfo b/www/dansguardian-devel/distinfo
index 0f79a6db96a0..4a5eba81661d 100644
--- a/www/dansguardian-devel/distinfo
+++ b/www/dansguardian-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dansguardian-2.12.0.2.tar.bz2) = 8f89077bf68e6d864c506193efc1d7a98e660650adb4edcb68b54c46f07f2fa0
-SIZE (dansguardian-2.12.0.2.tar.bz2) = 577994
+SHA256 (dansguardian-2.12.0.3.tar.bz2) = c74e9a32b97f9a9a056fced3da23fe48fca2bc6aa9af670afe9a53dc819414f5
+SIZE (dansguardian-2.12.0.3.tar.bz2) = 577701
diff --git a/www/dansguardian-devel/files/patch-src__ConnectionHandler.cpp b/www/dansguardian-devel/files/patch-src__ConnectionHandler.cpp
new file mode 100644
index 000000000000..852e663cc2b5
--- /dev/null
+++ b/www/dansguardian-devel/files/patch-src__ConnectionHandler.cpp
@@ -0,0 +1,14 @@
+--- ./src/ConnectionHandler.cpp.orig 2012-09-29 17:06:45.000000000 -0300
++++ ./src/ConnectionHandler.cpp 2013-01-16 03:04:07.000000000 -0200
+@@ -1488,8 +1488,11 @@
+
+ //if we cant write the certificate its not the end of the world but it is slow
+ if (!writecert){
++#ifdef DGDEBUG
+ std::cout << dbgPeerPort << " -Couldn't save certificate to on disk cache" << std::endl;
++#endif
+ syslog(LOG_ERR,"Couldn't save certificate to on disk cache");
++
+ }
+ #ifdef DGDEBUG
+
diff --git a/www/dansguardian-devel/files/patch-src__OptionContainer.cpp b/www/dansguardian-devel/files/patch-src__OptionContainer.cpp
new file mode 100644
index 000000000000..a643490b3d08
--- /dev/null
+++ b/www/dansguardian-devel/files/patch-src__OptionContainer.cpp
@@ -0,0 +1,11 @@
+--- ./src/OptionContainer.cpp.orig 2013-01-25 02:31:02.000000000 +0000
++++ ./src/OptionContainer.cpp 2013-01-25 02:31:25.000000000 +0000
+@@ -612,7 +612,7 @@
+ }
+
+ // if the more than one port is being used, validate the combination of auth plugins
+- if (authplugins.size() > 1) {
++ if (authplugins.size() > 1 and filter_ports.size() > 1) {
+ std::deque<Plugin*>::iterator it = authplugins.begin();
+ String firstPlugin;
+ bool sslused = false;