aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2013-10-25 12:27:53 +0000
committerSteve Wills <swills@FreeBSD.org>2013-10-25 12:27:53 +0000
commit523ab18cbc9e501c7167bb91b95bd33038a4eb03 (patch)
treeeac7e29f8b64ae1a5d393dfcdbeafbde647905f0 /www
parent2cf11697f1f887898d44af4fba3eb18ad9ec8802 (diff)
downloadports-523ab18cbc9e501c7167bb91b95bd33038a4eb03.tar.gz
ports-523ab18cbc9e501c7167bb91b95bd33038a4eb03.zip
Haml-rails provides Haml generators for Rails 3. It also enables Haml as the
templating engine for you, so you don't have to screw around in your own application.rb when your Gemfile already clearly indicated what templating engine you have installed. Hurrah. WWW: http://github.com/indirect/haml-rails PR: ports/183292 Submitted by: Loic Blot <loic.blot@unix-experience.fr>
Notes
Notes: svn path=/head/; revision=331570
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/rubygem-haml-rails/Makefile22
-rw-r--r--www/rubygem-haml-rails/distinfo2
-rw-r--r--www/rubygem-haml-rails/pkg-descr6
4 files changed, 31 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 9c05df127626..7e97bee7cb4d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1765,6 +1765,7 @@
SUBDIR += rubygem-gon
SUBDIR += rubygem-haml
SUBDIR += rubygem-haml-coderay
+ SUBDIR += rubygem-haml-rails
SUBDIR += rubygem-hpricot
SUBDIR += rubygem-http-cookie
SUBDIR += rubygem-httparty
diff --git a/www/rubygem-haml-rails/Makefile b/www/rubygem-haml-rails/Makefile
new file mode 100644
index 000000000000..9d71bc9b81f3
--- /dev/null
+++ b/www/rubygem-haml-rails/Makefile
@@ -0,0 +1,22 @@
+# $FreeBSD$
+
+PORTNAME= haml-rails
+PORTVERSION= 0.4
+CATEGORIES= www rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Haml generator for Rails
+
+RUN_DEPENDS= rubygem-actionpack>=3.1:${PORTSDIR}/www/rubygem-actionpack \
+ rubygem-activesupport>=3.1:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-haml>=3.1:${PORTSDIR}/www/rubygem-haml \
+ rubygem-railties>=3.1:${PORTSDIR}/www/rubygem-railties
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/www/rubygem-haml-rails/distinfo b/www/rubygem-haml-rails/distinfo
new file mode 100644
index 000000000000..f6448bf9b6d6
--- /dev/null
+++ b/www/rubygem-haml-rails/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/haml-rails-0.4.gem) = a2c13b66d37aaf10d3d4cdf7a133a72dd7024b943a799cdae963bc0ce6198308
+SIZE (rubygem/haml-rails-0.4.gem) = 8704
diff --git a/www/rubygem-haml-rails/pkg-descr b/www/rubygem-haml-rails/pkg-descr
new file mode 100644
index 000000000000..e5e522d7b0c1
--- /dev/null
+++ b/www/rubygem-haml-rails/pkg-descr
@@ -0,0 +1,6 @@
+Haml-rails provides Haml generators for Rails 3. It also enables Haml as the
+templating engine for you, so you don't have to screw around in your own
+application.rb when your Gemfile already clearly indicated what templating
+engine you have installed. Hurrah.
+
+WWW: http://github.com/indirect/haml-rails