aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2004-03-30 17:43:43 +0000
committerThierry Thomas <thierry@FreeBSD.org>2004-03-30 17:43:43 +0000
commitc4c7c2af79c46baa2fb1b55a27e1536ccfd1b13c (patch)
tree89509f99c0fea38514276e41fe95d5c62c73f58d /www
parent74737009a097703a789a8c7ab04c5ccea1e1b97a (diff)
downloadports-c4c7c2af79c46baa2fb1b55a27e1536ccfd1b13c.tar.gz
ports-c4c7c2af79c46baa2fb1b55a27e1536ccfd1b13c.zip
Make some cleaning in this old port:
- is no more interactive, since PHP4 with PEAR is built with XML; - switch dependence from www/mod_php4 to lang/php4-horde; - chase expat version; - use %%PORTDOCS%% and make portlint happy; - add a missing pkg-deinstall; - finally mark it "IGNORE" because it does not perform well with www/horde2. Don't remove it because a new release is expected with Horde3. Reported by: Troy and Massimiliano Stucchi. Approved by: mat (mentor).
Notes
Notes: svn path=/head/; revision=105717
Diffstat (limited to 'www')
-rw-r--r--www/jonah/Makefile7
-rw-r--r--www/jonah/pkg-deinstall27
-rw-r--r--www/jonah/pkg-plist14
3 files changed, 38 insertions, 10 deletions
diff --git a/www/jonah/Makefile b/www/jonah/Makefile
index 2770c623241b..1e540bc3330a 100644
--- a/www/jonah/Makefile
+++ b/www/jonah/Makefile
@@ -17,9 +17,10 @@ COMMENT= Jonah is a portal and content collection system
WRKSRC= ${WRKDIR}/${PORTNAME}
RUN_DEPENDS= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde2 \
- ${LOCALBASE}/bin/php:${PORTSDIR}/www/mod_php4
+ ${LOCALBASE}/bin/php:${PORTSDIR}/lang/php4-horde
+
+IGNORE= "Does not run with Horde 2.x"
-IS_INTERACTIVE= 'need to build php4 with XML support.'
NO_BUILD= yes
USE_REINPLACE= yes
@@ -46,7 +47,7 @@ HORDE_CNF= ${HORDEDIR}/config/horde.php
PHPSA_INI= ${PHPSADIR}/php.ini
pre-install:
- @if ! ${LDCONFIG} -r | ${GREP} -q -e "expat.2"; then \
+ @if ! ${LDCONFIG} -r | ${GREP} -q -e "expat.5"; then \
${ECHO_MSG} "" ; \
${ECHO_MSG} "Please configure PHP with XML support." ; \
${ECHO_MSG} "" ; \
diff --git a/www/jonah/pkg-deinstall b/www/jonah/pkg-deinstall
new file mode 100644
index 000000000000..2984a16bd66c
--- /dev/null
+++ b/www/jonah/pkg-deinstall
@@ -0,0 +1,27 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# Backup Jonah config files, if needed.
+
+if [ x$2 != xDEINSTALL ]; then
+ exit
+fi
+
+if [ -z "${PACKAGE_BUILDING}" ]; then
+ for cf in `ls ${PKG_PREFIX}/www/horde/jonah/config/*php`; do
+ diff -bBqw $cf $cf.dist >/dev/null 2>&1
+ case $? in
+ 0) # original config file, will be deleted by pkg-plist
+ ;;
+ 1) # config file has been updated, must be backuped
+ cp -p $cf $cf.previous
+ echo "===> Backing-up..."
+ echo "---> $cf has been saved ***"
+ echo "---> as $cf.previous ***"
+ ;;
+ *) # not found?
+ ;;
+ esac
+ done
+fi
diff --git a/www/jonah/pkg-plist b/www/jonah/pkg-plist
index e60149c64525..0a4de6a41c5b 100644
--- a/www/jonah/pkg-plist
+++ b/www/jonah/pkg-plist
@@ -1,9 +1,9 @@
-%%PORTDOCS%%share/doc/jonah/CHANGES
-%%PORTDOCS%%share/doc/jonah/COPYING
-%%PORTDOCS%%share/doc/jonah/CREDITS
-%%PORTDOCS%%share/doc/jonah/HELP
-%%PORTDOCS%%share/doc/jonah/INSTALL
-%%PORTDOCS%%share/doc/jonah/README
+%%PORTDOCS%%%%DOCSDIR%%/CHANGES
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/CREDITS
+%%PORTDOCS%%%%DOCSDIR%%/HELP
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/README
%%JONAHDIR%%/backend.php
%%JONAHDIR%%/channels.php
%%JONAHDIR%%/config/channels.php
@@ -65,7 +65,7 @@ etc/horde/httpd.conf.jonah
@dirrm %%JONAHDIR%%/templates/index
@dirrm %%JONAHDIR%%/templates
@dirrm %%JONAHDIR%%
-%%PORTDOCS%%@dirrm share/doc/jonah
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@unexec if cmp -s %D/www/horde/config/registry.php %D/www/horde/config/registry.php.afterJonah; then rm -f %D/www/horde/config/registry.php.afterJonah; mv %D/www/horde/config/registry.php.beforeJonah %D/www/horde/config/registry.php; fi
@unexec if cmp -s %D/www/horde/config/horde.php %D/www/horde/config/horde.php.afterJonah; then rm -f %D/www/horde/config/horde.php.afterJonah; mv %D/www/horde/config/horde.php.beforeJonah %D/www/horde/config/horde.php; fi
@unexec if cmp -s %D/etc/php.standalone/php.ini %D/etc/php.standalone/php.ini.afterJonah; then rm -f %D/etc/php.standalone/php.ini.afterJonah; mv %D/etc/php.standalone/php.ini.beforeJonah %D/etc/php.standalone/php.ini; fi