aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2004-04-16 20:08:19 +0000
committerMikhail Teterin <mi@FreeBSD.org>2004-04-16 20:08:19 +0000
commit5fc2d96054789e328547b92a19b0908a446dadba (patch)
treee9831a98da5e41f9a47f512922fe5c98b733b7fe /www
parent52fc6525910b1699dc2c025709783c4a900546c9 (diff)
downloadports-5fc2d96054789e328547b92a19b0908a446dadba.tar.gz
ports-5fc2d96054789e328547b92a19b0908a446dadba.zip
Default to Tcl-8.4, as neotcl and tclX do now.
Prompted by: kris
Notes
Notes: svn path=/head/; revision=107266
Diffstat (limited to 'www')
-rw-r--r--www/neowebscript/Makefile12
-rw-r--r--www/neowebscript/files/Makefile.lib2
2 files changed, 9 insertions, 5 deletions
diff --git a/www/neowebscript/Makefile b/www/neowebscript/Makefile
index ddf18ffd303d..8b08303a3ffa 100644
--- a/www/neowebscript/Makefile
+++ b/www/neowebscript/Makefile
@@ -7,7 +7,7 @@
PORTNAME= neowebscript
PORTVERSION= 3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= www tcl83
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR=nws
@@ -20,8 +20,11 @@ LIB_DEPENDS= neo82:${PORTSDIR}/devel/tcl-neo
MAKEFILE= ${FILESDIR}/Makefile.bsd
WRKSRC= ${WRKDIR}/${DISTNAME}/modules
+TCL_VERSION?= 8.4
MAKE_ENV+= FILESDIR="${FILESDIR}" INSTALL_DATA="${INSTALL_DATA}"
-USE_PERL5_BUILD=yes
+MAKE_ENV+= TCL_VERSION=${TCL_VERSION}
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
SUBDIRS= modules neowebscript htdocs # tools
@@ -31,8 +34,9 @@ EXTRACT_AFTER_ARGS:=| ${TAR} -xf - ${SUBDIRS:%=${PORTNAME}-${PORTVERSION}/%}
post-patch:
# Replacing writeGIF with writePNG
- ${PERL} -pi -e 's/writeGIF/writePNG/g' \
- `${FIND} ${WRKSRC}/.. -type f|${XARGS} fgrep -l --mmap writeGIF`
+ ${REINPLACE_CMD} 's/writeGIF/writePNG/g' \
+ `${FIND} ${WRKSRC}/.. -type f | \
+ ${XARGS} ${GREP} -F -l --mmap writeGIF`
pre-install:
# Removing *.orig files and empty directories:
diff --git a/www/neowebscript/files/Makefile.lib b/www/neowebscript/files/Makefile.lib
index 388c5da451e4..4a605e70badb 100644
--- a/www/neowebscript/files/Makefile.lib
+++ b/www/neowebscript/files/Makefile.lib
@@ -1,4 +1,4 @@
-TCL_VERSION?=8.3
+TCL_VERSION?=8.4
TCL_NDVER?=${TCL_VERSION:S/.//} # same, but without the dot
PREFIX?= /usr/local