aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2004-04-16 13:29:29 +0000
committerClement Laforet <clement@FreeBSD.org>2004-04-16 13:29:29 +0000
commita15906aee6164b16e267bfecc1e7f4b02d09255a (patch)
treea37c25bb6cb40ad699fd6216dde3c28419657592 /www
parent29b87cde37f78308cd5f8651a29951d8a700fb37 (diff)
downloadports-a15906aee6164b16e267bfecc1e7f4b02d09255a.tar.gz
ports-a15906aee6164b16e267bfecc1e7f4b02d09255a.zip
Remove noisy apache version detection
Notes
Notes: svn path=/head/; revision=107222
Diffstat (limited to 'www')
-rw-r--r--www/apache2/Makefile.modules.3rd14
-rw-r--r--www/apache20/Makefile.modules.3rd14
2 files changed, 6 insertions, 22 deletions
diff --git a/www/apache2/Makefile.modules.3rd b/www/apache2/Makefile.modules.3rd
index 7c788bded38a..c2c5c982557d 100644
--- a/www/apache2/Makefile.modules.3rd
+++ b/www/apache2/Makefile.modules.3rd
@@ -26,19 +26,13 @@ BROKEN= "This module require apache13 and you have apache2 installed"
. endif
.elif exists(${LOCALBASE}/include/apache/http_core.h)
WITH_APACHE13= YES
-.if exists(${LOCALBASE}/sbin/pkg_info)
-PKGINFO= ${LOCALBASE}/sbin/pkg_info
-.else
-PKGINFO= /usr/sbin/pkg_info
-.endif
-APACHE_PORT!= ${PKGINFO} -qo `${PKGINFO} -qW /usr/local/include/apache/http_core.h `
. if defined (WANT_APACHE)
. if ${WANT_APACHE} == 2
-BROKEN= "This module require apache2 and you have ${APACHE_PORT} installed"
+BROKEN= "This module require apache2 and you have apache13 installed"
. endif
. endif
. ifdef(WITH_APACHE2)
-.error You have `WITH_APACHE2' variable defined either in environment or in make(1) argumentsm. but ${APACHE_PORT} is installed Please undefine and try again.
+.error You have `WITH_APACHE2' variable defined either in environment or in make(1) argumentsm. but apache13 is installed Please undefine and try again.
. endif
.endif
@@ -60,9 +54,7 @@ AP_VER= 2
.else
AP_BUILDEXT= so
PLIST_SUB+= APACHEMODDIR="libexec/apache"
-. if !defined(APACHE_PORT)
-APACHE_PORT= www/apache13
-. endif
+APACHE_PORT?= www/apache13
AP_VER= 13
.endif
diff --git a/www/apache20/Makefile.modules.3rd b/www/apache20/Makefile.modules.3rd
index 7c788bded38a..c2c5c982557d 100644
--- a/www/apache20/Makefile.modules.3rd
+++ b/www/apache20/Makefile.modules.3rd
@@ -26,19 +26,13 @@ BROKEN= "This module require apache13 and you have apache2 installed"
. endif
.elif exists(${LOCALBASE}/include/apache/http_core.h)
WITH_APACHE13= YES
-.if exists(${LOCALBASE}/sbin/pkg_info)
-PKGINFO= ${LOCALBASE}/sbin/pkg_info
-.else
-PKGINFO= /usr/sbin/pkg_info
-.endif
-APACHE_PORT!= ${PKGINFO} -qo `${PKGINFO} -qW /usr/local/include/apache/http_core.h `
. if defined (WANT_APACHE)
. if ${WANT_APACHE} == 2
-BROKEN= "This module require apache2 and you have ${APACHE_PORT} installed"
+BROKEN= "This module require apache2 and you have apache13 installed"
. endif
. endif
. ifdef(WITH_APACHE2)
-.error You have `WITH_APACHE2' variable defined either in environment or in make(1) argumentsm. but ${APACHE_PORT} is installed Please undefine and try again.
+.error You have `WITH_APACHE2' variable defined either in environment or in make(1) argumentsm. but apache13 is installed Please undefine and try again.
. endif
.endif
@@ -60,9 +54,7 @@ AP_VER= 2
.else
AP_BUILDEXT= so
PLIST_SUB+= APACHEMODDIR="libexec/apache"
-. if !defined(APACHE_PORT)
-APACHE_PORT= www/apache13
-. endif
+APACHE_PORT?= www/apache13
AP_VER= 13
.endif