aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-03 08:14:43 +0000
commitdbba8af6447e625aae93ec45e619acbecb4ab189 (patch)
treed696a8c2d3e835a743132aa1f6a5cc0557d1c435 /www
parent683eaaa4ff765b627c52f147501abfaec4449cce (diff)
downloadports-dbba8af6447e625aae93ec45e619acbecb4ab189.tar.gz
ports-dbba8af6447e625aae93ec45e619acbecb4ab189.zip
Overhaul QT/KDE support:
- bsd.port.mk update to use bsd.kde.mk for USE_{QT,KDE}* - Cleanup corresponding ports for bsd.kde.mk update. - Fix bsd.kde.mk: use correct kdelibs dependency, put qt at the bottom, introduce QT_NONSTANDARD variable for nonstandard configure setup. - Update KDE2 to 2.1.1. Two patches included in x11/kdelibs2 to fix the proxy authentication that was broken for 2.1.1. Remove old patches. - Potentially fix kdelibs build for alpha. - Fix qt-designer 2.3.0 build. - Ruby stuff left alone since it looks like black magic to me. Should still work w/ compat shims for older USE_QT[,2] style. Some others were also left alone for the same reason. Reviewed by: portmgr, ports (bsd.kde.mk+bsd.port.mk) Submitted by: David Faure <faure@kde.org> (proxy auth patches) Alex Zepeda <garbanzo@kde.org> (old patches removal)
Notes
Notes: svn path=/head/; revision=40792
Diffstat (limited to 'www')
-rw-r--r--www/kdewebdev/Makefile15
-rw-r--r--www/kdewebdev4/Makefile15
-rw-r--r--www/kdreamsite/Makefile4
-rw-r--r--www/kwebsearch/Makefile3
-rw-r--r--www/kwebwatch/Makefile7
-rw-r--r--www/quanta/Makefile15
6 files changed, 12 insertions, 47 deletions
diff --git a/www/kdewebdev/Makefile b/www/kdewebdev/Makefile
index 58217d55e780..a2538b801d76 100644
--- a/www/kdewebdev/Makefile
+++ b/www/kdewebdev/Makefile
@@ -21,25 +21,16 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= jeremy@external.org
-LIB_DEPENDS= kdeui.4:${PORTSDIR}/x11/kdelibs2 \
- intl.1:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_XPM= yes
USE_BZIP2= yes
-USE_NEWGCC= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-libs=${LOCALBASE}/lib \
- --with-extra-includes=${LOCALBASE}/include \
+CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
--disable-closure
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
USE_GMAKE= yes
DOCS= css html javascript php
diff --git a/www/kdewebdev4/Makefile b/www/kdewebdev4/Makefile
index 58217d55e780..a2538b801d76 100644
--- a/www/kdewebdev4/Makefile
+++ b/www/kdewebdev4/Makefile
@@ -21,25 +21,16 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= jeremy@external.org
-LIB_DEPENDS= kdeui.4:${PORTSDIR}/x11/kdelibs2 \
- intl.1:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_XPM= yes
USE_BZIP2= yes
-USE_NEWGCC= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-libs=${LOCALBASE}/lib \
- --with-extra-includes=${LOCALBASE}/include \
+CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
--disable-closure
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
USE_GMAKE= yes
DOCS= css html javascript php
diff --git a/www/kdreamsite/Makefile b/www/kdreamsite/Makefile
index 56bf44416610..86d9ea4769f8 100644
--- a/www/kdreamsite/Makefile
+++ b/www/kdreamsite/Makefile
@@ -12,9 +12,7 @@ MASTER_SITES= http://neptune.spaceports.com/%7Eatnet/files/
MAINTAINER= ports@FreeBSD.org
-LIB_DEPENDS= kdeui.3:${PORTSDIR}/x11/kdelibs11/
-
-USE_QT= yes
+USE_KDELIBS_VER=1
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/www/kwebsearch/Makefile b/www/kwebsearch/Makefile
index c1ac190ec7ac..2fcd0775d414 100644
--- a/www/kwebsearch/Makefile
+++ b/www/kwebsearch/Makefile
@@ -13,9 +13,8 @@ MASTER_SITES= http://www.guruz.de/
MAINTAINER= ports@FreeBSD.org
BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11
-USE_QT= yes
+USE_KDELIBS_VER=1
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= QTDIR="${X11BASE}" KDEDIR="${LOCALBASE}"
diff --git a/www/kwebwatch/Makefile b/www/kwebwatch/Makefile
index 168a91a86ce2..9b757ceb7ff7 100644
--- a/www/kwebwatch/Makefile
+++ b/www/kwebwatch/Makefile
@@ -12,13 +12,8 @@ MASTER_SITES= http://linuxberg.uol.com.br/files/kde/network/
MAINTAINER= lioux@FreeBSD.org
-LIB_DEPENDS= kdecore.3:${PORTSDIR}/x11/kdelibs11 \
- kdeui.3:${PORTSDIR}/x11/kdelibs11 \
- kfile.3:${PORTSDIR}/x11/kdelibs11 \
- kfm.3:${PORTSDIR}/x11/kdelibs11
-
+USE_KDELIBS_VER=1
USE_XLIB= yes
-USE_QT= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/www/quanta/Makefile b/www/quanta/Makefile
index 58217d55e780..a2538b801d76 100644
--- a/www/quanta/Makefile
+++ b/www/quanta/Makefile
@@ -21,25 +21,16 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
MAINTAINER= jeremy@external.org
-LIB_DEPENDS= kdeui.4:${PORTSDIR}/x11/kdelibs2 \
- intl.1:${PORTSDIR}/devel/gettext
+LIB_DEPENDS= intl.1:${PORTSDIR}/devel/gettext
WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_QT2= yes
-MOC?= ${X11BASE}/bin/moc2
+USE_KDELIBS_VER=2
USE_XPM= yes
USE_BZIP2= yes
-USE_NEWGCC= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-qt-includes=${X11BASE}/include/qt2 \
- --with-qt-libraries=${X11BASE}/lib \
- --with-extra-libs=${LOCALBASE}/lib \
- --with-extra-includes=${LOCALBASE}/include \
+CONFIGURE_ARGS+= --with-extra-includes=${LOCALBASE}/include \
--disable-closure
-CONFIGURE_ENV+= MOC="${MOC}" LIBQT="-lqt2" LIBQTFILE="libqt2" \
- CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-Wl,-export-dynamic -L${LOCALBASE}/lib -ljpeg -lstdc++ -lgcc ${PTHREAD_LIBS}"
USE_GMAKE= yes
DOCS= css html javascript php