aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorErnst de Haan <znerd@FreeBSD.org>2002-03-29 12:54:15 +0000
committerErnst de Haan <znerd@FreeBSD.org>2002-03-29 12:54:15 +0000
commit0ff2aadb8a842a6e7b59c1a268e40bdbd18c02ff (patch)
tree29e65249b06abba5056bfe5352bdf658b5b8940b /www
parentbe91b104d3781fd869151e7ddc5d54ef166c4bcd (diff)
downloadports-0ff2aadb8a842a6e7b59c1a268e40bdbd18c02ff.tar.gz
ports-0ff2aadb8a842a6e7b59c1a268e40bdbd18c02ff.zip
Improved startup script. It now creates the PID file and fixes
the ownership and permissions before actually calling the orionctl program. Bumped PORTREVISION.
Notes
Notes: svn path=/head/; revision=56866
Diffstat (limited to 'www')
-rw-r--r--www/orion-devel/Makefile2
-rw-r--r--www/orion-devel/files/orion.sh13
-rw-r--r--www/orion/Makefile2
-rw-r--r--www/orion/files/orion.sh13
4 files changed, 28 insertions, 2 deletions
diff --git a/www/orion-devel/Makefile b/www/orion-devel/Makefile
index bcfb92e8526d..ba06e3b04b6b 100644
--- a/www/orion-devel/Makefile
+++ b/www/orion-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orion
PORTVERSION= 1.5.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= www java
MASTER_SITES= http://www.orionserver.com/distributions/ \
http://www.atlassian.com/software/orion/downloads/ \
diff --git a/www/orion-devel/files/orion.sh b/www/orion-devel/files/orion.sh
index 2bff6366dd1a..6627cfbda27f 100644
--- a/www/orion-devel/files/orion.sh
+++ b/www/orion-devel/files/orion.sh
@@ -1,13 +1,26 @@
#!/bin/sh
+# -*- mode: Fundamental; tab-width: 4; -*-
+# ex:ts=4
+#
+# Orion startup script.
+#
+# $FreeBSD$
+#
+
# Set some variables
MYSELF=`basename $0`
case "$1" in
start)
+ truncate -s 0 %%PID_FILE%%
+ chown %%USER%%:%%GROUP%% %%PID_FILE%%
+ chmod 600 %%PID_FILE%%
su -f -m %%USER%% -c "exec %%CONTROL_SCRIPT%% start > /dev/null" && echo -n ' %%APP_SHORTNAME%%'
;;
stop)
+ chown %%USER%%:%%GROUP%% %%PID_FILE%%
+ chmod 600 %%PID_FILE%%
su -f -m %%USER%% -c "exec %%CONTROL_SCRIPT%% stop > /dev/null" && echo -n ' %%APP_SHORTNAME%%'
;;
*)
diff --git a/www/orion/Makefile b/www/orion/Makefile
index bcfb92e8526d..ba06e3b04b6b 100644
--- a/www/orion/Makefile
+++ b/www/orion/Makefile
@@ -7,7 +7,7 @@
PORTNAME= orion
PORTVERSION= 1.5.2
-PORTREVISION= 12
+PORTREVISION= 13
CATEGORIES= www java
MASTER_SITES= http://www.orionserver.com/distributions/ \
http://www.atlassian.com/software/orion/downloads/ \
diff --git a/www/orion/files/orion.sh b/www/orion/files/orion.sh
index 2bff6366dd1a..6627cfbda27f 100644
--- a/www/orion/files/orion.sh
+++ b/www/orion/files/orion.sh
@@ -1,13 +1,26 @@
#!/bin/sh
+# -*- mode: Fundamental; tab-width: 4; -*-
+# ex:ts=4
+#
+# Orion startup script.
+#
+# $FreeBSD$
+#
+
# Set some variables
MYSELF=`basename $0`
case "$1" in
start)
+ truncate -s 0 %%PID_FILE%%
+ chown %%USER%%:%%GROUP%% %%PID_FILE%%
+ chmod 600 %%PID_FILE%%
su -f -m %%USER%% -c "exec %%CONTROL_SCRIPT%% start > /dev/null" && echo -n ' %%APP_SHORTNAME%%'
;;
stop)
+ chown %%USER%%:%%GROUP%% %%PID_FILE%%
+ chmod 600 %%PID_FILE%%
su -f -m %%USER%% -c "exec %%CONTROL_SCRIPT%% stop > /dev/null" && echo -n ' %%APP_SHORTNAME%%'
;;
*)