aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-03-20 10:00:37 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-03-20 10:00:37 +0000
commita1807bcfe56b6446dd8fe5d6176917ca78afd940 (patch)
tree40a897a6d737ecd4425c34ca3ca7526f1018a149 /www
parent9fc1c4fe89616480338adc0d98d5b1f0e4175302 (diff)
downloadports-a1807bcfe56b6446dd8fe5d6176917ca78afd940.tar.gz
ports-a1807bcfe56b6446dd8fe5d6176917ca78afd940.zip
Red5 is an Open Source Flash Server written
in Java that supports streaming Audio/Video (FLV and MP3),Recording Client Streams, Live Stream Publishing, etc. WWW: http://www.red5.fr/ PR: 121696 Submitted by: Wen heping <wenheping@gmail.com> Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=209421
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/red5/Makefile59
-rw-r--r--www/red5/distinfo3
-rw-r--r--www/red5/pkg-descr6
-rw-r--r--www/red5/pkg-message3
5 files changed, 72 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 705a5cc933fa..f8cb956ad92b 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1124,6 +1124,7 @@
SUBDIR += quickie
SUBDIR += quixote
SUBDIR += raqdevil
+ SUBDIR += red5
SUBDIR += rejik
SUBDIR += reportmagic
SUBDIR += resin2
diff --git a/www/red5/Makefile b/www/red5/Makefile
new file mode 100644
index 000000000000..e2aa7bff8778
--- /dev/null
+++ b/www/red5/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: devel/red5
+# Date created: 14 March 2008
+# Whom: wenheping@gmail.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= red5
+PORTVERSION= 0.7.0
+CATEGORIES= www java
+MASTER_SITES= http://www.nielsenaa.com/red5-installers/ \
+ http://www.red5.fr/release/0.7.0/war/
+DISTNAME= Red5War_${PORTVERSION}-java5
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= Red5 is an Open Source flash server
+
+OPTIONS= TOMCAT4 "Use Tomcat 4.1" OFF \
+ TOMCAT5 "Use Tomcat 5.5" OFF \
+ TOMCAT6 "Use Tomcat 6.0" ON
+
+WRKSRC= ${WRKDIR}
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.5
+NO_BUILD= yes
+
+.include <bsd.port.pre.mk>
+
+.if (defined(WITH_TOMCAT4) && defined(WITH_TOMCAT5)) || \
+ (defined(WITH_TOMCAT4) && defined(WITH_TOMCAT6)) || \
+ (defined(WITH_TOMCAT5) && defined(WITH_TOMCAT6))
+IGNORE= please select only one version of Tomcat
+.endif
+
+.if defined(WITH_TOMCAT4)
+RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat4.1:${PORTSDIR}/www/tomcat41
+WEBAPPDIR= ${PREFIX}/apache-tomcat4.1/webapps
+.elif defined(WITH_TOMCAT5)
+RUN_DEPENDS+= ${LOCALBASE}/tomcat5.5:${PORTSDIR}/www/tomcat55
+WEBAPPDIR= ${PREFIX}/tomcat5.5/webapps
+.elif defined(WITH_TOMCAT6)
+RUN_DEPENDS+= ${LOCALBASE}/apache-tomcat6.0:${PORTSDIR}/www/tomcat6
+WEBAPPDIR= ${PREFIX}/apache-tomcat6.0/webapps
+.else
+IGNORE= please select one version of Tomcat
+.endif
+
+PLIST_FILES= ${WEBAPPDIR:S|^${PREFIX}/||}/red5.war
+
+do-install:
+ @${MKDIR} ${WEBAPPDIR}
+ @${INSTALL_DATA} ${WRKSRC}/ROOT.war ${WEBAPPDIR}/red5.war
+ @${CHOWN} ${WWWOWN}:${WWWGRP} ${WEBAPPDIR}/red5.war
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/www/red5/distinfo b/www/red5/distinfo
new file mode 100644
index 000000000000..2ff90df3402c
--- /dev/null
+++ b/www/red5/distinfo
@@ -0,0 +1,3 @@
+MD5 (Red5War_0.7.0-java5.zip) = 88cd86aff8a50f35e8a4d07cb210bd0d
+SHA256 (Red5War_0.7.0-java5.zip) = 058d2be8ae20d567cf92be1edd02332532f0ca32b56365b8ae5302f086068946
+SIZE (Red5War_0.7.0-java5.zip) = 20335816
diff --git a/www/red5/pkg-descr b/www/red5/pkg-descr
new file mode 100644
index 000000000000..48b793ec0086
--- /dev/null
+++ b/www/red5/pkg-descr
@@ -0,0 +1,6 @@
+Red5 is an Open Source Flash Server written
+in Java that supports streaming Audio/Video
+(FLV and MP3),Recording Client Streams,
+Live Stream Publishing, etc.
+
+WWW: http://www.red5.fr/
diff --git a/www/red5/pkg-message b/www/red5/pkg-message
new file mode 100644
index 000000000000..3844b985e726
--- /dev/null
+++ b/www/red5/pkg-message
@@ -0,0 +1,3 @@
+=====================================
+Now start your Tomcat and browse with:
+http://your-server-ip:8180/red5/