aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-25 20:17:37 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-05-25 20:17:37 +0000
commit335f8cb35dd36e692a9ce203d40fe51d20a91902 (patch)
tree3990cbde7632e9eec02627fd861d5429bf51dae9 /www
parent3425efcfd407a2d46781e373a6e8d9b22fcbd717 (diff)
downloadports-335f8cb35dd36e692a9ce203d40fe51d20a91902.tar.gz
ports-335f8cb35dd36e692a9ce203d40fe51d20a91902.zip
Mk/bsd.apache.mk can not sufficiently alter things before Mk/bsd.options.mk
in Mk/bsd.ports.mk due to ordering in Mk/bsd.port.mk. This causes OPTIONSFILE to be incorrectly set during some make phases as a result of the recent PKGNAMEPREFIX for apache ports. 'Revert' some of the PKGNAMEPREFIX changes for apXX-. - Must be manually requested in tbe port Makefile either by a) AP_FAST_BUILD=yes b) PKGNAMEPREFIX=${APACHE_PKGNAMEPREFIX} - Going forward, we will only do this for ports where WITH_APACHE is NOT optional, but required. mod_* ports are a good fit. 141 ports are mod_ ports 80 of those use AP_FAST_BUILD and thus are auto hooked by this patch [a]. 61 remaining are then patched to mirror the other $lang frameworks [b]. PR: ports/146956 Reported by: Hans F. Nordhaug <Hans.F.Nordhaug@hiMolde.no>, several Discussed with: pav, itectu on #bsdports Tested by: P6 TB run Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=255075
Diffstat (limited to 'www')
-rw-r--r--www/mod_accounting/Makefile1
-rw-r--r--www/mod_auth_form/Makefile1
-rw-r--r--www/mod_auth_kerb/Makefile1
-rw-r--r--www/mod_auth_kerb2/Makefile1
-rw-r--r--www/mod_auth_mysql/Makefile1
-rw-r--r--www/mod_auth_openid/Makefile1
-rw-r--r--www/mod_auth_pam2/Makefile1
-rw-r--r--www/mod_auth_pgsql/Makefile1
-rw-r--r--www/mod_auth_pubtkt/Makefile1
-rw-r--r--www/mod_auth_xradius/Makefile1
-rw-r--r--www/mod_backhand/Makefile1
-rw-r--r--www/mod_bandwidth/Makefile1
-rw-r--r--www/mod_cband/Makefile1
-rw-r--r--www/mod_clamav/Makefile1
-rw-r--r--www/mod_cplusplus/Makefile1
-rw-r--r--www/mod_cvs2/Makefile1
-rw-r--r--www/mod_dav/Makefile1
-rw-r--r--www/mod_dnssd/Makefile1
-rw-r--r--www/mod_dtcl/Makefile1
-rw-r--r--www/mod_encoding/Makefile1
-rw-r--r--www/mod_fcgid/Makefile1
-rw-r--r--www/mod_fileiri/Makefile1
-rw-r--r--www/mod_gzip/Makefile1
-rw-r--r--www/mod_h264_streaming/Makefile1
-rw-r--r--www/mod_jk/Makefile1
-rw-r--r--www/mod_layout/Makefile1
-rw-r--r--www/mod_layout2/Makefile1
-rw-r--r--www/mod_layout22/Makefile1
-rw-r--r--www/mod_limitipconn/Makefile1
-rw-r--r--www/mod_limitipconn2/Makefile1
-rw-r--r--www/mod_line_edit/Makefile1
-rw-r--r--www/mod_log_dbd/Makefile1
-rw-r--r--www/mod_log_firstbyte/Makefile1
-rw-r--r--www/mod_log_sql/Makefile1
-rw-r--r--www/mod_log_sql2-dtc/Makefile1
-rw-r--r--www/mod_log_sql2/Makefile1
-rw-r--r--www/mod_memcache/Makefile1
-rw-r--r--www/mod_mono/Makefile1
-rw-r--r--www/mod_mp3/Makefile1
-rw-r--r--www/mod_musicindex/Makefile1
-rw-r--r--www/mod_ntlm/Makefile1
-rw-r--r--www/mod_ntlm2/Makefile1
-rw-r--r--www/mod_perl/Makefile1
-rw-r--r--www/mod_perl2/Makefile1
-rw-r--r--www/mod_proctitle/Makefile1
-rw-r--r--www/mod_proxy_xml/Makefile1
-rw-r--r--www/mod_pubcookie/Makefile2
-rw-r--r--www/mod_python/Makefile1
-rw-r--r--www/mod_python3/Makefile1
-rw-r--r--www/mod_ruby/Makefile1
-rw-r--r--www/mod_scgi/Makefile2
-rw-r--r--www/mod_security/Makefile1
-rw-r--r--www/mod_sed/Makefile1
-rw-r--r--www/mod_transform/Makefile1
-rw-r--r--www/mod_webapp/Makefile1
-rw-r--r--www/mod_wsgi/Makefile1
-rw-r--r--www/mod_wsgi3/Makefile1
-rw-r--r--www/mod_xmlns/Makefile1
58 files changed, 58 insertions, 2 deletions
diff --git a/www/mod_accounting/Makefile b/www/mod_accounting/Makefile
index 7b2ca76242a4..bdc591e29633 100644
--- a/www/mod_accounting/Makefile
+++ b/www/mod_accounting/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.5
PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= SF/mod-acct/mod-acct/${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= An Apache module that records traffic statistics into a database
diff --git a/www/mod_auth_form/Makefile b/www/mod_auth_form/Makefile
index 90673a9c8140..e9ff3acb7b26 100644
--- a/www/mod_auth_form/Makefile
+++ b/www/mod_auth_form/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_auth_form
PORTVERSION= 2.05
CATEGORIES= www
MASTER_SITES= http://comp.uark.edu/~ajarthu/mod_auth_form/download.php?download=v2_05/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
MAINTAINER= net@arrishq.net
diff --git a/www/mod_auth_kerb/Makefile b/www/mod_auth_kerb/Makefile
index 4b67a6b16492..355bc51d6670 100644
--- a/www/mod_auth_kerb/Makefile
+++ b/www/mod_auth_kerb/Makefile
@@ -12,6 +12,7 @@ PORTVERSION= 5.3
PORTEPOCH= 1
CATEGORIES= www
MASTER_SITES= SF/modauthkerb/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= An Apache module for authenticating users with Kerberos v5
diff --git a/www/mod_auth_kerb2/Makefile b/www/mod_auth_kerb2/Makefile
index 964f7d4f3926..a04aa1d5092e 100644
--- a/www/mod_auth_kerb2/Makefile
+++ b/www/mod_auth_kerb2/Makefile
@@ -12,6 +12,7 @@ PORTNAME= mod_auth_kerb
PORTVERSION= 5.4
CATEGORIES= www
MASTER_SITES= SF/modauthkerb/${PORTNAME}/${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= An Apache module for authenticating users with Kerberos v5
diff --git a/www/mod_auth_mysql/Makefile b/www/mod_auth_mysql/Makefile
index 9e3180fe5414..cad77edab06e 100644
--- a/www/mod_auth_mysql/Makefile
+++ b/www/mod_auth_mysql/Makefile
@@ -8,6 +8,7 @@ PORTNAME= mod_auth_mysql
PORTVERSION= 3.2
CATEGORIES= www
MASTER_SITES= SF/mod-auth-mysql/mod-auth-mysql/mod-auth-mysql-1.0
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows users to use MySQL databases for user authentication
diff --git a/www/mod_auth_openid/Makefile b/www/mod_auth_openid/Makefile
index a5d6d2331b69..e486d614aec6 100644
--- a/www/mod_auth_openid/Makefile
+++ b/www/mod_auth_openid/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_auth_openid
PORTVERSION= 0.4
CATEGORIES= www
MASTER_SITES= http://butterfat.net/releases/mod_auth_openid/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= zhoushuqun@gmail.com
COMMENT= An authentication module for the Apache 2 webserver with OpenID
diff --git a/www/mod_auth_pam2/Makefile b/www/mod_auth_pam2/Makefile
index 39eff44ee79e..16b812fd93ce 100644
--- a/www/mod_auth_pam2/Makefile
+++ b/www/mod_auth_pam2/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 1.1.1
PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://pam.sourceforge.net/mod_auth_pam/dist/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-2.0-${PORTVERSION}
MAINTAINER= apache@FreeBSD.org
diff --git a/www/mod_auth_pgsql/Makefile b/www/mod_auth_pgsql/Makefile
index 5eae25bbb3e4..f49856dda574 100644
--- a/www/mod_auth_pgsql/Makefile
+++ b/www/mod_auth_pgsql/Makefile
@@ -9,6 +9,7 @@ PORTVERSION= 0.9.12
PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://www.giuseppetanzilli.it/${PORTNAME}/dist/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows users to use PostgreSQL databases for user authentication
diff --git a/www/mod_auth_pubtkt/Makefile b/www/mod_auth_pubtkt/Makefile
index e1bd75165f58..e622d9fed163 100644
--- a/www/mod_auth_pubtkt/Makefile
+++ b/www/mod_auth_pubtkt/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_auth_pubtkt
PORTVERSION= 0.5
CATEGORIES= www
MASTER_SITES= https://neon1.net/mod_auth_pubtkt/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= mod_auth_pubtkt-${PORTVERSION}
MAINTAINER= mk@neon1.net
diff --git a/www/mod_auth_xradius/Makefile b/www/mod_auth_xradius/Makefile
index 4a8457d76ae5..428e4a13cc85 100644
--- a/www/mod_auth_xradius/Makefile
+++ b/www/mod_auth_xradius/Makefile
@@ -8,6 +8,7 @@ PORTNAME= mod_auth_xradius
PORTVERSION= 0.4.6
CATEGORIES= www
MASTER_SITES= http://www.outoforder.cc/downloads/mod_auth_xradius/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= mwlucas@FreeBSD.org
COMMENT= Enables RADIUS authentication
diff --git a/www/mod_backhand/Makefile b/www/mod_backhand/Makefile
index ed5fbcd36b2c..819347304d85 100644
--- a/www/mod_backhand/Makefile
+++ b/www/mod_backhand/Makefile
@@ -11,6 +11,7 @@ PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://mirrors.omniti.com/mod_backhand/ \
http://people.FreeBSD.org/~seanc/ports/mod_backhand/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module that allows seamless redirection and load balancing of HTTP requests
diff --git a/www/mod_bandwidth/Makefile b/www/mod_bandwidth/Makefile
index 031755abd564..229e697ab1b7 100644
--- a/www/mod_bandwidth/Makefile
+++ b/www/mod_bandwidth/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_bandwidth
PORTVERSION= 2.1.0
CATEGORIES= www
MASTER_SITES= http://potatohead.estat.com/FreeBSD/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
#Orignal locations: ftp://ftp.cohprog.com/pub/apache/module/1.3.0/mod_bandwidth.c
# ftp://ftp.cohprog.com/pub/apache/module/cleanlink.pl
DIST_SUBDIR= apache
diff --git a/www/mod_cband/Makefile b/www/mod_cband/Makefile
index dabccfb0362a..91f262ffb416 100644
--- a/www/mod_cband/Makefile
+++ b/www/mod_cband/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.9.7.5
PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://www.sfr-fresh.com/unix/privat/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:C/_/-/}-${PORTVERSION}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= apache2
diff --git a/www/mod_clamav/Makefile b/www/mod_clamav/Makefile
index 9e4055867d82..42451c3c850e 100644
--- a/www/mod_clamav/Makefile
+++ b/www/mod_clamav/Makefile
@@ -11,6 +11,7 @@ PORTREVISION= 3
CATEGORIES= www security
MASTER_SITES= http://software.othello.ch/mod_clamav/ \
http://www.kommunity.net/download/mod_clamav/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= tmueko@kommunity.net
COMMENT= Scans content delivered by the Apache20 proxy module for viruses
diff --git a/www/mod_cplusplus/Makefile b/www/mod_cplusplus/Makefile
index d34d0ef81553..b38cc1b1ab03 100644
--- a/www/mod_cplusplus/Makefile
+++ b/www/mod_cplusplus/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_cplusplus
PORTVERSION= 1.5.4
CATEGORIES= www
MASTER_SITES= SF/modcplusplus/modcplusplus/${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module for loading C++ objects as handlers
diff --git a/www/mod_cvs2/Makefile b/www/mod_cvs2/Makefile
index 559228bbdcb8..a109b95364a0 100644
--- a/www/mod_cvs2/Makefile
+++ b/www/mod_cvs2/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.5.91
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://resare.com/noa/mod_cvs/dist/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= A module that makes Apache 2 CVS aware
diff --git a/www/mod_dav/Makefile b/www/mod_dav/Makefile
index eb813504cb61..f49357a43266 100644
--- a/www/mod_dav/Makefile
+++ b/www/mod_dav/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 1.0.3
PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://www.webdav.org/${PORTNAME}/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-${PORTVERSION}-1.3.6
MAINTAINER= apache@FreeBSD.org
diff --git a/www/mod_dnssd/Makefile b/www/mod_dnssd/Makefile
index 91d021956bc5..a3a0b182e3f0 100644
--- a/www/mod_dnssd/Makefile
+++ b/www/mod_dnssd/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.6
PORTREVISION= 6
CATEGORIES= www
MASTER_SITES= http://0pointer.de/lennart/projects/mod_dnssd/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= An Apache module that provides DNS-SD capabilities
diff --git a/www/mod_dtcl/Makefile b/www/mod_dtcl/Makefile
index 9c587181ebde..931fe2e6181b 100644
--- a/www/mod_dtcl/Makefile
+++ b/www/mod_dtcl/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.12.0
PORTREVISION= 1
CATEGORIES= www tcl
MASTER_SITES= http://tcl.apache.org/mod_dtcl/download/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= mi@aldan.algebra.com
COMMENT= Embeds a TCL8 interpreter in the Apache server
diff --git a/www/mod_encoding/Makefile b/www/mod_encoding/Makefile
index ce529f182781..da133fcfff9e 100644
--- a/www/mod_encoding/Makefile
+++ b/www/mod_encoding/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 20021209
PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://webdav.todo.gr.jp/download/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= edwin@mavetju.org
COMMENT= Apache module for non-ascii filename interoperability
diff --git a/www/mod_fcgid/Makefile b/www/mod_fcgid/Makefile
index ef5293e85cbb..965404c0ebc8 100644
--- a/www/mod_fcgid/Makefile
+++ b/www/mod_fcgid/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 2.3.5
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= hemi@puresimplicity.net
diff --git a/www/mod_fileiri/Makefile b/www/mod_fileiri/Makefile
index a18812add5db..e19611ecc559 100644
--- a/www/mod_fileiri/Makefile
+++ b/www/mod_fileiri/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_fileiri
PORTVERSION= 1.15
CATEGORIES= www
MASTER_SITES= LOCAL/chinsan
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DIST_SUBDIR= apache2
MAINTAINER= apache@FreeBSD.org
diff --git a/www/mod_gzip/Makefile b/www/mod_gzip/Makefile
index 73a125d23ebc..8b45924de83b 100644
--- a/www/mod_gzip/Makefile
+++ b/www/mod_gzip/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_gzip
PORTVERSION= 1.3.26.1a
CATEGORIES= www
MASTER_SITES= SF/mod-gzip/mod-gzip13x/${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
EXTRACT_SUFX= .tgz
MAINTAINER= ale@FreeBSD.org
diff --git a/www/mod_h264_streaming/Makefile b/www/mod_h264_streaming/Makefile
index b70002cbae16..030d3537e62b 100644
--- a/www/mod_h264_streaming/Makefile
+++ b/www/mod_h264_streaming/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 2.2.7
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://h264.code-shop.com/download/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= apache_${PORTNAME}-${PORTVERSION}
DIST_SUBDIR= apache22
diff --git a/www/mod_jk/Makefile b/www/mod_jk/Makefile
index 200ce8399a4c..9c1efbd0c223 100644
--- a/www/mod_jk/Makefile
+++ b/www/mod_jk/Makefile
@@ -11,6 +11,7 @@ PORTEPOCH?= 1
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_APACHE}
MASTER_SITE_SUBDIR= tomcat/tomcat-connectors/jk/source/jk-${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= tomcat-connectors-${PORTVERSION}-src
MAINTAINER?= girgen@FreeBSD.org
diff --git a/www/mod_layout/Makefile b/www/mod_layout/Makefile
index 53a7e05f365a..4bd1017fad8a 100644
--- a/www/mod_layout/Makefile
+++ b/www/mod_layout/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_layout
PORTVERSION= 3.4
CATEGORIES= www
MASTER_SITES= http://download.tangent.org/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module to wrap served pages with a header and/or footer
diff --git a/www/mod_layout2/Makefile b/www/mod_layout2/Makefile
index 403c463786ef..b212c2dde048 100644
--- a/www/mod_layout2/Makefile
+++ b/www/mod_layout2/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_layout
PORTVERSION= 4.1
CATEGORIES= www
MASTER_SITES= http://download.tangent.org/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache2 module to wrap served pages with a header and/or footer
diff --git a/www/mod_layout22/Makefile b/www/mod_layout22/Makefile
index c6379e1e30ec..0469d4328dd3 100644
--- a/www/mod_layout22/Makefile
+++ b/www/mod_layout22/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 5.1
PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= http://download.tangent.org/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache2.2 module to wrap served pages with a header and/or footer
diff --git a/www/mod_limitipconn/Makefile b/www/mod_limitipconn/Makefile
index 8790db57a1d9..f72b41eadb25 100644
--- a/www/mod_limitipconn/Makefile
+++ b/www/mod_limitipconn/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.04
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://dominia.org/djao/limit/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= ychsiao@ychsiao.org
COMMENT= Limit the number of simultaneous connections from a single IP address
diff --git a/www/mod_limitipconn2/Makefile b/www/mod_limitipconn2/Makefile
index e48b0b5e5639..eb6024212f87 100644
--- a/www/mod_limitipconn2/Makefile
+++ b/www/mod_limitipconn2/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_limitipconn
PORTVERSION= 0.23
CATEGORIES= www
MASTER_SITES= http://dominia.org/djao/limit/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DIST_SUBDIR= apache2
MAINTAINER= ychsiao@ychsiao.org
diff --git a/www/mod_line_edit/Makefile b/www/mod_line_edit/Makefile
index 525e8656e390..eb4bbc23be48 100644
--- a/www/mod_line_edit/Makefile
+++ b/www/mod_line_edit/Makefile
@@ -11,6 +11,7 @@ PORTVERSION= 1.0.0
PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://apache.webthing.com/mod_line_edit/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTFILES= mod_line_edit.c
MAINTAINER= apache@FreeBSD.org
diff --git a/www/mod_log_dbd/Makefile b/www/mod_log_dbd/Makefile
index 15a22178abc4..f6e924cedcaf 100644
--- a/www/mod_log_dbd/Makefile
+++ b/www/mod_log_dbd/Makefile
@@ -9,6 +9,7 @@ PORTVERSION= 0.2
PORTREVISION= 3
CATEGORIES= www databases
MASTER_SITES= http://bfoz.net/projects/${PORTNAME}/release/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= bfoz@bfoz.net
COMMENT= Uses APR DBD to store Apache access logs in a database
diff --git a/www/mod_log_firstbyte/Makefile b/www/mod_log_firstbyte/Makefile
index 89e7d1cd1b02..3df9ebb3b4fa 100644
--- a/www/mod_log_firstbyte/Makefile
+++ b/www/mod_log_firstbyte/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_log_firstbyte
PORTVERSION= 1.01
CATEGORIES= www
MASTER_SITES= http://mod-log-firstbyte.googlecode.com/svn/trunk/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTFILES= ${PORTNAME}.c readme.txt
MAINTAINER= leeym@FreeBSD.org
diff --git a/www/mod_log_sql/Makefile b/www/mod_log_sql/Makefile
index 31eaa0741901..b02f819bae69 100644
--- a/www/mod_log_sql/Makefile
+++ b/www/mod_log_sql/Makefile
@@ -9,6 +9,7 @@ PORTVERSION= 1.18
PORTREVISION= 3
CATEGORIES= www databases
MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= lev@FreeBSD.org
COMMENT= Allows Apache to log to a MySQL database
diff --git a/www/mod_log_sql2-dtc/Makefile b/www/mod_log_sql2-dtc/Makefile
index 1545f3dc62e4..45cd1fa25416 100644
--- a/www/mod_log_sql2-dtc/Makefile
+++ b/www/mod_log_sql2-dtc/Makefile
@@ -9,6 +9,7 @@ PORTVERSION= 1.101
PORTREVISION= 2
CATEGORIES= www databases
MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
PKGNAMESUFFIX= -dtc
MAINTAINER= apache@FreeBSD.org
diff --git a/www/mod_log_sql2/Makefile b/www/mod_log_sql2/Makefile
index 53fc9c639869..f0c5f80087fc 100644
--- a/www/mod_log_sql2/Makefile
+++ b/www/mod_log_sql2/Makefile
@@ -8,6 +8,7 @@ PORTNAME= mod_log_sql
PORTVERSION= 1.101
CATEGORIES= www databases
MASTER_SITES= http://www.outoforder.cc/downloads/${PORTNAME}/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Allows Apache to log to a MySQL database
diff --git a/www/mod_memcache/Makefile b/www/mod_memcache/Makefile
index 3262da027c0a..55c88d4c03e8 100644
--- a/www/mod_memcache/Makefile
+++ b/www/mod_memcache/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.1.0
PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= gslin@gslin.org
COMMENT= Apache 2.2.x module to manage apr_memcache connections
diff --git a/www/mod_mono/Makefile b/www/mod_mono/Makefile
index e43f4a6e4fbf..7f795c8df432 100644
--- a/www/mod_mono/Makefile
+++ b/www/mod_mono/Makefile
@@ -11,6 +11,7 @@ PORTVERSION= 2.4.3
PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://ftp.novell.com/pub/mono/sources/${PORTNAME}/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= mono@FreeBSD.org
COMMENT= Apache module for serving ASP.NET applications
diff --git a/www/mod_mp3/Makefile b/www/mod_mp3/Makefile
index 1d8e0428fcae..d9a257f4331a 100644
--- a/www/mod_mp3/Makefile
+++ b/www/mod_mp3/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.40
PORTREVISION= 1
CATEGORIES= www audio
MASTER_SITES= http://download.tangent.org/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module to allow MP3 streaming
diff --git a/www/mod_musicindex/Makefile b/www/mod_musicindex/Makefile
index 6b7f2fc4c5fa..12073772c908 100644
--- a/www/mod_musicindex/Makefile
+++ b/www/mod_musicindex/Makefile
@@ -11,6 +11,7 @@ PORTREVISION= 2
CATEGORIES= www audio
MASTER_SITES= http://www.parisc-linux.org/~varenet/musicindex/ \
http://depot.fsck.ch/mirror/distfiles/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Apache module that allows downloading and streaming of audio
diff --git a/www/mod_ntlm/Makefile b/www/mod_ntlm/Makefile
index 4f76bcf8f462..2a8261a377df 100644
--- a/www/mod_ntlm/Makefile
+++ b/www/mod_ntlm/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_ntlm
PORTVERSION= 0.4
CATEGORIES= www
MASTER_SITES= SF/modntlm/modntlm/${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= skv@FreeBSD.org
COMMENT= NTLM authentication module for the Apache webserver
diff --git a/www/mod_ntlm2/Makefile b/www/mod_ntlm2/Makefile
index 02578a92bc37..d892142e9ddc 100644
--- a/www/mod_ntlm2/Makefile
+++ b/www/mod_ntlm2/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.1
PORTREVISION= 2
CATEGORIES= www
MASTER_SITES= SF/modntlm/modntlm2/${PORTNAME}-${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
EXTRACT_SUFX= .tgz
MAINTAINER= admin@lissyara.su
diff --git a/www/mod_perl/Makefile b/www/mod_perl/Makefile
index 88a21ff863e1..8456a210e40c 100644
--- a/www/mod_perl/Makefile
+++ b/www/mod_perl/Makefile
@@ -11,6 +11,7 @@ PORTREVISION= 1
CATEGORIES= www perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= ModPerl/GOZER
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= Embeds a Perl interpreter in the Apache server
diff --git a/www/mod_perl2/Makefile b/www/mod_perl2/Makefile
index e65ea31c21ab..85b67a7358e3 100644
--- a/www/mod_perl2/Makefile
+++ b/www/mod_perl2/Makefile
@@ -12,6 +12,7 @@ PORTEPOCH= 3
CATEGORIES= www perl5
MASTER_SITES= http://perl.apache.org/dist/ \
http://perl.apache.org/dist/old/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
PKGNAMESUFFIX= 2
MAINTAINER= apache@FreeBSD.org
diff --git a/www/mod_proctitle/Makefile b/www/mod_proctitle/Makefile
index ff89abd6302b..46faa6d850df 100644
--- a/www/mod_proctitle/Makefile
+++ b/www/mod_proctitle/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_proctitle
PORTVERSION= 0.3
CATEGORIES= www
MASTER_SITES= ftp://ftp.springdaemons.com/soft/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= stas@FreeBSD.org
COMMENT= Set httpd process titles to reflect currently processed request
diff --git a/www/mod_proxy_xml/Makefile b/www/mod_proxy_xml/Makefile
index 0ce692bca55a..3b7727f52660 100644
--- a/www/mod_proxy_xml/Makefile
+++ b/www/mod_proxy_xml/Makefile
@@ -10,6 +10,7 @@ PORTNAME= mod_proxy_xml
PORTVERSION= 0.1
CATEGORIES= www
MASTER_SITES= http://apache.webthing.com/svn/apache/filters/xmlns/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTFILES= xmlns.h mod_proxy_xml.c
MAINTAINER= apache@FreeBSD.org
diff --git a/www/mod_pubcookie/Makefile b/www/mod_pubcookie/Makefile
index 647bbc418c0d..71c8665ea857 100644
--- a/www/mod_pubcookie/Makefile
+++ b/www/mod_pubcookie/Makefile
@@ -9,7 +9,7 @@ PORTNAME= pubcookie
PORTVERSION= 3.3.0
CATEGORIES= www security
MASTER_SITES= http://pubcookie.org/downloads/
-PKGNAMEPREFIX= mod_
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}mod_
DISTNAME= ${PORTNAME}-3.3.0a
MAINTAINER= brooks@FreeBSD.org
diff --git a/www/mod_python/Makefile b/www/mod_python/Makefile
index b6bf28181c21..107ca69b1c03 100644
--- a/www/mod_python/Makefile
+++ b/www/mod_python/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 2.7.11
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
EXTRACT_SUFX= .tgz
DIST_SUBDIR= python
diff --git a/www/mod_python3/Makefile b/www/mod_python3/Makefile
index 705428726ecc..d63fa04b73ee 100644
--- a/www/mod_python3/Makefile
+++ b/www/mod_python3/Makefile
@@ -11,6 +11,7 @@ PORTREVISION= 2
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_APACHE_HTTPD}
MASTER_SITE_SUBDIR= modpython
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
EXTRACT_SUFX= .tgz
MAINTAINER= apache@FreeBSD.org
diff --git a/www/mod_ruby/Makefile b/www/mod_ruby/Makefile
index 2b3afd130316..ba505b2519f1 100644
--- a/www/mod_ruby/Makefile
+++ b/www/mod_ruby/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 1.3.0
PORTREVISION= 1
CATEGORIES= www ruby
MASTER_SITES= http://www.modruby.net/archive/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DIST_SUBDIR= ruby
MAINTAINER= dinoex@FreeBSD.org
diff --git a/www/mod_scgi/Makefile b/www/mod_scgi/Makefile
index 0456108cb004..111b75deaf7f 100644
--- a/www/mod_scgi/Makefile
+++ b/www/mod_scgi/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.12
CATEGORIES= www
MASTER_SITES= http://quixote.python.ca/releases/ \
http://dryice.name/computer/FreeBSD/distfiles/
-PKGNAMEPREFIX= mod_
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}mod_
DISTNAME= scgi-${PORTVERSION:S/.a/a/}
MAINTAINER= dryice@dryice.name
diff --git a/www/mod_security/Makefile b/www/mod_security/Makefile
index 324ebb9324ab..66a8a9238097 100644
--- a/www/mod_security/Makefile
+++ b/www/mod_security/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 2.5.11
PORTREVISION= 3
CATEGORIES= www security
MASTER_SITES= SF/mod-security/modsecurity-apache/${PORTVERSION}
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME:S/_//:S/2//}-apache_${PORTVERSION}
MAINTAINER= araujo@FreeBSD.org
diff --git a/www/mod_sed/Makefile b/www/mod_sed/Makefile
index dfc7b6c0c259..eb543dbffdba 100644
--- a/www/mod_sed/Makefile
+++ b/www/mod_sed/Makefile
@@ -10,6 +10,7 @@ PORTNAME= mod_sed
PORTVERSION= 0.1
CATEGORIES= www
MASTER_SITES= http://www.happygiraffe.net/dist/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= apache@FreeBSD.org
COMMENT= An apache module that embeds a copy of the sed(1) command
diff --git a/www/mod_transform/Makefile b/www/mod_transform/Makefile
index c4fb55a139d8..c63490d8ea75 100644
--- a/www/mod_transform/Makefile
+++ b/www/mod_transform/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_transform
PORTVERSION= 0.6.0
CATEGORIES= www
MASTER_SITES= http://www.outoforder.cc/downloads/mod_transform/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
MAINTAINER= stan@stormier.net
COMMENT= An XSLT and XIncludes Filter module for Apache 2.0
diff --git a/www/mod_webapp/Makefile b/www/mod_webapp/Makefile
index bf29f49be0d5..79a3fb23cca2 100644
--- a/www/mod_webapp/Makefile
+++ b/www/mod_webapp/Makefile
@@ -11,6 +11,7 @@ PORTREVISION= 4
CATEGORIES= www
MASTER_SITES= http://jakarta.apache.org/%SUBDIR%/
MASTER_SITE_SUBDIR= builds/jakarta-tomcat-4.0/release/v${TOMCAT_RELEASE}/src
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTNAME= jakarta-tomcat-connectors-${CONNECTORS_RELEASE}-src
DIST_SUBDIR= mod_webapp
diff --git a/www/mod_wsgi/Makefile b/www/mod_wsgi/Makefile
index f1871afb996c..917427d689e7 100644
--- a/www/mod_wsgi/Makefile
+++ b/www/mod_wsgi/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_wsgi
PORTVERSION= 2.8
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
http://apt.douglasthrift.net/files/${PORTNAME}/ \
http://code.douglasthrift.net/files/${PORTNAME}/
diff --git a/www/mod_wsgi3/Makefile b/www/mod_wsgi3/Makefile
index 9f0b3d518be4..be5584dcf8af 100644
--- a/www/mod_wsgi3/Makefile
+++ b/www/mod_wsgi3/Makefile
@@ -9,6 +9,7 @@ PORTNAME= mod_wsgi
PORTVERSION= 3.2
CATEGORIES= www python
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
http://apt.douglasthrift.net/files/${PORTNAME}/ \
http://code.douglasthrift.net/files/${PORTNAME}/
diff --git a/www/mod_xmlns/Makefile b/www/mod_xmlns/Makefile
index f598180d8efd..3d2a00f7cf38 100644
--- a/www/mod_xmlns/Makefile
+++ b/www/mod_xmlns/Makefile
@@ -10,6 +10,7 @@ PORTNAME= mod_xmlns
PORTVERSION= 0.97
CATEGORIES= www
MASTER_SITES= http://apache.webthing.com/svn/apache/filters/xmlns/
+PKGNAMEPREFIX= ${APACHE_PKGNAMEPREFIX}
DISTFILES= xmlns.h mod_xmlns.c
MAINTAINER= apache@FreeBSD.org