aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-14 06:21:03 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2010-01-14 06:21:03 +0000
commit3a29df29a01ae222fbccebc2f7f47640c8e82b71 (patch)
tree3b27fab605617c936ba2c7803a6111892b24ad2b /www
parentb64ed3c4b4b2b128d3b3a8aaac307e9dd16e69ac (diff)
downloadports-3a29df29a01ae222fbccebc2f7f47640c8e82b71.tar.gz
ports-3a29df29a01ae222fbccebc2f7f47640c8e82b71.zip
* Switch to using bsd.port.options.mk
* Track PREFIX settings from the parent www/rt38 or www/rt36 port: has to match, or it won't work. * Minor fix to pkg-plist.rt38 PR: ports/142135 Submitted by: Matthew Seaman <m.seaman@infracaninophile.co.uk> (maintainer)
Notes
Notes: svn path=/head/; revision=247851
Diffstat (limited to 'www')
-rw-r--r--www/p5-RT-Authen-ExternalAuth/Makefile21
-rw-r--r--www/p5-RT-Authen-ExternalAuth/pkg-plist.rt382
2 files changed, 11 insertions, 12 deletions
diff --git a/www/p5-RT-Authen-ExternalAuth/Makefile b/www/p5-RT-Authen-ExternalAuth/Makefile
index f1517c5cf10b..43d09588f091 100644
--- a/www/p5-RT-Authen-ExternalAuth/Makefile
+++ b/www/p5-RT-Authen-ExternalAuth/Makefile
@@ -18,15 +18,11 @@ COMMENT= RT extension to authenticate users against an external source
BUILD_DEPENDS= ${SITE_PERL}/Net/LDAP.pm:${PORTSDIR}/net/p5-perl-ldap
RUN_DEPENDS= ${BUILD_DEPENDS}
-OPTIONS= RT36 "Install for rt-3.6.x (default rt-3.8.x)" off
-
PERL_CONFIGURE= yes
-MAN3= RT::Authen::ExternalAuth.3 RT::User_Vendor.3
-
-PLIST_SUB+= RTHOME=${RTHOME}
+OPTIONS= RT36 "Install for rt-3.6.x (default rt-3.8.x)" off
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_RT36)
@@ -47,12 +43,15 @@ MAN3PREFIX= ${PREFIX}
.endif
-# Don't use normal CONFIGURE_ARGS. Disable doc_?????_indstall targets to
-# suppress installing perllocal.pod. This duplicates code from bsd.perl.mk
-# rather undesirably.
+MAN3= RT::Authen::ExternalAuth.3 RT::User_Vendor.3
+PLIST_SUB+= RTHOME=${RTHOME}
+
+# Note: You can install using an arbitrary $PREFIX but only if it
+# matches the $PREFIX used to install www/rt3{6,8}. Hence ignore
+# $PREFIX in the environment and inherit settings from RT.pm
do-configure:
@cd ${CONFIGURE_WRKSRC} && \
- ${SETENV} ${CONFIGURE_ENV} ${PERL5} -I${RT_PM_DIR} ./${CONFIGURE_SCRIPT} && \
+ ${SETENV} -u PREFIX ${CONFIGURE_ENV} ${PERL5} -I${RT_PM_DIR} ./${CONFIGURE_SCRIPT} && \
${PERL5} -pi -e 's/ doc_(perl|site|\$$\(INSTALLDIRS\))_install$$//' Makefile
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt38 b/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt38
index d5f330ef36ed..c8c897b48fdb 100644
--- a/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt38
+++ b/www/p5-RT-Authen-ExternalAuth/pkg-plist.rt38
@@ -19,7 +19,7 @@ man/auto/RT/Authen/ExternalAuth/.packlist
@dirrm %%RTHOME%%/plugins/RT-Authen-ExternalAuth
@dirrm man/auto/RT/Authen/ExternalAuth
@dirrmtry man/auto/RT/Authen
-@dirrm man/auto/RT
+@dirrmtry man/auto/RT
@dirrmtry man/auto
@dirrmtry lib/RT/Authen
@dirrmtry lib/RT