aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-01-28 23:19:35 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-01-28 23:19:35 +0000
commit8cbd49115e39c1ab2bfe5951705b8925c858b42c (patch)
tree8a4394da7e2ee92e0294ce30bcc80269ebb8c3ef /www
parentea7867da1e550f2125938763a9d20c5a185110c2 (diff)
downloadports-8cbd49115e39c1ab2bfe5951705b8925c858b42c.tar.gz
ports-8cbd49115e39c1ab2bfe5951705b8925c858b42c.zip
- Update to 4.5.0
- New knobs WITH_CUR and WITH_MBSTRING - Change defaults: WITH_IMAGICK and WITH_GD are enabled by default now - Add LICENSE PR: 154356 Submitted by: Helmut Schneider <jumper99@gmx.de> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=268348
Diffstat (limited to 'www')
-rw-r--r--www/typo3/Makefile33
-rw-r--r--www/typo3/distinfo8
-rw-r--r--www/typo345/Makefile33
-rw-r--r--www/typo345/distinfo8
-rw-r--r--www/typo346/Makefile33
-rw-r--r--www/typo346/distinfo8
6 files changed, 81 insertions, 42 deletions
diff --git a/www/typo3/Makefile b/www/typo3/Makefile
index 3cb1c790e7a4..cdf239dcc6d2 100644
--- a/www/typo3/Makefile
+++ b/www/typo3/Makefile
@@ -6,16 +6,19 @@
#
PORTNAME= typo3
-PORTVERSION= 4.4.6
+PORTVERSION= 4.5.0
CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME}/TYPO3%20Source%20and%20Dummy/TYPO3%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/TYPO3%20Source%20and%20Dummy/TYPO3%20${PORTVERSION} \
+ http://dl1.typo3.org/TYPO3_${PORTVERSION}/
DISTNAME= ${PORTNAME}_src-${PORTVERSION}
MAINTAINER= jumper99@gmx.de
COMMENT= The typo3 content management system
+LICENSE= GPLv2
+
NO_BUILD= yes
-USE_PHP= mysql pcre xml session ctype filter json
+USE_PHP= ctype filter json mysql pcre session xml
WANT_PHP_WEB= yes
IGNORE_WITH_PHP= 4
@@ -27,24 +30,34 @@ EDITION= dummy
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${EDITION}-${PORTVERSION}${EXTRACT_SUFX}
-OPTIONS= GD "Configure with GDlib/freetype support" off \
- ZLIB "Configure with zlib support" off \
- IMAGICK "Configure with ImageMagick support" off
+OPTIONS= CURL "Configure with cURL support" off \
+ GD "Configure with GDlib/freetype support" on \
+ IMAGICK "Configure with ImageMagick support" on \
+ MBSTRING "Configure with mbstring support" off \
+ ZLIB "Configure with zlib support" off
.include <bsd.port.pre.mk>
-.if defined(WITH_GD)
-USE_PHP+= gd
+.if defined(WITH_CURL)
+USE_PHP+= curl
.endif
-.if defined(WITH_ZLIB)
-USE_PHP+= zlib
+.if defined(WITH_GD)
+USE_PHP+= gd
.endif
.if defined(WITH_IMAGICK)
LIB_DEPENDS+= MagickWand.4:${PORTSDIR}/graphics/ImageMagick
.endif
+.if defined(WITH_MBSTRING)
+USE_PHP+= mbstring
+.endif
+
+.if defined(WITH_ZLIB)
+USE_PHP+= zlib
+.endif
+
pre-install:
${MV} ${SITESRC}/typo3conf/localconf.php ${SITESRC}/typo3conf/localconf.php.dist
diff --git a/www/typo3/distinfo b/www/typo3/distinfo
index 003724283c5e..659192768d5c 100644
--- a/www/typo3/distinfo
+++ b/www/typo3/distinfo
@@ -1,4 +1,4 @@
-SHA256 (typo3_src-4.4.6.tar.gz) = 13b72d27d1c31b317f62520e6fc69773536b079d06676ec3f79888ac6cc15f83
-SIZE (typo3_src-4.4.6.tar.gz) = 18540098
-SHA256 (dummy-4.4.6.tar.gz) = 91758719ebab5fd552089ae509e6fb5990a2d6d3a9f0d93430fc7af31d5480ca
-SIZE (dummy-4.4.6.tar.gz) = 9763
+SHA256 (typo3_src-4.5.0.tar.gz) = dfbcf86e439f26983450111e0b02fe2ef70d4d72e9d5d6125658ec3137502f52
+SIZE (typo3_src-4.5.0.tar.gz) = 18939036
+SHA256 (dummy-4.5.0.tar.gz) = 11abe57c8f1cfe6ccbe2a4aa3c8ff07a300c7210ae1e402a1166fb7c2e2c6dd2
+SIZE (dummy-4.5.0.tar.gz) = 9220
diff --git a/www/typo345/Makefile b/www/typo345/Makefile
index 3cb1c790e7a4..cdf239dcc6d2 100644
--- a/www/typo345/Makefile
+++ b/www/typo345/Makefile
@@ -6,16 +6,19 @@
#
PORTNAME= typo3
-PORTVERSION= 4.4.6
+PORTVERSION= 4.5.0
CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME}/TYPO3%20Source%20and%20Dummy/TYPO3%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/TYPO3%20Source%20and%20Dummy/TYPO3%20${PORTVERSION} \
+ http://dl1.typo3.org/TYPO3_${PORTVERSION}/
DISTNAME= ${PORTNAME}_src-${PORTVERSION}
MAINTAINER= jumper99@gmx.de
COMMENT= The typo3 content management system
+LICENSE= GPLv2
+
NO_BUILD= yes
-USE_PHP= mysql pcre xml session ctype filter json
+USE_PHP= ctype filter json mysql pcre session xml
WANT_PHP_WEB= yes
IGNORE_WITH_PHP= 4
@@ -27,24 +30,34 @@ EDITION= dummy
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${EDITION}-${PORTVERSION}${EXTRACT_SUFX}
-OPTIONS= GD "Configure with GDlib/freetype support" off \
- ZLIB "Configure with zlib support" off \
- IMAGICK "Configure with ImageMagick support" off
+OPTIONS= CURL "Configure with cURL support" off \
+ GD "Configure with GDlib/freetype support" on \
+ IMAGICK "Configure with ImageMagick support" on \
+ MBSTRING "Configure with mbstring support" off \
+ ZLIB "Configure with zlib support" off
.include <bsd.port.pre.mk>
-.if defined(WITH_GD)
-USE_PHP+= gd
+.if defined(WITH_CURL)
+USE_PHP+= curl
.endif
-.if defined(WITH_ZLIB)
-USE_PHP+= zlib
+.if defined(WITH_GD)
+USE_PHP+= gd
.endif
.if defined(WITH_IMAGICK)
LIB_DEPENDS+= MagickWand.4:${PORTSDIR}/graphics/ImageMagick
.endif
+.if defined(WITH_MBSTRING)
+USE_PHP+= mbstring
+.endif
+
+.if defined(WITH_ZLIB)
+USE_PHP+= zlib
+.endif
+
pre-install:
${MV} ${SITESRC}/typo3conf/localconf.php ${SITESRC}/typo3conf/localconf.php.dist
diff --git a/www/typo345/distinfo b/www/typo345/distinfo
index 003724283c5e..659192768d5c 100644
--- a/www/typo345/distinfo
+++ b/www/typo345/distinfo
@@ -1,4 +1,4 @@
-SHA256 (typo3_src-4.4.6.tar.gz) = 13b72d27d1c31b317f62520e6fc69773536b079d06676ec3f79888ac6cc15f83
-SIZE (typo3_src-4.4.6.tar.gz) = 18540098
-SHA256 (dummy-4.4.6.tar.gz) = 91758719ebab5fd552089ae509e6fb5990a2d6d3a9f0d93430fc7af31d5480ca
-SIZE (dummy-4.4.6.tar.gz) = 9763
+SHA256 (typo3_src-4.5.0.tar.gz) = dfbcf86e439f26983450111e0b02fe2ef70d4d72e9d5d6125658ec3137502f52
+SIZE (typo3_src-4.5.0.tar.gz) = 18939036
+SHA256 (dummy-4.5.0.tar.gz) = 11abe57c8f1cfe6ccbe2a4aa3c8ff07a300c7210ae1e402a1166fb7c2e2c6dd2
+SIZE (dummy-4.5.0.tar.gz) = 9220
diff --git a/www/typo346/Makefile b/www/typo346/Makefile
index 3cb1c790e7a4..cdf239dcc6d2 100644
--- a/www/typo346/Makefile
+++ b/www/typo346/Makefile
@@ -6,16 +6,19 @@
#
PORTNAME= typo3
-PORTVERSION= 4.4.6
+PORTVERSION= 4.5.0
CATEGORIES= www
-MASTER_SITES= SF/${PORTNAME}/TYPO3%20Source%20and%20Dummy/TYPO3%20${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/TYPO3%20Source%20and%20Dummy/TYPO3%20${PORTVERSION} \
+ http://dl1.typo3.org/TYPO3_${PORTVERSION}/
DISTNAME= ${PORTNAME}_src-${PORTVERSION}
MAINTAINER= jumper99@gmx.de
COMMENT= The typo3 content management system
+LICENSE= GPLv2
+
NO_BUILD= yes
-USE_PHP= mysql pcre xml session ctype filter json
+USE_PHP= ctype filter json mysql pcre session xml
WANT_PHP_WEB= yes
IGNORE_WITH_PHP= 4
@@ -27,24 +30,34 @@ EDITION= dummy
DISTFILES+= ${DISTNAME}${EXTRACT_SUFX} ${EDITION}-${PORTVERSION}${EXTRACT_SUFX}
-OPTIONS= GD "Configure with GDlib/freetype support" off \
- ZLIB "Configure with zlib support" off \
- IMAGICK "Configure with ImageMagick support" off
+OPTIONS= CURL "Configure with cURL support" off \
+ GD "Configure with GDlib/freetype support" on \
+ IMAGICK "Configure with ImageMagick support" on \
+ MBSTRING "Configure with mbstring support" off \
+ ZLIB "Configure with zlib support" off
.include <bsd.port.pre.mk>
-.if defined(WITH_GD)
-USE_PHP+= gd
+.if defined(WITH_CURL)
+USE_PHP+= curl
.endif
-.if defined(WITH_ZLIB)
-USE_PHP+= zlib
+.if defined(WITH_GD)
+USE_PHP+= gd
.endif
.if defined(WITH_IMAGICK)
LIB_DEPENDS+= MagickWand.4:${PORTSDIR}/graphics/ImageMagick
.endif
+.if defined(WITH_MBSTRING)
+USE_PHP+= mbstring
+.endif
+
+.if defined(WITH_ZLIB)
+USE_PHP+= zlib
+.endif
+
pre-install:
${MV} ${SITESRC}/typo3conf/localconf.php ${SITESRC}/typo3conf/localconf.php.dist
diff --git a/www/typo346/distinfo b/www/typo346/distinfo
index 003724283c5e..659192768d5c 100644
--- a/www/typo346/distinfo
+++ b/www/typo346/distinfo
@@ -1,4 +1,4 @@
-SHA256 (typo3_src-4.4.6.tar.gz) = 13b72d27d1c31b317f62520e6fc69773536b079d06676ec3f79888ac6cc15f83
-SIZE (typo3_src-4.4.6.tar.gz) = 18540098
-SHA256 (dummy-4.4.6.tar.gz) = 91758719ebab5fd552089ae509e6fb5990a2d6d3a9f0d93430fc7af31d5480ca
-SIZE (dummy-4.4.6.tar.gz) = 9763
+SHA256 (typo3_src-4.5.0.tar.gz) = dfbcf86e439f26983450111e0b02fe2ef70d4d72e9d5d6125658ec3137502f52
+SIZE (typo3_src-4.5.0.tar.gz) = 18939036
+SHA256 (dummy-4.5.0.tar.gz) = 11abe57c8f1cfe6ccbe2a4aa3c8ff07a300c7210ae1e402a1166fb7c2e2c6dd2
+SIZE (dummy-4.5.0.tar.gz) = 9220