aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2005-11-02 02:11:52 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2005-11-02 02:11:52 +0000
commitead009d688ec8625a9ef0663134151f18efa2175 (patch)
tree9a359c41f93f0855df5e970dda8cd13e45f93c5b /www
parentf9f58770d33cdc13eaa49644ffe5d73979cfdb4b (diff)
downloadports-ead009d688ec8625a9ef0663134151f18efa2175.tar.gz
ports-ead009d688ec8625a9ef0663134151f18efa2175.zip
[patch] Update www/raqdevil to 0.9.6
We've released an 0.9.6 version of RAQdevil. The shar last time was apparently quite mangled, so I'm not sure that the current port actually works. Sorry for any miscommunication about that. PR: ports/88308 Submitted by: Devon H. O'Dell <dodell@offmyserver.com>
Notes
Notes: svn path=/head/; revision=146984
Diffstat (limited to 'www')
-rw-r--r--www/raqdevil/Makefile65
-rw-r--r--www/raqdevil/distinfo4
-rw-r--r--www/raqdevil/pkg-install13
-rw-r--r--www/raqdevil/pkg-plist10
4 files changed, 50 insertions, 42 deletions
diff --git a/www/raqdevil/Makefile b/www/raqdevil/Makefile
index 23b75346af5c..bed9f1d10b39 100644
--- a/www/raqdevil/Makefile
+++ b/www/raqdevil/Makefile
@@ -6,55 +6,58 @@
#
PORTNAME= raqdevil
-PORTVERSION= 0.9.4
+PORTVERSION= 0.9.6
CATEGORIES= www sysutils
-MASTER_SITES= http://raqdevil.alkeninternet.com/ \
- http://www.sitetronics.com/
+MASTER_SITES= http://www.raqdevil.com/
MAINTAINER= dodell@offmyserver.com
COMMENT= A port of the Sun Cobalt RaQ550 software to FreeBSD
-RUN_DEPENDS= \
- ${LOCALBASE}/libexec/imapd:${PORTSDIR}/mail/imap-uw \
- ${LOCALBASE}/libexec/qpopper:${PORTSDIR}/mail/qpopper \
- ${SITE_PERL}/${PERL_ARCH}/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
- ${SITE_PERL}/${PERL_ARCH}/Quota.pm:${PORTSDIR}/sysutils/p5-Quota \
- ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
- analog:${PORTSDIR}/www/analog \
- clamscan:${PORTSDIR}/security/clamav \
- logrotate:${PORTSDIR}/sysutils/logrotate \
- pcretest:${PORTSDIR}/devel/pcre \
- procmail:${PORTSDIR}/mail/procmail \
- proftpd:${PORTSDIR}/ftp/proftpd \
- sendmail:${PORTSDIR}/mail/sendmail-sasl \
- snmpd:${PORTSDIR}/net-mgmt/net-snmp \
- spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
- xinetd:${PORTSDIR}/security/xinetd
-BUILD_DEPENDS= bison:${PORTSDIR}/devel/bison \
- re2c:${PORTSDIR}/devel/re2c
+RUN_DEPENDS= ${LOCALBASE}/sbin/sendmail:${PORTSDIR}/mail/sendmail-sasl \
+ ${SITE_PERL}/Jcode.pm:${PORTSDIR}/japanese/p5-Jcode \
+ ${SITE_PERL}/mach/Quota.pm:${PORTSDIR}/sysutils/p5-Quota \
+ ${SITE_PERL}/mach/Locale/gettext.pm:${PORTSDIR}/devel/p5-Locale-gettext \
+ ${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
+ ${SITE_PERL}/Mail/SPF/Query.pm:${PORTSDIR}/mail/p5-Mail-SPF-Query \
+ logrotate:${PORTSDIR}/sysutils/logrotate \
+ httpd:${PORTSDIR}/www/apache20 \
+ perl:${PORTSDIR}/lang/perl5.8 \
+ imapd:${PORTSDIR}/mail/imap-uw \
+ pcretest:${PORTSDIR}/devel/pcre \
+ snmpd:${PORTSDIR}/net-mgmt/net-snmp \
+ proftpd:${PORTSDIR}/ftp/proftpd \
+ qpopauth:${PORTSDIR}/mail/qpopper \
+ xinetd:${PORTSDIR}/security/xinetd \
+ spamc:${PORTSDIR}/mail/p5-Mail-SpamAssassin \
+ procmail:${PORTSDIR}/mail/procmail \
+ clamscan:${PORTSDIR}/security/clamav \
+ analog:${PORTSDIR}/www/analog
+BUILD_DEPENDS= re2c:${PORTSDIR}/devel/re2c
USE_GNOME= glib20
-USE_PHP= xml pcre
+USE_PHP= pcre session xml
USE_GMAKE= yes
USE_PERL5= yes
USE_REINPLACE= yes
+USE_APACHE= yes
+
+WITH_APACHE2= yes
REINPLACE_ARGS= -i""
INSTALLS_SHLIB= yes
LDCONFIG_DIRS= ${PREFIX}/raqdevil/lib
.include <bsd.port.pre.mk>
-.ifdef (WITH_APACHE)
-WITH_APACHE2= yes
-.endif
-
-.ifndef (WITH_APACHE2)
-BROKEN?= "This port requires Apache 2. Use make -DWITH_APACHE."
-.endif
-
pre-extract:
@${SH} ${FILESDIR}/warning
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^sendmail+tls+sasl*' 2> /dev/null`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: sendmail with sasl support is required for RAQdevil to properly function."; \
+ ${ECHO_CMD} "Please install mail/sendmail-sasl." \
+ ${FALSE}; \
+ fi
+
post-extract:
.if !defined(PACKAGE_BUILDING)
${CC} -o ${WRKSRC}/rdqchk ${FILESDIR}/rdqchk.c
@@ -67,7 +70,7 @@ post-patch:
@${FIND} ${WRKSRC} -type f -name \*-e | ${XARGS} ${RM} -f
post-install:
- @${SETENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @PKG_PREFIX=${PREFIX} ${SCRIPTS_ENV} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>
diff --git a/www/raqdevil/distinfo b/www/raqdevil/distinfo
index a7240fee809b..285e26dce689 100644
--- a/www/raqdevil/distinfo
+++ b/www/raqdevil/distinfo
@@ -1,2 +1,2 @@
-MD5 (raqdevil-0.9.4.tar.gz) = e4f8a3aff80814788d588b3138355b20
-SIZE (raqdevil-0.9.4.tar.gz) = 2194931
+MD5 (raqdevil-0.9.6.tar.gz) = 7fa7a5134daa037384f465032cd15d2c
+SIZE (raqdevil-0.9.6.tar.gz) = 2196422
diff --git a/www/raqdevil/pkg-install b/www/raqdevil/pkg-install
index 6fc9811e8641..659e58528672 100644
--- a/www/raqdevil/pkg-install
+++ b/www/raqdevil/pkg-install
@@ -1,5 +1,6 @@
#!/bin/sh
+PREF=${PREFIX:-$PKG_PREFIX}
PATH=/bin:/usr/sbin
case $2 in
@@ -19,13 +20,11 @@ POST-INSTALL)
/usr/bin/touch /etc/mail/access
- if [ \! -d /usr/local/raqdevil/ui/web/base/sitestats/img ]; then
- mkdir -p /usr/local/raqdevil/ui/web/base/sitestats/img;
- chown www:wheel /usr/local/raqdevil/ui/web/base/sitestats/img;
- mkdir -p /usr/local/raqdevil/skel/spam;
- mkdir -p /usr/local/raqdevil/skel/quarantine;
- mkdir -p /usr/local/raqdevil/sessions;
- fi;
+ mkdir -p ${PREF}/raqdevil/ui/web/base/sitestats/img;
+ chown www:wheel ${PREF}/raqdevil/ui/web/base/sitestats/img;
+ mkdir -p ${PREF}/raqdevil/skel/spam;
+ mkdir -p ${PREF}/raqdevil/skel/quarantine;
+ mkdir -p ${PREF}/raqdevil/sessions;
( cd /etc/namedb; sh /etc/namedb/make-localhost )
;;
diff --git a/www/raqdevil/pkg-plist b/www/raqdevil/pkg-plist
index db55b5594d95..d4e4cb8b7e97 100644
--- a/www/raqdevil/pkg-plist
+++ b/www/raqdevil/pkg-plist
@@ -23,6 +23,7 @@ admserv/certs/key
admserv/certs/request
admserv/libexec
bin/clamfilter.pl
+bin/generateGraph.pl
etc/apache2/httpd.conf
etc/apache2/ssl.conf
etc/build
@@ -34,6 +35,7 @@ etc/proftpd.conf
etc/rc.d/admserv.sh
etc/rc.d/cced.sh
etc/ssh_banner
+etc/snmp/snmpd.conf
etc/xinetd.conf
etc/xinetd/xinetd.d/imap
etc/xinetd/xinetd.d/imaps
@@ -596,6 +598,9 @@ raqdevil/ui/menu/palette/palette_attachments.xml
raqdevil/ui/style/trueBlue.xml
raqdevil/ui/style/trueBlue.xml.en
raqdevil/ui/style/trueBlue.xml.ja
+raqdevil/ui/style/trueBlue.xml.fr
+raqdevil/ui/style/trueBlue.xml.de
+raqdevil/ui/style/trueBlue.xml.es
raqdevil/ui/web/base/alpine/adminredirect.html
raqdevil/ui/web/base/alpine/license.php
raqdevil/ui/web/base/alpine/splashPersonal.php
@@ -1006,7 +1011,10 @@ raqdevil/ui/web/test_i18n.php
raqdevil/ui/web/uiLog.php
raqdevil/ui/web/uifc/MultiFileUpload.php
raqdevil/ui/web/uifc/MultiFileUploadHandler.php
+sbin/ftplog2commonlog
+sbin/maillog2commonlog.pl
sbin/split_logs
+sbin/grab_logs.pl
share/locale/de/LC_MESSAGES/base-am.mo
share/locale/de/LC_MESSAGES/base-apache.mo
share/locale/de/LC_MESSAGES/base-cce.mo
@@ -1286,8 +1294,6 @@ share/locale/fr/LC_MESSAGES/trueBlue.mo
@dirrm raqdevil/ccewrap
@dirrm raqdevil/bin
@dirrm raqdevil
-@dirrm etc/rc.d/init.d
-@dirrm etc/ccewrap.d
@dirrm admserv/run
@dirrm admserv/conf.d
@dirrm admserv/conf