aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2008-07-26 04:31:12 +0000
committerBeech Rintoul <beech@FreeBSD.org>2008-07-26 04:31:12 +0000
commited86f41155edabfc5d4ba2ec297b64837bf91955 (patch)
tree17f2d4f4b74035ebe5c943d0f92fd006576abc3f /www
parent229c98f306185ab4bfa9e7047e493b0d46cf4af4 (diff)
downloadports-ed86f41155edabfc5d4ba2ec297b64837bf91955.tar.gz
ports-ed86f41155edabfc5d4ba2ec297b64837bf91955.zip
Google App Engine Oil (GAEO) is an open-source web framework
running on Google App Engine. Google App Engine Oil (GAEO) enables the web development on Google AppEngine quick and less configurations. GAEO enhances Google AppEngine SDK with new features such as: - Well-formed URL Routing - Enhanced Request Handler (Controller) - Enhanced Object-Relation Mapping (ORM) PR: ports/125923 Submitted by: Yi-Jheng Lin <yzlin at cs.nctu.edu.tw>
Notes
Notes: svn path=/head/; revision=217539
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/gaeo/Makefile40
-rw-r--r--www/gaeo/distinfo3
-rw-r--r--www/gaeo/files/patch-bin_gaeo.py11
-rw-r--r--www/gaeo/pkg-descr11
-rw-r--r--www/gaeo/pkg-plist18
6 files changed, 84 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0fd71c0e0b48..271ac713c71c 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -212,6 +212,7 @@
SUBDIR += fswiki
SUBDIR += g-cows
SUBDIR += g-gcl
+ SUBDIR += gaeo
SUBDIR += galeon
SUBDIR += gallery
SUBDIR += gallery2
diff --git a/www/gaeo/Makefile b/www/gaeo/Makefile
new file mode 100644
index 000000000000..81ef5c0a2629
--- /dev/null
+++ b/www/gaeo/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: gaeo
+# Date created: 2008-07-24
+# Whom: Yi-Jheng Lin <yzlin@cs.nctu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gaeo
+PORTVERSION= 45
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+DISTNAME= ${PORTNAME}-trunk-r${PORTVERSION}
+
+MAINTAINER= yzlin@cs.nctu.edu.tw
+COMMENT= An open-source web framework running on Google App Engine
+
+RUN_DEPENDS= google-appengine>=1.1.0:${PORTSDIR}/www/google-appengine
+
+PROJECTHOST= google-app-engine-oil
+
+NO_BUILD= yes
+
+USE_PYTHON= 2.5+
+USE_ZIP= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+post-patch:
+ ${REINPLACE_CMD} -e "s,%%DATADIR%%,${DATADIR},g" ${WRKSRC}/bin/gaeo.py
+
+do-install:
+ cd ${WRKSRC} && ${COPYTREE_SHARE} "gaeo" ${DATADIR}
+.if !defined(NOPORTDOCS)
+ ${INSTALL} -d ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.TXT ${DOCSDIR}/README
+.endif
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/gaeo.py ${PREFIX}/bin/gaeo.py
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/gaeogen.py ${PREFIX}/bin/gaeogen.py
+
+.include <bsd.port.mk>
diff --git a/www/gaeo/distinfo b/www/gaeo/distinfo
new file mode 100644
index 000000000000..1037b3117faf
--- /dev/null
+++ b/www/gaeo/distinfo
@@ -0,0 +1,3 @@
+MD5 (gaeo-trunk-r45.zip) = fd5243b6067759cd4d54bd65c5b931f7
+SHA256 (gaeo-trunk-r45.zip) = 386d7114841b5af6baeb65a28a8ab8cc69767f3f22b5367349d90d61a6c17a4d
+SIZE (gaeo-trunk-r45.zip) = 18299
diff --git a/www/gaeo/files/patch-bin_gaeo.py b/www/gaeo/files/patch-bin_gaeo.py
new file mode 100644
index 000000000000..1524628b65d9
--- /dev/null
+++ b/www/gaeo/files/patch-bin_gaeo.py
@@ -0,0 +1,11 @@
+--- bin/gaeo.py.orig 2008-07-24 15:24:37.000000000 +0800
++++ bin/gaeo.py 2008-07-24 15:25:07.000000000 +0800
+@@ -196,7 +196,7 @@
+ create_file(os.path.join(project_home, 'favicon.ico'), [])
+
+ # copy GAEO directory
+- copytree(os.path.join(os.path.dirname(__file__), '..', 'gaeo'), os.path.join(project_home, 'gaeo'))
++ copytree(os.path.join(os.path.dirname(__file__), '%%DATADIR%%', 'gaeo'), os.path.join(project_home, 'gaeo'))
+
+ # create the eclipse project file
+ if create_eclipse_proj:
diff --git a/www/gaeo/pkg-descr b/www/gaeo/pkg-descr
new file mode 100644
index 000000000000..7e3116e15acf
--- /dev/null
+++ b/www/gaeo/pkg-descr
@@ -0,0 +1,11 @@
+Google App Engine Oil (GAEO) is an open-source web framework
+running on Google App Engine.
+
+Google App Engine Oil (GAEO) enables the web development on
+Google AppEngine quick and less configurations. GAEO enhances
+Google AppEngine SDK with new features such as:
+ - Well-formed URL Routing
+ - Enhanced Request Handler (Controller)
+ - Enhanced Object-Relation Mapping (ORM)
+
+WWW: http://gaeo.org
diff --git a/www/gaeo/pkg-plist b/www/gaeo/pkg-plist
new file mode 100644
index 000000000000..f485c5ec2d74
--- /dev/null
+++ b/www/gaeo/pkg-plist
@@ -0,0 +1,18 @@
+bin/gaeo.py
+bin/gaeogen.py
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/gaeo/__init__.py
+%%DATADIR%%/gaeo/controller/__init__.py
+%%DATADIR%%/gaeo/controller/errors.py
+%%DATADIR%%/gaeo/controller/helper.py
+%%DATADIR%%/gaeo/dispatch/__init__.py
+%%DATADIR%%/gaeo/dispatch/dispatcher.py
+%%DATADIR%%/gaeo/dispatch/router.py
+%%DATADIR%%/gaeo/session/__init__.py
+%%DATADIR%%/gaeo/session/memcache.py
+@dirrm %%DATADIR%%/gaeo/session
+@dirrm %%DATADIR%%/gaeo/dispatch
+@dirrm %%DATADIR%%/gaeo/controller
+@dirrm %%DATADIR%%/gaeo
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%