aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2011-09-14 11:01:45 +0000
committerXin LI <delphij@FreeBSD.org>2011-09-14 11:01:45 +0000
commitae37fa8bc1bf395275a8a456daf2fa3d601a0a5c (patch)
tree23a5000174b31531ea9c3506431af7d61af799fe /www
parent38b3a0d42778edfbbba745408209cb33e9d1dea1 (diff)
downloadports-ae37fa8bc1bf395275a8a456daf2fa3d601a0a5c.tar.gz
ports-ae37fa8bc1bf395275a8a456daf2fa3d601a0a5c.zip
Update to 0.5.6.
Submitted by: maintainer (Jin-Sih Lin) PR: ports/160726
Notes
Notes: svn path=/head/; revision=281760
Diffstat (limited to 'www')
-rw-r--r--www/node-devel/Makefile2
-rw-r--r--www/node-devel/distinfo4
-rw-r--r--www/node-devel/files/patch-deps-uv-src-unix-fs.c11
-rw-r--r--www/node-devel/pkg-plist23
4 files changed, 22 insertions, 18 deletions
diff --git a/www/node-devel/Makefile b/www/node-devel/Makefile
index 30feea74d9bf..f3ae7ea68c4a 100644
--- a/www/node-devel/Makefile
+++ b/www/node-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= node
-PORTVERSION= 0.5.5
+PORTVERSION= 0.5.6
CATEGORIES= www
MASTER_SITES= http://nodejs.org/dist/v${PORTVERSION}/
PKGNAMESUFFIX= -devel
diff --git a/www/node-devel/distinfo b/www/node-devel/distinfo
index 5073f31699da..a6221243c9d6 100644
--- a/www/node-devel/distinfo
+++ b/www/node-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (node-v0.5.5.tar.gz) = 6f7ef8859e43545ff9a0e178e39a070f22c6a2abcf46b2cae079f446b5750e65
-SIZE (node-v0.5.5.tar.gz) = 9359415
+SHA256 (node-v0.5.6.tar.gz) = f9745ab3b19be29d3ddf40c40cec6d4c4685ae94d9943389d6b67178f11ecd9b
+SIZE (node-v0.5.6.tar.gz) = 9078567
diff --git a/www/node-devel/files/patch-deps-uv-src-unix-fs.c b/www/node-devel/files/patch-deps-uv-src-unix-fs.c
new file mode 100644
index 000000000000..c0fa987593ff
--- /dev/null
+++ b/www/node-devel/files/patch-deps-uv-src-unix-fs.c
@@ -0,0 +1,11 @@
+--- deps/uv/src/unix/fs.c.orig 2011-09-14 16:00:16.000000000 +0800
++++ deps/uv/src/unix/fs.c 2011-09-14 16:19:48.000000000 +0800
+@@ -434,7 +434,7 @@
+
+ int uv_fs_fdatasync(uv_loop_t* loop, uv_fs_t* req, uv_file file, uv_fs_cb cb) {
+ char* path = NULL;
+- WRAP_EIO(UV_FS_FDATASYNC, eio_fdatasync, fdatasync, ARGS1(file))
++ WRAP_EIO(UV_FS_FSYNC, eio_fsync, fsync, ARGS1(file))
+ }
+
+
diff --git a/www/node-devel/pkg-plist b/www/node-devel/pkg-plist
index 7c7ea610b589..8101d8e5218f 100644
--- a/www/node-devel/pkg-plist
+++ b/www/node-devel/pkg-plist
@@ -5,26 +5,17 @@ include/node/ares_version.h
include/node/c-ares/ares.h
include/node/c-ares/ares_version.h
include/node/config.h
-include/node/eio.h
-include/node/ev.h
-include/node/ev/config_cygwin.h
-include/node/ev/config_darwin.h
-include/node/ev/config_freebsd.h
-include/node/ev/config_linux.h
-include/node/ev/config_sunos.h
-include/node/ev/ev++.h
-include/node/ev/ev_vars.h
-include/node/ev/ev_wrap.h
-include/node/ev/event.h
-include/node/ngx-queue.h
include/node/node.h
include/node/node_buffer.h
include/node/node_config.h
include/node/node_object_wrap.h
include/node/node_version.h
-include/node/tree.h
-include/node/uv-unix.h
-include/node/uv-win.h
+include/node/uv-private/eio.h
+include/node/uv-private/ev.h
+include/node/uv-private/ngx-queue.h
+include/node/uv-private/tree.h
+include/node/uv-private/uv-unix.h
+include/node/uv-private/uv-win.h
include/node/uv.h
include/node/v8-debug.h
include/node/v8-preparser.h
@@ -84,6 +75,8 @@ lib/node/wafadmin/py3kfixes.py
@dirrm lib/node/wafadmin/Tools
@dirrm lib/node/wafadmin
@dirrm lib/node
+@dirrm include/node/uv-private
@dirrm include/node/ev
@dirrm include/node/c-ares
@dirrm include/node
+@exec mkdir -p %D/include/node/ev