aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2011-09-20 19:07:58 +0000
committerBrooks Davis <brooks@FreeBSD.org>2011-09-20 19:07:58 +0000
commitf4c52ec8b976abd0feaba452f9970e144475f994 (patch)
tree90b4e37d7cfea80ee82e889a0b30d145719fbe99 /www
parent0c6dbbac51bb5ead11c4c14f6098054f59d46972 (diff)
downloadports-f4c52ec8b976abd0feaba452f9970e144475f994.tar.gz
ports-f4c52ec8b976abd0feaba452f9970e144475f994.zip
Add the trac-fullblognotification plugin which allows notifications to
be sent when trac-fullblog blogs are changed.
Notes
Notes: svn path=/head/; revision=282084
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/trac-fullblognotification/Makefile52
-rw-r--r--www/trac-fullblognotification/distinfo2
-rw-r--r--www/trac-fullblognotification/pkg-descr18
-rw-r--r--www/trac-fullblognotification/pkg-plist21
5 files changed, 94 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index b419864d5ab1..55a6f88e450f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1783,6 +1783,7 @@
SUBDIR += trac-estimator
SUBDIR += trac-fivestarvote
SUBDIR += trac-fullblog
+ SUBDIR += trac-fullblognotification
SUBDIR += trac-gantt
SUBDIR += trac-gitplugin
SUBDIR += trac-graphviz
diff --git a/www/trac-fullblognotification/Makefile b/www/trac-fullblognotification/Makefile
new file mode 100644
index 000000000000..a8af4e3f3e86
--- /dev/null
+++ b/www/trac-fullblognotification/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: trac-fullblog
+# Date created: January 9, 2009
+# Whom: Brooks Davis <brooks@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ${PYDISTUTILS_PKGNAME:S;^Trac;;S;Plugin$;;:L}
+PORTVERSION= 0.2.1
+CATEGORIES= www devel python
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+PKGNAMEPREFIX= trac-
+DISTNAME= ${PORTNAME}plugin-${PORTVERSION}
+DIST_SUBDIR= trac
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= This plugin provides a project Blog
+
+RUN_DEPENDS+= trac-fullblog>=0.1.1:${PORTSDIR}/www/trac-fullblog
+BUILD_DEPENDS+= easy_install:${PORTSDIR}/devel/py-setuptools
+
+USE_PYTHON= 2.5+
+NO_BUILD= yes
+USE_PYDISTUTILS=yes
+PYDISTUTILS_PKGNAME= TracFullBlogNotificationPlugin
+PYDISTUTILS_NOEGGINFO= yes
+PLIST_SUB= PORTVERSION=${PORTVERSION} \
+ PYTHON_VER=${PYTHON_VER}
+
+EGG_PATH= ${PYTHONPREFIX_SITELIBDIR}/${PYDISTUTILS_PKGNAME}-${PORTVERSION}-py${PYTHON_VER}.egg
+
+.if defined(BOOTSTRAP)
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ svn export http://trac-hacks.org/svn/fullblognotificationplugin/0.12/ \
+ ${WRKSRC}
+ ${MKDIR} ${_DISTDIR}
+ cd ${WRKDIR} && \
+ tar cfvz ${_DISTDIR}/${DISTNAME}.tar.gz ${DISTNAME}
+.endif
+
+build-plist:
+ @${CAT} /dev/null > ${PLIST}
+ ${FIND} ${EGG_PATH} -type f | \
+ ${SED} -e 's|${EGG_PATH}|%%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-%%PORTVERSION%%-py%%PYTHON_VER%%.egg|' | \
+ ${SORT} >> ${PLIST}
+ ${FIND} ${EGG_PATH} -type d | \
+ ${SED} -e 's|${EGG_PATH}|@dirrm %%PYTHON_SITELIBDIR%%/${PYDISTUTILS_PKGNAME}-%%PORTVERSION%%-py%%PYTHON_VER%%.egg|' | \
+ ${SORT} -r >> ${PLIST}
+
+.include <bsd.port.mk>
diff --git a/www/trac-fullblognotification/distinfo b/www/trac-fullblognotification/distinfo
new file mode 100644
index 000000000000..e8242e76e2dd
--- /dev/null
+++ b/www/trac-fullblognotification/distinfo
@@ -0,0 +1,2 @@
+SHA256 (trac/fullblognotificationplugin-0.2.1.tar.gz) = 3c58f59cdb05bdaea6de17af710a90f95915b1bad3880468a87f2bc2edf5eba3
+SIZE (trac/fullblognotificationplugin-0.2.1.tar.gz) = 4605
diff --git a/www/trac-fullblognotification/pkg-descr b/www/trac-fullblognotification/pkg-descr
new file mode 100644
index 000000000000..88db4db52948
--- /dev/null
+++ b/www/trac-fullblognotification/pkg-descr
@@ -0,0 +1,18 @@
+This plugin uses the blog change interface in FullBlogPlugin to send out
+email notifications for:
+ * new posts
+ * updated posts
+ * comment added
+ * deleted posts
+
+Email notifications are sent to the user who made the change.
+Notifications can also be sent to other users or a distribution list by
+specifying the smtp_always_cc option.
+
+The emails are sent in plain text using a template that was modeled
+after Trac's ticket_notify_email template.
+
+If you are using the AnnouncerPlugin, you should use its FullBlogPlugin
+rather than the FullBlogNotificationPlugin.
+
+WWW: http://trac-hacks.org/wiki/FullBlogNotificationPlugin
diff --git a/www/trac-fullblognotification/pkg-plist b/www/trac-fullblognotification/pkg-plist
new file mode 100644
index 000000000000..8ee4248d0a49
--- /dev/null
+++ b/www/trac-fullblognotification/pkg-plist
@@ -0,0 +1,21 @@
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/__init__.py
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/__init__.pyc
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/__init__.pyo
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/fullblognotification.py
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/fullblognotification.pyc
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/fullblognotification.pyo
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/notification.py
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/notification.pyc
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/notification.pyo
+%%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/templates/fullblognotification_email_template.txt
+@dirrm %%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification/templates
+@dirrm %%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/fullblognotification
+@dirrm %%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/TracFullBlogNotificationPlugin-%%PORTVERSION%%-py%%PYTHON_VER%%.egg