aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2003-05-11 00:29:36 +0000
committerPete Fritchman <petef@FreeBSD.org>2003-05-11 00:29:36 +0000
commit62806b628a9d5ae08d50a8e5c9f5fcbfbbfbbd82 (patch)
treed1f3b9b77fd59b2e4c4976ed29c6551ad47c1a3d /www
parentf903d995bec183a4b01d9f4948bcd057e7e535c4 (diff)
downloadports-62806b628a9d5ae08d50a8e5c9f5fcbfbbfbbd82.tar.gz
ports-62806b628a9d5ae08d50a8e5c9f5fcbfbbfbbd82.zip
Update to 2.3.10.
PR: 51976 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=80634
Diffstat (limited to 'www')
-rw-r--r--www/eaccelerator/Makefile9
-rw-r--r--www/eaccelerator/distinfo2
-rw-r--r--www/eaccelerator/files/patch-encoder.php37
-rw-r--r--www/eaccelerator/pkg-descr6
-rw-r--r--www/eaccelerator/pkg-plist3
-rw-r--r--www/turck-mmcache/Makefile9
-rw-r--r--www/turck-mmcache/distinfo2
-rw-r--r--www/turck-mmcache/files/patch-encoder.php37
-rw-r--r--www/turck-mmcache/pkg-descr6
-rw-r--r--www/turck-mmcache/pkg-plist3
10 files changed, 106 insertions, 8 deletions
diff --git a/www/eaccelerator/Makefile b/www/eaccelerator/Makefile
index ceda6afca1bd..975ae6af4806 100644
--- a/www/eaccelerator/Makefile
+++ b/www/eaccelerator/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= turck-mmcache
-PORTVERSION= 2.3.9
+PORTVERSION= 2.3.10
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sysadmin@alexdupre.com
-COMMENT= An opcode cache for PHP
+COMMENT= An opcode cache for PHP with encoder and loader
EXTRACT_DEPENDS=phpize:${PORTSDIR}/www/mod_php4
BUILD_DEPENDS= ${LOCALBASE}/include/php/Zend/zend.h:${PORTSDIR}/www/mod_php4
@@ -45,11 +45,11 @@ APACHE_PORT?= ${PORTSDIR}/www/apache13
post-extract:
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/config.m4
- @${REINPLACE_CMD} -e 's,[[:cntrl:]]$$,,g' ${WRKSRC}/mmcache.c
@${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
@cd ${WRKSRC} && ${LOCALBASE}/bin/phpize
post-build:
+ @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/encoder.php > ${WRKSRC}/encoder
@${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%EXT_DIR%%|${EXT_DIR}|g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
@@ -57,6 +57,9 @@ do-install:
@${MKDIR} ${PREFIX}/lib/php/${EXT_DIR}
@${INSTALL_DATA} ${WRKSRC}/modules/mmcache.so \
${PREFIX}/lib/php/${EXT_DIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/encoder ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/mmcache.php ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/www/eaccelerator/distinfo b/www/eaccelerator/distinfo
index 89ad8d074256..e1f36be7926b 100644
--- a/www/eaccelerator/distinfo
+++ b/www/eaccelerator/distinfo
@@ -1 +1 @@
-MD5 (turck-mmcache-2.3.9.tar.gz) = d578827ef7914f6c9d7920ad0e27727d
+MD5 (turck-mmcache-2.3.10.tar.gz) = 6dd12cd6c122a821af1aa872b808704e
diff --git a/www/eaccelerator/files/patch-encoder.php b/www/eaccelerator/files/patch-encoder.php
new file mode 100644
index 000000000000..b70e531d78d6
--- /dev/null
+++ b/www/eaccelerator/files/patch-encoder.php
@@ -0,0 +1,37 @@
+--- encoder.php.orig Thu May 8 16:58:25 2003
++++ encoder.php Thu May 8 17:00:00 2003
+@@ -1,25 +1,25 @@
+-#! /usr/bin/php -f
++#! %%LOCALBASE%%/bin/php -f
+
+ <?php
+ function mmcache_encoder_usage() {
+- echo "Usage:\tphp -q encoder.php [options] source_file_name\n";
+- echo "\tphp -q encoder.php [options] source_file_name...\n";
+- echo "\tphp -q encoder.php [options] source_directory_name...\n\n";
++ echo "Usage:\tencoder [options] source_file_name\n";
++ echo "\tencoder [options] source_file_name...\n";
++ echo "\tencoder [options] source_directory_name...\n\n";
+ echo "Options:\n";
+ echo "\t-s suffix\n\t\tencode files only with following suffix (default is \"php\")\n";
+ echo "\t-a\n\t\tencode all files (no by default)\n";
+ echo "\t-l\n\t\tfollow symbolic links (no by default)\n";
+ echo "\t-r\n\t\tencode directories recursively (no by default)\n";
+ echo "\t-c\n\t\tcopy files those shouldn't be encoded (no by default)\n";
+- echo "\t-f\n\t\toverfrite existing files (no by default)\n";
++ echo "\t-f\n\t\toverwrite existing files (no by default)\n";
+ echo "\t-o target\n\t\tIf you encode only one script then 'target' specifyes an output\n";
+ echo "\t\tfile name. If you encode directory or several files at once\n";
+ echo "\t\tthen 'target' specifyes an output directory name.\n";
+ echo "\nExamples:\n";
+- echo "\tphp -q encoder.php some_file.php\n";
+- echo "\tphp -q encoder.php some_file.php -o some_encoded_file.php\n";
+- echo "\tphp -q encoder.php *.php -o some_dir\n";
+- echo "\tphp -q encoder.php ~/public_html/x -rcf -sphp -sinc -o ~/public_html/y\n";
++ echo "\tencoder some_file.php\n";
++ echo "\tencoder some_file.php -o some_encoded_file.php\n";
++ echo "\tencoder *.php -o some_dir\n";
++ echo "\tencoder ~/public_html/x -rcf -sphp -sinc -o ~/public_html/y\n";
+ echo "\n";
+ exit();
+ }
diff --git a/www/eaccelerator/pkg-descr b/www/eaccelerator/pkg-descr
index 6618fbcb7a30..183f202c3868 100644
--- a/www/eaccelerator/pkg-descr
+++ b/www/eaccelerator/pkg-descr
@@ -5,6 +5,12 @@ Also it uses some optimizations for speed up of PHP scripts execution.
Turck MMCache typically reduces server load and increases
the speed of your PHP code by 1-10 times.
+Turck MMCache contains PHP encoder and loader. You can encode any PHP
+scripts with encoder to distribute them without sources. Encoded files
+can be run on any site which runs PHP with Turck MMCache. The sources
+of encoded script can't be restored because they are stored in a compiled
+form and the encoded version doesn't contain the source.
+
WWW: http://www.turcksoft.com/en/e_mmc.htm
- Alex Dupre
diff --git a/www/eaccelerator/pkg-plist b/www/eaccelerator/pkg-plist
index 9c691ea755ae..d40ab6cb27bc 100644
--- a/www/eaccelerator/pkg-plist
+++ b/www/eaccelerator/pkg-plist
@@ -1,4 +1,7 @@
+bin/encoder
lib/php/%%EXT_DIR%%/mmcache.so
%%PORTDOCS%%share/doc/turck-mmcache/README
@unexec rmdir %D/lib/php/%%EXT_DIR%% 2> /dev/null || true
+share/examples/turck-mmcache/mmcache.php
%%PORTDOCS%%@dirrm share/doc/turck-mmcache
+@dirrm share/examples/turck-mmcache
diff --git a/www/turck-mmcache/Makefile b/www/turck-mmcache/Makefile
index ceda6afca1bd..975ae6af4806 100644
--- a/www/turck-mmcache/Makefile
+++ b/www/turck-mmcache/Makefile
@@ -6,13 +6,13 @@
#
PORTNAME= turck-mmcache
-PORTVERSION= 2.3.9
+PORTVERSION= 2.3.10
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sysadmin@alexdupre.com
-COMMENT= An opcode cache for PHP
+COMMENT= An opcode cache for PHP with encoder and loader
EXTRACT_DEPENDS=phpize:${PORTSDIR}/www/mod_php4
BUILD_DEPENDS= ${LOCALBASE}/include/php/Zend/zend.h:${PORTSDIR}/www/mod_php4
@@ -45,11 +45,11 @@ APACHE_PORT?= ${PORTSDIR}/www/apache13
post-extract:
@${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/config.m4
- @${REINPLACE_CMD} -e 's,[[:cntrl:]]$$,,g' ${WRKSRC}/mmcache.c
@${ECHO_MSG} "===> PHPizing for ${DISTNAME}"
@cd ${WRKSRC} && ${LOCALBASE}/bin/phpize
post-build:
+ @${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/encoder.php > ${WRKSRC}/encoder
@${SED} "s|%%LOCALBASE%%|${LOCALBASE}|g;s|%%PREFIX%%|${PREFIX}|g;s|%%EXT_DIR%%|${EXT_DIR}|g" \
${.CURDIR}/pkg-message > ${PKGMESSAGE}
@@ -57,6 +57,9 @@ do-install:
@${MKDIR} ${PREFIX}/lib/php/${EXT_DIR}
@${INSTALL_DATA} ${WRKSRC}/modules/mmcache.so \
${PREFIX}/lib/php/${EXT_DIR}
+ @${INSTALL_SCRIPT} ${WRKSRC}/encoder ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/mmcache.php ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
diff --git a/www/turck-mmcache/distinfo b/www/turck-mmcache/distinfo
index 89ad8d074256..e1f36be7926b 100644
--- a/www/turck-mmcache/distinfo
+++ b/www/turck-mmcache/distinfo
@@ -1 +1 @@
-MD5 (turck-mmcache-2.3.9.tar.gz) = d578827ef7914f6c9d7920ad0e27727d
+MD5 (turck-mmcache-2.3.10.tar.gz) = 6dd12cd6c122a821af1aa872b808704e
diff --git a/www/turck-mmcache/files/patch-encoder.php b/www/turck-mmcache/files/patch-encoder.php
new file mode 100644
index 000000000000..b70e531d78d6
--- /dev/null
+++ b/www/turck-mmcache/files/patch-encoder.php
@@ -0,0 +1,37 @@
+--- encoder.php.orig Thu May 8 16:58:25 2003
++++ encoder.php Thu May 8 17:00:00 2003
+@@ -1,25 +1,25 @@
+-#! /usr/bin/php -f
++#! %%LOCALBASE%%/bin/php -f
+
+ <?php
+ function mmcache_encoder_usage() {
+- echo "Usage:\tphp -q encoder.php [options] source_file_name\n";
+- echo "\tphp -q encoder.php [options] source_file_name...\n";
+- echo "\tphp -q encoder.php [options] source_directory_name...\n\n";
++ echo "Usage:\tencoder [options] source_file_name\n";
++ echo "\tencoder [options] source_file_name...\n";
++ echo "\tencoder [options] source_directory_name...\n\n";
+ echo "Options:\n";
+ echo "\t-s suffix\n\t\tencode files only with following suffix (default is \"php\")\n";
+ echo "\t-a\n\t\tencode all files (no by default)\n";
+ echo "\t-l\n\t\tfollow symbolic links (no by default)\n";
+ echo "\t-r\n\t\tencode directories recursively (no by default)\n";
+ echo "\t-c\n\t\tcopy files those shouldn't be encoded (no by default)\n";
+- echo "\t-f\n\t\toverfrite existing files (no by default)\n";
++ echo "\t-f\n\t\toverwrite existing files (no by default)\n";
+ echo "\t-o target\n\t\tIf you encode only one script then 'target' specifyes an output\n";
+ echo "\t\tfile name. If you encode directory or several files at once\n";
+ echo "\t\tthen 'target' specifyes an output directory name.\n";
+ echo "\nExamples:\n";
+- echo "\tphp -q encoder.php some_file.php\n";
+- echo "\tphp -q encoder.php some_file.php -o some_encoded_file.php\n";
+- echo "\tphp -q encoder.php *.php -o some_dir\n";
+- echo "\tphp -q encoder.php ~/public_html/x -rcf -sphp -sinc -o ~/public_html/y\n";
++ echo "\tencoder some_file.php\n";
++ echo "\tencoder some_file.php -o some_encoded_file.php\n";
++ echo "\tencoder *.php -o some_dir\n";
++ echo "\tencoder ~/public_html/x -rcf -sphp -sinc -o ~/public_html/y\n";
+ echo "\n";
+ exit();
+ }
diff --git a/www/turck-mmcache/pkg-descr b/www/turck-mmcache/pkg-descr
index 6618fbcb7a30..183f202c3868 100644
--- a/www/turck-mmcache/pkg-descr
+++ b/www/turck-mmcache/pkg-descr
@@ -5,6 +5,12 @@ Also it uses some optimizations for speed up of PHP scripts execution.
Turck MMCache typically reduces server load and increases
the speed of your PHP code by 1-10 times.
+Turck MMCache contains PHP encoder and loader. You can encode any PHP
+scripts with encoder to distribute them without sources. Encoded files
+can be run on any site which runs PHP with Turck MMCache. The sources
+of encoded script can't be restored because they are stored in a compiled
+form and the encoded version doesn't contain the source.
+
WWW: http://www.turcksoft.com/en/e_mmc.htm
- Alex Dupre
diff --git a/www/turck-mmcache/pkg-plist b/www/turck-mmcache/pkg-plist
index 9c691ea755ae..d40ab6cb27bc 100644
--- a/www/turck-mmcache/pkg-plist
+++ b/www/turck-mmcache/pkg-plist
@@ -1,4 +1,7 @@
+bin/encoder
lib/php/%%EXT_DIR%%/mmcache.so
%%PORTDOCS%%share/doc/turck-mmcache/README
@unexec rmdir %D/lib/php/%%EXT_DIR%% 2> /dev/null || true
+share/examples/turck-mmcache/mmcache.php
%%PORTDOCS%%@dirrm share/doc/turck-mmcache
+@dirrm share/examples/turck-mmcache