aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2009-07-21 13:53:14 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2009-07-21 13:53:14 +0000
commit677fe26a9ccd8c6b5a93519d006c6783fde4563f (patch)
treec4a7d4666741a5da87a5ddf5a91d386c53e19b6d /www
parent7ee0ace4630e95e1028d2fea5234d1eb11634719 (diff)
downloadports-677fe26a9ccd8c6b5a93519d006c6783fde4563f.tar.gz
ports-677fe26a9ccd8c6b5a93519d006c6783fde4563f.zip
Add support for http_geoip module (introduced in 0.8.6).
Do not bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=238169
Diffstat (limited to 'www')
-rw-r--r--www/nginx-devel/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/nginx-devel/Makefile b/www/nginx-devel/Makefile
index bf3161885b12..15d8d3fed692 100644
--- a/www/nginx-devel/Makefile
+++ b/www/nginx-devel/Makefile
@@ -25,6 +25,7 @@ OPTIONS= DEBUG "Enable nginx debugging" off \
HTTP_CACHE_MODULE "Enable http_cache module" on \
HTTP_DAV_MODULE "Enable http_webdav module" off \
HTTP_FLV_MODULE "Enable http_flv module" off \
+ HTTP_GEOIP_MODULE "Enable http_geoip module" off \
HTTP_GZIP_STATIC_MODULE "Enable http_gzip_static module" off \
HTTP_PERL_MODULE "Enable http_perl module" off \
HTTP_RANDOM_INDEX_MODULE "Enable http_random_index module" off \
@@ -157,6 +158,11 @@ CONFIGURE_ARGS+=--add-module=${WRKDIR}/nginx-fancyindex-${NGINX_FANCYINDEX_MODUL
CONFIGURE_ARGS+=--with-http_flv_module
.endif
+.if defined(WITH_HTTP_GEOIP_MODULE)
+CONFIGURE_ARGS+=--with-http_geoip_module
+LIB_DEPENDS+= GeoIP.5:${PORTSDIR}/net/GeoIP
+.endif
+
.if defined(WITH_HTTP_GZIP_STATIC_MODULE)
CONFIGURE_ARGS+=--with-http_gzip_static_module
.endif