aboutsummaryrefslogtreecommitdiff
path: root/www
diff options
context:
space:
mode:
authorFrederic Culot <culot@FreeBSD.org>2012-03-19 09:42:24 +0000
committerFrederic Culot <culot@FreeBSD.org>2012-03-19 09:42:24 +0000
commitbae5a4a5432a04f362cf8630adcd0ef2eab71d67 (patch)
treef96df3e8a117421c69bab11b6d16f561b68e1513 /www
parent53fa14f80183d35bb7e201c98c563999b607c0ee (diff)
downloadports-bae5a4a5432a04f362cf8630adcd0ef2eab71d67.tar.gz
ports-bae5a4a5432a04f362cf8630adcd0ef2eab71d67.zip
WWW::LongURL is a simple interface for using the LongURL API to expand
shortened URLs. WWW: http://search.cpan.org/dist/WWW-LongURL/ PR: ports/166186 Submitted by: Yi-Hsuan Hsin <mhsin@mhsin.org> Feature safe: yes
Notes
Notes: svn path=/head/; revision=293554
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-WWW-LongURL/Makefile32
-rw-r--r--www/p5-WWW-LongURL/distinfo2
-rw-r--r--www/p5-WWW-LongURL/pkg-descr4
-rw-r--r--www/p5-WWW-LongURL/pkg-plist5
5 files changed, 44 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 16d4fc39acb6..c2536c1d897a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1209,6 +1209,7 @@
SUBDIR += p5-WWW-IMDb
SUBDIR += p5-WWW-Instapaper-Client
SUBDIR += p5-WWW-Link
+ SUBDIR += p5-WWW-LongURL
SUBDIR += p5-WWW-Mechanize
SUBDIR += p5-WWW-Mechanize-CGI
SUBDIR += p5-WWW-Mechanize-Cached
diff --git a/www/p5-WWW-LongURL/Makefile b/www/p5-WWW-LongURL/Makefile
new file mode 100644
index 000000000000..5ba3d83b90bb
--- /dev/null
+++ b/www/p5-WWW-LongURL/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-WWW-LongURL
+# Date created: 2012-02-27
+# Whom: Yi-Hsuan Hsin <mhsin@mhsin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= WWW-LongURL
+PORTVERSION= 0.05
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mhsin@mhsin.org
+COMMENT= Perl interface to the LongURL API
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-JSON-Any>0:${PORTSDIR}/converters/p5-JSON-Any \
+ p5-URI>0:${PORTSDIR}/net/p5-URI \
+ p5-Class-Accessor>0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-LWP-Online>0:${PORTSDIR}/www/p5-LWP-Online
+
+PERL_CONFIGURE= yes
+
+MAN3= WWW::LongURL.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-WWW-LongURL/distinfo b/www/p5-WWW-LongURL/distinfo
new file mode 100644
index 000000000000..38dd7550cf2f
--- /dev/null
+++ b/www/p5-WWW-LongURL/distinfo
@@ -0,0 +1,2 @@
+SHA256 (WWW-LongURL-0.05.tar.gz) = 7dd82a3f3cefc4fa88819a0c7494645d62ee799e856d1d944ff5287602f79373
+SIZE (WWW-LongURL-0.05.tar.gz) = 26884
diff --git a/www/p5-WWW-LongURL/pkg-descr b/www/p5-WWW-LongURL/pkg-descr
new file mode 100644
index 000000000000..c951d4896d50
--- /dev/null
+++ b/www/p5-WWW-LongURL/pkg-descr
@@ -0,0 +1,4 @@
+WWW::LongURL is a simple interface for using the LongURL API to expand
+shortened URLs.
+
+WWW: http://search.cpan.org/dist/WWW-LongURL/
diff --git a/www/p5-WWW-LongURL/pkg-plist b/www/p5-WWW-LongURL/pkg-plist
new file mode 100644
index 000000000000..dcd6a30e00a2
--- /dev/null
+++ b/www/p5-WWW-LongURL/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/WWW/LongURL.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/LongURL/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW/LongURL
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/WWW
+@dirrmtry %%SITE_PERL%%/WWW