aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks/sanduhr
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-09-14 06:53:20 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-09-14 06:53:20 +0000
commit47d5cca8456d3bbc564f15943c4b0340d8191dab (patch)
tree6d9f641bc6032a547a2cbf2679ff8150384ad1f9 /x11-clocks/sanduhr
parentd1840354ccef405a447aaeb34e44477b4b89bfa0 (diff)
downloadports-47d5cca8456d3bbc564f15943c4b0340d8191dab.tar.gz
ports-47d5cca8456d3bbc564f15943c4b0340d8191dab.zip
Add sanduhr - an alarm clock for GNOME desktop designed as a sand-glass.
Notes
Notes: svn path=/head/; revision=32599
Diffstat (limited to 'x11-clocks/sanduhr')
-rw-r--r--x11-clocks/sanduhr/Makefile42
-rw-r--r--x11-clocks/sanduhr/distinfo1
-rw-r--r--x11-clocks/sanduhr/pkg-comment1
-rw-r--r--x11-clocks/sanduhr/pkg-descr14
-rw-r--r--x11-clocks/sanduhr/pkg-plist37
5 files changed, 95 insertions, 0 deletions
diff --git a/x11-clocks/sanduhr/Makefile b/x11-clocks/sanduhr/Makefile
new file mode 100644
index 000000000000..6e2c9c26c698
--- /dev/null
+++ b/x11-clocks/sanduhr/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: sanduhr
+# Date created: 14 September 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sanduhr
+PORTVERSION= 0.3.50
+CATEGORIES= x11-clocks gnome
+MASTER_SITES= http://www.mathematik.uni-kl.de/~wwwstoch/voss/
+
+MAINTAINER= sobomax@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore \
+ ${X11BASE}/share/gnome/sounds/login.wav:${PORTSDIR}/audio/gnomeaudio
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= sanduhr.1
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+.include <bsd.port.mk>
diff --git a/x11-clocks/sanduhr/distinfo b/x11-clocks/sanduhr/distinfo
new file mode 100644
index 000000000000..a25f12ca984d
--- /dev/null
+++ b/x11-clocks/sanduhr/distinfo
@@ -0,0 +1 @@
+MD5 (sanduhr-0.3.50.tar.gz) = 9f25b04f18cd453d44c7002b208f8ddd
diff --git a/x11-clocks/sanduhr/pkg-comment b/x11-clocks/sanduhr/pkg-comment
new file mode 100644
index 000000000000..7d016927fbc8
--- /dev/null
+++ b/x11-clocks/sanduhr/pkg-comment
@@ -0,0 +1 @@
+An alarm clock for GNOME desktop designed as a sand-glass
diff --git a/x11-clocks/sanduhr/pkg-descr b/x11-clocks/sanduhr/pkg-descr
new file mode 100644
index 000000000000..2b528119f5fe
--- /dev/null
+++ b/x11-clocks/sanduhr/pkg-descr
@@ -0,0 +1,14 @@
+SandUhr is an alarm clock, which is designed as a sand-glass. The program uses
+the X Window System and the GNOME desktop environment. The alarm is delivered
+to you by either ringing the console bell, by playing a sound file, or by
+starting an external program of your choice.
+
+The program is fully integrated into the GNOME application framework.
+
+o Drag and drop: you may drop a color onto the timer to change the sand's visual
+ appearance.
+o It uses the GNOME help system to provide a manual.
+o Use of CORBA: The program provides a CORBA interface. So you may control the
+ SandUhr from within your own programs.
+
+WWW: http://www.mathematik.uni-kl.de/~wwwstoch/voss/sanduhr.html
diff --git a/x11-clocks/sanduhr/pkg-plist b/x11-clocks/sanduhr/pkg-plist
new file mode 100644
index 000000000000..19917718c6fc
--- /dev/null
+++ b/x11-clocks/sanduhr/pkg-plist
@@ -0,0 +1,37 @@
+bin/sanduhr
+etc/CORBA/servers/sanduhr.gnorba
+share/gnome/apps/Utilities/sanduhr.desktop
+share/gnome/help/sanduhr/C/docbook.css
+share/gnome/help/sanduhr/C/index.html
+share/gnome/help/sanduhr/C/intro.html
+share/gnome/help/sanduhr/C/invocation.html
+share/gnome/help/sanduhr/C/ln14.html
+share/gnome/help/sanduhr/C/preferences.html
+share/gnome/help/sanduhr/C/sanduhr.html
+share/gnome/help/sanduhr/C/timespec.html
+share/gnome/help/sanduhr/C/topic.dat
+share/gnome/help/sanduhr/de/docbook.css
+share/gnome/help/sanduhr/de/index.html
+share/gnome/help/sanduhr/de/intro.html
+share/gnome/help/sanduhr/de/invocation.html
+share/gnome/help/sanduhr/de/ln14.html
+share/gnome/help/sanduhr/de/preferences.html
+share/gnome/help/sanduhr/de/sanduhr.html
+share/gnome/help/sanduhr/de/timespec.html
+share/gnome/help/sanduhr/de/topic.dat
+share/gnome/idl/sanduhr.idl
+share/gnome/pixmaps/sanduhr/about.png
+share/gnome/pixmaps/sanduhr/back.png
+share/gnome/pixmaps/sanduhr/front.png
+share/gnome/pixmaps/sanduhr/icon.xpm
+share/gnome/pixmaps/sanduhr/logo.png
+share/gnome/pixmaps/sanduhr/mask.png
+share/gnome/sounds/sanduhr/bell.wav
+share/locale/de/LC_MESSAGES/sanduhr.mo
+@dirrm share/gnome/sounds/sanduhr
+@dirrm share/gnome/pixmaps/sanduhr
+@dirrm share/gnome/help/sanduhr/de/images
+@dirrm share/gnome/help/sanduhr/de
+@dirrm share/gnome/help/sanduhr/C/images
+@dirrm share/gnome/help/sanduhr/C
+@dirrm share/gnome/help/sanduhr