aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2005-01-08 10:58:55 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2005-01-08 10:58:55 +0000
commit37bfaf52b3f8dbc59e190231e65e83e736524a8e (patch)
tree62c878de10c57cdc45a7dc91ec892913c38068a2 /x11-clocks
parenta2e723382c857cb52517547dd55100b5817933d1 (diff)
downloadports-37bfaf52b3f8dbc59e190231e65e83e736524a8e.tar.gz
ports-37bfaf52b3f8dbc59e190231e65e83e736524a8e.zip
Add option "-H" - horizontal offset (e.g. osdclock -H 100).
PR: ports/75924 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=125772
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/osdclock/Makefile1
-rw-r--r--x11-clocks/osdclock/files/patch-osd_clock.c41
2 files changed, 37 insertions, 5 deletions
diff --git a/x11-clocks/osdclock/Makefile b/x11-clocks/osdclock/Makefile
index a25cc238704f..9228e9e9a1fd 100644
--- a/x11-clocks/osdclock/Makefile
+++ b/x11-clocks/osdclock/Makefile
@@ -7,6 +7,7 @@
PORTNAME= osdclock
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= x11-clocks
MASTER_SITES= http://leftorium.net/software/
DISTNAME= osd_clock-${PORTVERSION}
diff --git a/x11-clocks/osdclock/files/patch-osd_clock.c b/x11-clocks/osdclock/files/patch-osd_clock.c
index 05c1b61cd291..b21075a9c108 100644
--- a/x11-clocks/osdclock/files/patch-osd_clock.c
+++ b/x11-clocks/osdclock/files/patch-osd_clock.c
@@ -1,6 +1,36 @@
---- osd_clock.c.orig Thu Mar 29 19:10:24 2001
-+++ osd_clock.c Fri Aug 6 08:05:45 2004
-@@ -109,7 +109,15 @@
+--- osd_clock.c.orig Sun Apr 8 02:50:01 2001
++++ osd_clock.c Tue Jan 4 16:27:20 2005
+@@ -57,8 +57,9 @@
+ int offset = 0;
+ int shadow = 2;
+ int interval = 1;
+-
+- while ((c = getopt_long(argc ,argv,"f:c:d:F:i:s:o:tbh",
++ int horizontal_offset = 0;
++
++ while ((c = getopt_long(argc ,argv,"f:c:d:F:i:s:o:tbH:h",
+ long_options, NULL)) != -1)
+ {
+ switch(c)
+@@ -90,6 +91,9 @@
+ case 'b':
+ pos = XOSD_bottom;
+ break;
++ case 'H':
++ horizontal_offset = atoi(optarg);
++ break;
+ case 'h':
+ printf("USAGE: %s [-flag args]\n"
+ "\t-f\tfully qualified font. default: fixed\n"
+@@ -102,6 +106,7 @@
+ "\t-d\tDelay (time the clock stays on screen when it's updated)\n"
+ "\t\tin seconds\n"
+ "\t-i\tInterval (time between updates) in seconds\n"
++ "\t-H\thorizontal offset. default: 0\n"
+ "\t-h\tthis help message\n",
+ argv[0]);
+ return EXIT_SUCCESS;
+@@ -109,7 +114,16 @@
}
}
@@ -12,13 +42,14 @@
+ xosd_set_timeout(osd, delay);
+ xosd_set_pos(osd, pos);
+ xosd_set_vertical_offset(osd, offset);
++ xosd_set_horizontal_offset(osd, horizontal_offset);
+ xosd_set_shadow_offset(osd, shadow);
+
if (!osd)
{
fprintf (stderr, "Error initializing osd\n");
-@@ -127,11 +135,12 @@
- output = malloc(255 * sizeof(char));
+@@ -126,11 +140,12 @@
+
strftime(output, 255, format, localtime(&curr_time));
- xosd_display (osd, 1, XOSD_string, output);