aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-02-19 13:26:41 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-02-19 13:26:41 +0000
commitca4548562ef6213f0b1cf5cc3d633fd604b96844 (patch)
tree823f36f2a507f245dbd74dbaeff6de280e3c9a7e /x11-clocks
parent9b67d42adbae5de4024300f2026f8193ed3b4e67 (diff)
downloadports-ca4548562ef6213f0b1cf5cc3d633fd604b96844.tar.gz
ports-ca4548562ef6213f0b1cf5cc3d633fd604b96844.zip
Fix Kweather for !english users.
Obtained from: KDE CVS (via Frerich Raabe <raabe@kde.org> Reported by: arved, Michael Nottebrock <michaelnottebrock@gmx.net>, many
Notes
Notes: svn path=/head/; revision=75885
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/kdetoys3/Makefile1
-rw-r--r--x11-clocks/kdetoys3/files/patch-kweather-kweather.cpp17
-rw-r--r--x11-clocks/kdetoys3/files/patch-kweather-reportmain.cpp23
-rw-r--r--x11-clocks/kdetoys4/Makefile1
-rw-r--r--x11-clocks/kdetoys4/files/patch-kweather-kweather.cpp17
-rw-r--r--x11-clocks/kdetoys4/files/patch-kweather-reportmain.cpp23
6 files changed, 82 insertions, 0 deletions
diff --git a/x11-clocks/kdetoys3/Makefile b/x11-clocks/kdetoys3/Makefile
index 627a3d301094..59444817b9c9 100644
--- a/x11-clocks/kdetoys3/Makefile
+++ b/x11-clocks/kdetoys3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdetoys
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-clocks kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11-clocks/kdetoys3/files/patch-kweather-kweather.cpp b/x11-clocks/kdetoys3/files/patch-kweather-kweather.cpp
new file mode 100644
index 000000000000..f1aaf54edb3f
--- /dev/null
+++ b/x11-clocks/kdetoys3/files/patch-kweather-kweather.cpp
@@ -0,0 +1,17 @@
+Index: kweather.cpp
+===================================================================
+RCS file: /home/kde/kdetoys/kweather/kweather.cpp,v
+retrieving revision 1.47
+retrieving revision 1.48
+diff -u -r1.47 -r1.48
+--- kweather.cpp 8 Jan 2003 12:40:57 -0000 1.47
++++ kweather/kweather.cpp 24 Jan 2003 21:55:43 -0000 1.48
+@@ -672,7 +672,7 @@
+ if (!client->isApplicationRegistered("KWeatherService"))
+ {
+ kdDebug() << "Could not find service so I am starting it..." << endl;
+- if(!KApplication::startServiceByName("KWeatherService",QStringList(), &error,&appID ))
++ if(!KApplication::startServiceByDesktopName("kweatherservice",QStringList(), &error,&appID ))
+
+ {
+ kdDebug() << "Starting KWeatherService failed with message: " << error << endl;
diff --git a/x11-clocks/kdetoys3/files/patch-kweather-reportmain.cpp b/x11-clocks/kdetoys3/files/patch-kweather-reportmain.cpp
new file mode 100644
index 000000000000..37e2737c4751
--- /dev/null
+++ b/x11-clocks/kdetoys3/files/patch-kweather-reportmain.cpp
@@ -0,0 +1,23 @@
+Index: reportmain.cpp
+===================================================================
+RCS file: /home/kde/kdetoys/kweather/reportmain.cpp,v
+retrieving revision 1.4
+retrieving revision 1.5
+diff -u -r1.4 -r1.5
+--- reportmain.cpp 9 Dec 2002 06:55:56 -0000 1.4
++++ kweather/reportmain.cpp 24 Jan 2003 21:55:43 -0000 1.5
+@@ -1,4 +1,4 @@
+-/* $Id: reportmain.cpp,v 1.4 2002/12/09 06:55:56 mlaurent Exp $ */
++/* $Id: reportmain.cpp,v 1.5 2003/01/24 21:55:43 cloose Exp $ */
+
+ #include <stdlib.h>
+ #include <kapplication.h>
+@@ -27,7 +27,7 @@
+ QCString appID = "";
+ if (!client->isApplicationRegistered("kweatherservice"))
+ {
+- if(KApplication::startServiceByName("kweatherservice",QStringList(), &error, &appID ))
++ if(KApplication::startServiceByDesktopName("kweatherservice",QStringList(), &error, &appID ))
+ {
+ kdDebug() << "Starting kweatherservice failed with message: " << error << endl;
+ exit(0);
diff --git a/x11-clocks/kdetoys4/Makefile b/x11-clocks/kdetoys4/Makefile
index 627a3d301094..59444817b9c9 100644
--- a/x11-clocks/kdetoys4/Makefile
+++ b/x11-clocks/kdetoys4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdetoys
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11-clocks kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11-clocks/kdetoys4/files/patch-kweather-kweather.cpp b/x11-clocks/kdetoys4/files/patch-kweather-kweather.cpp
new file mode 100644
index 000000000000..f1aaf54edb3f
--- /dev/null
+++ b/x11-clocks/kdetoys4/files/patch-kweather-kweather.cpp
@@ -0,0 +1,17 @@
+Index: kweather.cpp
+===================================================================
+RCS file: /home/kde/kdetoys/kweather/kweather.cpp,v
+retrieving revision 1.47
+retrieving revision 1.48
+diff -u -r1.47 -r1.48
+--- kweather.cpp 8 Jan 2003 12:40:57 -0000 1.47
++++ kweather/kweather.cpp 24 Jan 2003 21:55:43 -0000 1.48
+@@ -672,7 +672,7 @@
+ if (!client->isApplicationRegistered("KWeatherService"))
+ {
+ kdDebug() << "Could not find service so I am starting it..." << endl;
+- if(!KApplication::startServiceByName("KWeatherService",QStringList(), &error,&appID ))
++ if(!KApplication::startServiceByDesktopName("kweatherservice",QStringList(), &error,&appID ))
+
+ {
+ kdDebug() << "Starting KWeatherService failed with message: " << error << endl;
diff --git a/x11-clocks/kdetoys4/files/patch-kweather-reportmain.cpp b/x11-clocks/kdetoys4/files/patch-kweather-reportmain.cpp
new file mode 100644
index 000000000000..37e2737c4751
--- /dev/null
+++ b/x11-clocks/kdetoys4/files/patch-kweather-reportmain.cpp
@@ -0,0 +1,23 @@
+Index: reportmain.cpp
+===================================================================
+RCS file: /home/kde/kdetoys/kweather/reportmain.cpp,v
+retrieving revision 1.4
+retrieving revision 1.5
+diff -u -r1.4 -r1.5
+--- reportmain.cpp 9 Dec 2002 06:55:56 -0000 1.4
++++ kweather/reportmain.cpp 24 Jan 2003 21:55:43 -0000 1.5
+@@ -1,4 +1,4 @@
+-/* $Id: reportmain.cpp,v 1.4 2002/12/09 06:55:56 mlaurent Exp $ */
++/* $Id: reportmain.cpp,v 1.5 2003/01/24 21:55:43 cloose Exp $ */
+
+ #include <stdlib.h>
+ #include <kapplication.h>
+@@ -27,7 +27,7 @@
+ QCString appID = "";
+ if (!client->isApplicationRegistered("kweatherservice"))
+ {
+- if(KApplication::startServiceByName("kweatherservice",QStringList(), &error, &appID ))
++ if(KApplication::startServiceByDesktopName("kweatherservice",QStringList(), &error, &appID ))
+ {
+ kdDebug() << "Starting kweatherservice failed with message: " << error << endl;
+ exit(0);