aboutsummaryrefslogtreecommitdiff
path: root/x11-clocks
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-01-07 00:35:38 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-01-07 00:35:38 +0000
commit0f4a49c72c8ba28afa232b34d6519f5f8f9db281 (patch)
tree67abba83d64739ab2c0765e01a07be1d064e2f9f /x11-clocks
parent89cb5042c86eeaf822b070334ba75a51e478d1cb (diff)
downloadports-0f4a49c72c8ba28afa232b34d6519f5f8f9db281.tar.gz
ports-0f4a49c72c8ba28afa232b34d6519f5f8f9db281.zip
Add gdesklets-praytime, a desklet that displays muslim prayer times
for a given city. PR: ports/60992 Submitted by: Vincent Tantardini <vinc@FreeBSD-fr.org>
Notes
Notes: svn path=/head/; revision=97518
Diffstat (limited to 'x11-clocks')
-rw-r--r--x11-clocks/Makefile1
-rw-r--r--x11-clocks/gdesklets-praytime/Makefile46
-rw-r--r--x11-clocks/gdesklets-praytime/distinfo1
-rw-r--r--x11-clocks/gdesklets-praytime/files/patch-Install_PrayerTime_Sensor.bin19
-rw-r--r--x11-clocks/gdesklets-praytime/pkg-descr4
-rw-r--r--x11-clocks/gdesklets-praytime/pkg-message9
-rw-r--r--x11-clocks/gdesklets-praytime/pkg-plist18
7 files changed, 98 insertions, 0 deletions
diff --git a/x11-clocks/Makefile b/x11-clocks/Makefile
index db3771be7ed3..76479f7c1ee7 100644
--- a/x11-clocks/Makefile
+++ b/x11-clocks/Makefile
@@ -13,6 +13,7 @@
SUBDIR += eyeclock
SUBDIR += gdesklets-clock
SUBDIR += gdesklets-countdown
+ SUBDIR += gdesklets-praytime
SUBDIR += glclock
SUBDIR += kdetoys3
SUBDIR += mlclock
diff --git a/x11-clocks/gdesklets-praytime/Makefile b/x11-clocks/gdesklets-praytime/Makefile
new file mode 100644
index 000000000000..1e55dd4aefa6
--- /dev/null
+++ b/x11-clocks/gdesklets-praytime/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: gdesklets-praytime
+# Date created: 06 January 2004
+# Whom: Vincent Tantardini <vinc@FreeBSD-fr.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= praytime
+PORTVERSION= 0.21
+CATEGORIES= x11-clocks gnome
+MASTER_SITES= http://gdesklets.gnomedesktop.org/files/
+PKGNAMEPREFIX= gdesklets-
+DISTNAME= ${PORTNAME}-desklet-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Display muslim prayer times on your desktop
+
+RUN_DEPENDS= ${X11BASE}/libdata/pkgconfig/gdesklets-core.pc:${PORTSDIR}/deskutils/gdesklets
+
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_PYTHON= yes
+
+NAME= PrayerTime
+DATADIR= ${PREFIX}/share/gnome
+WRKSRC= ${WRKDIR}/${PORTNAME}-desklet-${PORTVERSION}
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+do-build:
+ @${WRKSRC}/Install_${NAME}_Sensor.bin --nomsg ${WRKSRC}
+ @${CAT} pkg-message | ${SED} -e 's|%%PREFIX%%|${PREFIX}|g ; s|%%NAME%%|${NAME}|g' > ${PKGMESSAGE}
+
+do-install:
+ @${MKDIR} ${DATADIR}/gdesklets/Displays/${NAME}/gfx
+ @${MKDIR} ${DATADIR}/gdesklets/Displays/${NAME}/icons
+ @${MKDIR} ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/*.py ${DATADIR}/gdesklets/Sensors/${NAME}/
+ @${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py ${DATADIR}/gdesklets/Sensors/${NAME}
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/*.display ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/gfx/*.png ${DATADIR}/gdesklets/Displays/${NAME}/gfx/
+ @${INSTALL_DATA} ${WRKSRC}/${NAME}/icons/*.png ${DATADIR}/gdesklets/Displays/${NAME}/icons/
+ @${INSTALL_DATA} ${WRKSRC}/README ${DATADIR}/gdesklets/Displays/${NAME}/
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/x11-clocks/gdesklets-praytime/distinfo b/x11-clocks/gdesklets-praytime/distinfo
new file mode 100644
index 000000000000..0be4155d5603
--- /dev/null
+++ b/x11-clocks/gdesklets-praytime/distinfo
@@ -0,0 +1 @@
+MD5 (praytime-desklet-0.21.tar.bz2) = 6749b850178224ef7de846974bdb5fda
diff --git a/x11-clocks/gdesklets-praytime/files/patch-Install_PrayerTime_Sensor.bin b/x11-clocks/gdesklets-praytime/files/patch-Install_PrayerTime_Sensor.bin
new file mode 100644
index 000000000000..284718b66b55
--- /dev/null
+++ b/x11-clocks/gdesklets-praytime/files/patch-Install_PrayerTime_Sensor.bin
@@ -0,0 +1,19 @@
+--- Install_PrayerTime_Sensor.bin.orig Tue Jan 6 21:50:08 2004
++++ Install_PrayerTime_Sensor.bin Tue Jan 6 21:50:33 2004
+@@ -75,15 +75,9 @@
+ else:
+ cmd = "mkdir -p %(destination)s; cd %(destination)s; " \
+ "LANG=C tar -xzvf %(tmp)s 2>&1"
+- fail, out = commands.getstatusoutput(cmd % vars())
++ commands.getstatusoutput(cmd % vars())
+ os.unlink(tmp)
+
+- if (fail):
+- if (no_message): print ERROR_TAR + out
+- else: message(ERROR_TAR + out, "error")
+- sys.exit(1)
+-
+- print out
+ if (not list_only):
+ if (no_message): print SUCCESS
+ else: message(SUCCESS, "info")
diff --git a/x11-clocks/gdesklets-praytime/pkg-descr b/x11-clocks/gdesklets-praytime/pkg-descr
new file mode 100644
index 000000000000..0e99d7bd51ec
--- /dev/null
+++ b/x11-clocks/gdesklets-praytime/pkg-descr
@@ -0,0 +1,4 @@
+This desklet obtains the prayer times for the respective location
+from prayer.al-islam.com and displays them.
+
+WWW: http://gdesklets.gnomedesktop.org/
diff --git a/x11-clocks/gdesklets-praytime/pkg-message b/x11-clocks/gdesklets-praytime/pkg-message
new file mode 100644
index 000000000000..ddb9640c7c1e
--- /dev/null
+++ b/x11-clocks/gdesklets-praytime/pkg-message
@@ -0,0 +1,9 @@
+
+To list displays installed by this port:
+
+ gdesklets %%PREFIX%%/share/gnome/gdesklets/Displays/%%NAME%%
+
+To add this desklet to your desktop:
+
+ gdesklets %%PREFIX%%/share/gnome/gdesklets/Displays/%%NAME%%/<name>.display
+
diff --git a/x11-clocks/gdesklets-praytime/pkg-plist b/x11-clocks/gdesklets-praytime/pkg-plist
new file mode 100644
index 000000000000..047d13807c8a
--- /dev/null
+++ b/x11-clocks/gdesklets-praytime/pkg-plist
@@ -0,0 +1,18 @@
+share/gnome/gdesklets/Displays/PrayerTime/README
+share/gnome/gdesklets/Displays/PrayerTime/gfx/bg-left.png
+share/gnome/gdesklets/Displays/PrayerTime/gfx/bg-right.png
+share/gnome/gdesklets/Displays/PrayerTime/gfx/bg-weather.png
+share/gnome/gdesklets/Displays/PrayerTime/icons/asr.png
+share/gnome/gdesklets/Displays/PrayerTime/icons/fajr.png
+share/gnome/gdesklets/Displays/PrayerTime/icons/isha.png
+share/gnome/gdesklets/Displays/PrayerTime/icons/maghrib.png
+share/gnome/gdesklets/Displays/PrayerTime/icons/zuhr.png
+share/gnome/gdesklets/Displays/PrayerTime/prayboard.display
+share/gnome/gdesklets/Displays/PrayerTime/praytime.display
+share/gnome/gdesklets/Sensors/PrayerTime/__init__.py
+share/gnome/gdesklets/Sensors/PrayerTime/__init__.pyc
+share/gnome/gdesklets/Sensors/PrayerTime/__init__.pyo
+@dirrm share/gnome/gdesklets/Sensors/PrayerTime
+@dirrm share/gnome/gdesklets/Displays/PrayerTime/icons
+@dirrm share/gnome/gdesklets/Displays/PrayerTime/gfx
+@dirrm share/gnome/gdesklets/Displays/PrayerTime