aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 14:49:26 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-05-31 14:49:26 +0000
commitebb04f49c21a7da2953675b331eb7c9b1cb7d35b (patch)
tree334e2b5d414b5b4e2d6139fd6873cb1dfd72552a /x11-drivers
parent1884ff8c5075f3e906d1bd2d422dba3269b523d8 (diff)
downloadports-ebb04f49c21a7da2953675b331eb7c9b1cb7d35b.tar.gz
ports-ebb04f49c21a7da2953675b331eb7c9b1cb7d35b.zip
Convert to new options framework
Notes
Notes: svn path=/head/; revision=297880
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/input-wacom/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/x11-drivers/input-wacom/Makefile b/x11-drivers/input-wacom/Makefile
index c03aedee0703..1c483b12c858 100644
--- a/x11-drivers/input-wacom/Makefile
+++ b/x11-drivers/input-wacom/Makefile
@@ -50,15 +50,16 @@ CONFIGURE_WRKSRC= ${WRKDIR}/${LINUXWACOM}
USE_AUTOTOOLS= autoconf
MAKE_ARGS+= UDEV_CFLAGS=""
+OPTIONS_DEFINE= UWACOMKLD
+UWACOMKLD_DESC= Install USB kernel module (not supported on 8.x)
+
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800064
-OPTIONS= UWACOMKLD "Install USB kernel module (not supported on 8.x)" Off
-.else
-OPTIONS= UWACOMKLD "Install USB kernel module (not supported on 8.x)" On
+.if ${OSVERSION} < 800064
+OPTIONS_DEFAULT= UWACOMKLD
.endif
-.if defined(WITH_UWACOMKLD)
+.if ${PORT_OPTIONS:MUWACOMKLD}
.if ${OSVERSION} >= 800064
BROKEN= does not build with USB support
.endif
@@ -70,7 +71,7 @@ PORTTYPE= serial
.endif
do-build:
-.if defined(WITH_UWACOMKLD)
+.if ${PORT_OPTIONS:MUWACOMKLD}
@cd ${WRKDIR}/uwacom \
&& ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS}
.endif
@@ -78,7 +79,7 @@ do-build:
&& ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_ARGS}
do-install:
-.if defined(WITH_UWACOMKLD)
+.if ${PORT_OPTIONS:MUWACOMKLD}
@${MKDIR} ${KMODDIR}
@${INSTALL_KLD} ${WRKDIR}/uwacom/uwacom.ko ${KMODDIR}/
.endif