aboutsummaryrefslogtreecommitdiff
path: root/x11-drivers
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2010-05-07 05:12:36 +0000
committerMartin Wilke <miwi@FreeBSD.org>2010-05-07 05:12:36 +0000
commit782d0a4471497c04fffad12bf27383357101ea54 (patch)
tree4cd9a82e2244d400c5979cae83786faa998a0e52 /x11-drivers
parentbad881dd75376827336b2541941f4c7b3e7b829d (diff)
downloadports-782d0a4471497c04fffad12bf27383357101ea54.tar.gz
ports-782d0a4471497c04fffad12bf27383357101ea54.zip
- Fix build on 6.X
Notes
Notes: svn path=/head/; revision=253883
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-apm/Makefile8
-rw-r--r--x11-drivers/xf86-video-ark/Makefile8
-rw-r--r--x11-drivers/xf86-video-ati/Makefile8
-rw-r--r--x11-drivers/xf86-video-ati613/Makefile8
-rw-r--r--x11-drivers/xf86-video-chips/Makefile8
-rw-r--r--x11-drivers/xf86-video-cirrus/Makefile8
-rw-r--r--x11-drivers/xf86-video-dummy/Makefile8
-rw-r--r--x11-drivers/xf86-video-fbdev/Makefile8
-rw-r--r--x11-drivers/xf86-video-glint/Makefile8
-rw-r--r--x11-drivers/xf86-video-i128/Makefile8
-rw-r--r--x11-drivers/xf86-video-i740/Makefile8
-rw-r--r--x11-drivers/xf86-video-intel/Makefile8
-rw-r--r--x11-drivers/xf86-video-mach64/Makefile8
-rw-r--r--x11-drivers/xf86-video-mga/Makefile9
-rw-r--r--x11-drivers/xf86-video-neomagic/Makefile8
-rw-r--r--x11-drivers/xf86-video-newport/Makefile8
-rw-r--r--x11-drivers/xf86-video-nv/Makefile8
-rw-r--r--x11-drivers/xf86-video-openchrome/Makefile8
-rw-r--r--x11-drivers/xf86-video-r128/Makefile8
-rw-r--r--x11-drivers/xf86-video-radeonhd-devel/Makefile8
-rw-r--r--x11-drivers/xf86-video-radeonhd/Makefile4
-rw-r--r--x11-drivers/xf86-video-rendition/Makefile8
-rw-r--r--x11-drivers/xf86-video-s3/Makefile8
-rw-r--r--x11-drivers/xf86-video-s3virge/Makefile8
-rw-r--r--x11-drivers/xf86-video-savage/Makefile8
-rw-r--r--x11-drivers/xf86-video-siliconmotion/Makefile8
-rw-r--r--x11-drivers/xf86-video-sis/Makefile8
-rw-r--r--x11-drivers/xf86-video-tdfx/Makefile8
-rw-r--r--x11-drivers/xf86-video-tga/Makefile8
-rw-r--r--x11-drivers/xf86-video-trident/Makefile8
-rw-r--r--x11-drivers/xf86-video-tseng/Makefile8
-rw-r--r--x11-drivers/xf86-video-vesa/Makefile8
-rw-r--r--x11-drivers/xf86-video-vmware/Makefile8
-rw-r--r--x11-drivers/xf86-video-voodoo/Makefile8
34 files changed, 236 insertions, 33 deletions
diff --git a/x11-drivers/xf86-video-apm/Makefile b/x11-drivers/xf86-video-apm/Makefile
index cce06334402a..05896bb90461 100644
--- a/x11-drivers/xf86-video-apm/Makefile
+++ b/x11-drivers/xf86-video-apm/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= apm.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-ark/Makefile b/x11-drivers/xf86-video-ark/Makefile
index 05ff06d4cc61..66470ea99fa0 100644
--- a/x11-drivers/xf86-video-ark/Makefile
+++ b/x11-drivers/xf86-video-ark/Makefile
@@ -15,4 +15,10 @@ COMMENT= X.Org ark display driver
XORG_CAT= driver
USE_XORG= xextproto
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-ati/Makefile b/x11-drivers/xf86-video-ati/Makefile
index 52b55d95499c..fd9c97284a4a 100644
--- a/x11-drivers/xf86-video-ati/Makefile
+++ b/x11-drivers/xf86-video-ati/Makefile
@@ -18,4 +18,10 @@ XORG_CAT= driver
USE_XORG= xf86driproto xineramaproto videoproto xf86miscproto xextproto glproto
MAN4= ati.4x radeon.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-ati613/Makefile b/x11-drivers/xf86-video-ati613/Makefile
index 52b55d95499c..fd9c97284a4a 100644
--- a/x11-drivers/xf86-video-ati613/Makefile
+++ b/x11-drivers/xf86-video-ati613/Makefile
@@ -18,4 +18,10 @@ XORG_CAT= driver
USE_XORG= xf86driproto xineramaproto videoproto xf86miscproto xextproto glproto
MAN4= ati.4x radeon.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-chips/Makefile b/x11-drivers/xf86-video-chips/Makefile
index 0c95049dc15d..15ef01c34bb6 100644
--- a/x11-drivers/xf86-video-chips/Makefile
+++ b/x11-drivers/xf86-video-chips/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= chips.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-cirrus/Makefile b/x11-drivers/xf86-video-cirrus/Makefile
index 1909893324a0..47ae0ce20f0f 100644
--- a/x11-drivers/xf86-video-cirrus/Makefile
+++ b/x11-drivers/xf86-video-cirrus/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= cirrus.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-dummy/Makefile b/x11-drivers/xf86-video-dummy/Makefile
index 7885594523c7..786ab73d5576 100644
--- a/x11-drivers/xf86-video-dummy/Makefile
+++ b/x11-drivers/xf86-video-dummy/Makefile
@@ -15,4 +15,10 @@ COMMENT= X.Org dummy display driver
XORG_CAT= driver
USE_XORG= videoproto xf86dgaproto
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-fbdev/Makefile b/x11-drivers/xf86-video-fbdev/Makefile
index bcd7abca5717..4d72da1707e0 100644
--- a/x11-drivers/xf86-video-fbdev/Makefile
+++ b/x11-drivers/xf86-video-fbdev/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto
MAN4= fbdev.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-glint/Makefile b/x11-drivers/xf86-video-glint/Makefile
index 99e349c89a61..62cea86ea49b 100644
--- a/x11-drivers/xf86-video-glint/Makefile
+++ b/x11-drivers/xf86-video-glint/Makefile
@@ -18,4 +18,10 @@ XORG_CAT= driver
USE_XORG= xf86driproto videoproto xextproto xf86dgaproto glproto
MAN4= glint.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-i128/Makefile b/x11-drivers/xf86-video-i128/Makefile
index a75a6f96e5b3..4d87e6c992b7 100644
--- a/x11-drivers/xf86-video-i128/Makefile
+++ b/x11-drivers/xf86-video-i128/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= i128.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-i740/Makefile b/x11-drivers/xf86-video-i740/Makefile
index 7513b721e0c7..b320e95644d4 100644
--- a/x11-drivers/xf86-video-i740/Makefile
+++ b/x11-drivers/xf86-video-i740/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= i740.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-intel/Makefile b/x11-drivers/xf86-video-intel/Makefile
index aa0d3bce8b3b..9d537bad6b5d 100644
--- a/x11-drivers/xf86-video-intel/Makefile
+++ b/x11-drivers/xf86-video-intel/Makefile
@@ -22,4 +22,10 @@ XORG_CAT= driver
USE_XORG= xvmc xineramaproto xextproto x11 xf86driproto glproto
MAN4= intel.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-mach64/Makefile b/x11-drivers/xf86-video-mach64/Makefile
index 40877d30b348..f7d3973e59b6 100644
--- a/x11-drivers/xf86-video-mach64/Makefile
+++ b/x11-drivers/xf86-video-mach64/Makefile
@@ -17,4 +17,10 @@ USE_GL= gl
XORG_CAT= driver
USE_XORG= glproto videoproto xextproto xf86driproto xf86miscproto xineramaproto
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-mga/Makefile b/x11-drivers/xf86-video-mga/Makefile
index 8ffe2ccff5f6..b53fe7395e03 100644
--- a/x11-drivers/xf86-video-mga/Makefile
+++ b/x11-drivers/xf86-video-mga/Makefile
@@ -25,4 +25,11 @@ pre-patch:
-e 's|MAXSHORT|SHRT_MAX|g' \
${WRKSRC}/src/mga_arc.c
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
+
diff --git a/x11-drivers/xf86-video-neomagic/Makefile b/x11-drivers/xf86-video-neomagic/Makefile
index f9d20360c356..8fef841fa9f5 100644
--- a/x11-drivers/xf86-video-neomagic/Makefile
+++ b/x11-drivers/xf86-video-neomagic/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto xf86dgaproto
MAN4= neomagic.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-newport/Makefile b/x11-drivers/xf86-video-newport/Makefile
index 18fce8099af6..340be9246ddc 100644
--- a/x11-drivers/xf86-video-newport/Makefile
+++ b/x11-drivers/xf86-video-newport/Makefile
@@ -21,4 +21,10 @@ post-patch:
-e 's|MAXSHORT|SHRT_MAX|g' \
${WRKSRC}/src/newport_accel.c
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-nv/Makefile b/x11-drivers/xf86-video-nv/Makefile
index e9980edaa84b..dc0b892f3631 100644
--- a/x11-drivers/xf86-video-nv/Makefile
+++ b/x11-drivers/xf86-video-nv/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= nv.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk> \ No newline at end of file
diff --git a/x11-drivers/xf86-video-openchrome/Makefile b/x11-drivers/xf86-video-openchrome/Makefile
index d3087e5335f7..85695f8680fb 100644
--- a/x11-drivers/xf86-video-openchrome/Makefile
+++ b/x11-drivers/xf86-video-openchrome/Makefile
@@ -24,4 +24,10 @@ MAKE_ARGS+= drivermandir=${LOCALBASE}/man/man4
ONLY_FOR_ARCHS= amd64 i386 ia64
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk> \ No newline at end of file
diff --git a/x11-drivers/xf86-video-r128/Makefile b/x11-drivers/xf86-video-r128/Makefile
index 899a8e3528dc..8cba4b04b7a6 100644
--- a/x11-drivers/xf86-video-r128/Makefile
+++ b/x11-drivers/xf86-video-r128/Makefile
@@ -18,4 +18,10 @@ XORG_CAT= driver
USE_XORG= glproto videoproto xextproto xf86driproto xf86miscproto xineramaproto
MAN4= r128.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-radeonhd-devel/Makefile b/x11-drivers/xf86-video-radeonhd-devel/Makefile
index 56e47fdee3c9..14c24ef77a51 100644
--- a/x11-drivers/xf86-video-radeonhd-devel/Makefile
+++ b/x11-drivers/xf86-video-radeonhd-devel/Makefile
@@ -37,4 +37,10 @@ post-install:
${INSTALL_PROGRAM} ${WRKSRC}/utils/conntest/rhd_conntest ${PREFIX}/sbin
${INSTALL_PROGRAM} ${WRKSRC}/utils/conntest/rhd_dump ${PREFIX}/sbin
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-radeonhd/Makefile b/x11-drivers/xf86-video-radeonhd/Makefile
index 63dae81ad6fd..c005f5907f55 100644
--- a/x11-drivers/xf86-video-radeonhd/Makefile
+++ b/x11-drivers/xf86-video-radeonhd/Makefile
@@ -40,4 +40,8 @@ post-install:
${INSTALL_PROGRAM} ${WRKSRC}/utils/conntest/rhd_dump ${PREFIX}/sbin
.endif
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-rendition/Makefile b/x11-drivers/xf86-video-rendition/Makefile
index 434b64c36633..64a4b1489693 100644
--- a/x11-drivers/xf86-video-rendition/Makefile
+++ b/x11-drivers/xf86-video-rendition/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= xextproto
MAN4= rendition.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-s3/Makefile b/x11-drivers/xf86-video-s3/Makefile
index c5f0f62fdc2f..49b4bc669602 100644
--- a/x11-drivers/xf86-video-s3/Makefile
+++ b/x11-drivers/xf86-video-s3/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= s3.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-s3virge/Makefile b/x11-drivers/xf86-video-s3virge/Makefile
index bfda8931ca44..57ec08c899a7 100644
--- a/x11-drivers/xf86-video-s3virge/Makefile
+++ b/x11-drivers/xf86-video-s3virge/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= s3virge.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-savage/Makefile b/x11-drivers/xf86-video-savage/Makefile
index d518df3c2120..d81e3deba947 100644
--- a/x11-drivers/xf86-video-savage/Makefile
+++ b/x11-drivers/xf86-video-savage/Makefile
@@ -18,4 +18,10 @@ XORG_CAT= driver
USE_XORG= xf86driproto videoproto xextproto glproto
MAN4= savage.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-siliconmotion/Makefile b/x11-drivers/xf86-video-siliconmotion/Makefile
index cfa486f576bd..0d4939173c87 100644
--- a/x11-drivers/xf86-video-siliconmotion/Makefile
+++ b/x11-drivers/xf86-video-siliconmotion/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= siliconmotion.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-sis/Makefile b/x11-drivers/xf86-video-sis/Makefile
index 9e69a2401da0..ffd3258e3e96 100644
--- a/x11-drivers/xf86-video-sis/Makefile
+++ b/x11-drivers/xf86-video-sis/Makefile
@@ -20,4 +20,10 @@ XORG_CAT= driver
USE_XORG= xf86dgaproto xf86driproto xineramaproto videoproto xf86miscproto xextproto glproto
MAN4= sis.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-tdfx/Makefile b/x11-drivers/xf86-video-tdfx/Makefile
index e06236683aaa..070a516d622c 100644
--- a/x11-drivers/xf86-video-tdfx/Makefile
+++ b/x11-drivers/xf86-video-tdfx/Makefile
@@ -18,4 +18,10 @@ XORG_CAT= driver
USE_XORG= xf86driproto videoproto xextproto glproto
MAN4= tdfx.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-tga/Makefile b/x11-drivers/xf86-video-tga/Makefile
index 4ffe5dfbf894..1a4babbe6489 100644
--- a/x11-drivers/xf86-video-tga/Makefile
+++ b/x11-drivers/xf86-video-tga/Makefile
@@ -15,4 +15,10 @@ COMMENT= X.Org tga display driver
XORG_CAT= driver
USE_XORG= videoproto xextproto xf86dgaproto
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-trident/Makefile b/x11-drivers/xf86-video-trident/Makefile
index 97b3c1d368ff..58a47b23c0f4 100644
--- a/x11-drivers/xf86-video-trident/Makefile
+++ b/x11-drivers/xf86-video-trident/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto xf86dgaproto
MAN4= trident.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-tseng/Makefile b/x11-drivers/xf86-video-tseng/Makefile
index 51c45edb1b85..6f693132343a 100644
--- a/x11-drivers/xf86-video-tseng/Makefile
+++ b/x11-drivers/xf86-video-tseng/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= videoproto xextproto
MAN4= tseng.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-vesa/Makefile b/x11-drivers/xf86-video-vesa/Makefile
index 815964632a39..4ef5ad73d5dc 100644
--- a/x11-drivers/xf86-video-vesa/Makefile
+++ b/x11-drivers/xf86-video-vesa/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= xextproto
MAN4= vesa.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-vmware/Makefile b/x11-drivers/xf86-video-vmware/Makefile
index 61970eb9a522..ffe26ac35f14 100644
--- a/x11-drivers/xf86-video-vmware/Makefile
+++ b/x11-drivers/xf86-video-vmware/Makefile
@@ -17,4 +17,10 @@ USE_XORG= xextproto xineramaproto videoproto
MAN4= vmware.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/x11-drivers/xf86-video-voodoo/Makefile b/x11-drivers/xf86-video-voodoo/Makefile
index 7cc591a48b3d..35f0c105a1ec 100644
--- a/x11-drivers/xf86-video-voodoo/Makefile
+++ b/x11-drivers/xf86-video-voodoo/Makefile
@@ -16,4 +16,10 @@ XORG_CAT= driver
USE_XORG= xf86dgaproto xextproto
MAN4= voodoo.4x
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+USE_GCC= 4.2+
+.endif
+
+.include <bsd.port.post.mk>