aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/krusader2/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-04-26 19:31:15 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-04-26 19:31:15 +0000
commit9aac5771a1be24f3dadf22334849877f916d0368 (patch)
tree485759e5a8b2135d2e88b28ef162cd586c8d4a11 /x11-fm/krusader2/Makefile
parentdd9f87a045700b22bea4c635efbf88fd8105e667 (diff)
downloadports-9aac5771a1be24f3dadf22334849877f916d0368.tar.gz
ports-9aac5771a1be24f3dadf22334849877f916d0368.zip
- Update to 2.0.0
PR: 133615 Submitted by: Heiner <h.eichmann@gmx.de> (maintainer)
Notes
Notes: svn path=/head/; revision=232782
Diffstat (limited to 'x11-fm/krusader2/Makefile')
-rw-r--r--x11-fm/krusader2/Makefile38
1 files changed, 10 insertions, 28 deletions
diff --git a/x11-fm/krusader2/Makefile b/x11-fm/krusader2/Makefile
index 953948946814..a0b9be4c398c 100644
--- a/x11-fm/krusader2/Makefile
+++ b/x11-fm/krusader2/Makefile
@@ -6,41 +6,23 @@
#
PORTNAME= krusader
-PORTVERSION= 1.90.0
-PORTREVISION= 1
+PORTVERSION= 2.0.0
CATEGORIES= x11-fm kde
MASTER_SITES= SF
MAINTAINER= h.eichmann@gmx.de
COMMENT= A two window file-manager for KDE, like midnight or norton commander
-USE_KDELIBS_VER=3
-USE_AUTOTOOLS= libtool:15
-USE_GMAKE= yes
+USE_KDE4= kdelibs kdeprefix kdehier automoc4
+KDE4_BUILDENV= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui network xml moc_build qmake_build\
+ rcc_build uic_build
USE_GETTEXT= yes
+USE_ICONV= yes
+MAKE_JOBS_UNSAFE= yes
-QTDIR?=${QT_PREFIX}/bin
-KDEDIR?=${LOCALBASE}/bin
-CONFIGURE_ENV+=QTDIR=${QTDIR} KDEDIR=${KDEDIR}
-LD_CONFIG= yes
-INSTALLS_ICONS= yes
-
-MAN1= krusader.1
-
-pre-everything::
- @${ECHO_MSG}
- @${ECHO_MSG} "The following settings are assumed:"
- @${ECHO_MSG} "Installation directory of qt3: QTDIR=${QTDIR}"
- @${ECHO_MSG} "Installation directory of KDE3: KDEDIR=${KDEDIR}"
- @${ECHO_MSG} "If these assumptions are wrong, stop the build NOW and set the variables correspondingly!"
- @${ECHO_MSG}
- @sleep 3
-
-pre-configure:
- ${RM} ${WRKSRC}/admin/cvs.sh
- ${TOUCH} ${WRKSRC}/admin/cvs.sh
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+post-extract:
+ ${MKDIR} ${WRKSRC}
.include <bsd.port.mk>