aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/mtoolsfm/Makefile
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-01-22 02:31:50 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-01-22 02:31:50 +0000
commitb089d59e6a386b341ea4a3583dd50caf539e31d7 (patch)
tree88f29f891228f3e193bbfcc64a28f7e728838c11 /x11-fm/mtoolsfm/Makefile
parent98ba52ccac61f67acfdece4ceb5e712a9e63f268 (diff)
downloadports-b089d59e6a386b341ea4a3583dd50caf539e31d7.tar.gz
ports-b089d59e6a386b341ea4a3583dd50caf539e31d7.zip
Add mfm.
MFM is a mtools frontend filemanager written in GTK. PR: 16080 Submitted by: Michael Vasilenko <acid@stu.cn.ua>
Notes
Notes: svn path=/head/; revision=24890
Diffstat (limited to 'x11-fm/mtoolsfm/Makefile')
-rw-r--r--x11-fm/mtoolsfm/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/x11-fm/mtoolsfm/Makefile b/x11-fm/mtoolsfm/Makefile
new file mode 100644
index 000000000000..9312eaeaa36c
--- /dev/null
+++ b/x11-fm/mtoolsfm/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: mfm
+# Version required: 1.2
+# Date created: 12 Jan 2000
+# Whom: Michael Vasilenko <acid@stu.cn.ua>
+#
+# $FreeBSD$
+#
+
+DISTNAME= mfm-1.2
+CATEGORIES= x11-fm
+MASTER_SITES= http://www.core-coutainville.org/mfm/archive/SOURCES/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+RUN_DEPENDS= mtools:${PORTSDIR}/emulators/mtools
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/mfm ${PREFIX}/bin
+
+.include <bsd.port.mk>