aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/nautilus2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-09-18 06:49:37 +0000
commit9c0caae1c20155b432bb0feb074a8fd9cc1c12bc (patch)
tree534d0190982c831de589344c3003940ec6f2d6b1 /x11-fm/nautilus2/Makefile
parent27d17afba2c21f490ea8472d7aa37495e02e3ed8 (diff)
downloadports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.tar.gz
ports-9c0caae1c20155b432bb0feb074a8fd9cc1c12bc.zip
Update to GNOME 2.4.0. For all the goodies on what's changed, known issues,
future plans, etc., please see http://www.gnome.org/start/2.4/. This commit represents work done by adamw, bland, and myself as well as many other contributers: Koop Mast <einekoai@chello.nl> Akifyev Sergey <asa@gascom.ru> Franz Klammer <klammer@webonaut.com> Øyvind Kolbu <oyvind@kebab.gaffel.nu> Thomas E. Zander <riggs@rrr.de> Jeremy Messenger <mezz7@cox.net> Without these contirbuters, and our faithful users, GNOME 2.4.0 would not be possible. Please check the FreeBSD GNOME site for any FreeBSD gotchas, as well as general FAQs and documentation (GNOME 2.4 updates to be posted soon). The best way to upgrade so that you get all shared library dependencies is: portupgrade -rf -m BATCH=yes atk portupgrade -R -m BATCH=yes gnome2 Approved by: portmgr (kris, will, myself implicitly) Requested by: re as well as many other users
Notes
Notes: svn path=/head/; revision=89023
Diffstat (limited to 'x11-fm/nautilus2/Makefile')
-rw-r--r--x11-fm/nautilus2/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index 0bf6c2b25e1f..8cbb405cb1e9 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -6,10 +6,10 @@
#
PORTNAME= nautilus2
-PORTVERSION= 2.2.4
+PORTVERSION= 2.4.0
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.2
+MASTER_SITE_SUBDIR= sources/${PORTNAME:S/2$//}/2.4
DIST_SUBDIR= gnome2
DISTNAME= nautilus-${PORTVERSION}
@@ -21,17 +21,17 @@ BUILD_DEPENDS= freetype-config:${PORTSDIR}/print/freetype2
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomeprefix gnomehack gnomehier gnomedesktop eel2 librsvg2 \
- gnomecontrolcenter2
+USE_GNOME= gnomeprefix gnomehack gnomehier gnomedesktop eel2 librsvg2
GNOME_DESKTOP_VERSION=2
INSTALLS_SHLIB= yes
-USE_LIBTOOL= yes
+GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -fno-rtti -fno-exceptions" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib -liconv" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz ${MOZILLA_LIBS}"
CONFIGURE_ARGS= --with-freetype2-lib-place=${LOCALBASE}/lib \
- --with-freetype2-include-place=${LOCALBASE}/include/freetype2
+ --with-freetype2-include-place=${LOCALBASE}/include/freetype2 \
+ --enable-static
MAKE_ENV= G_CHARSET_ALIAS="${LOCALBASE}/libdata/charset.alias"
post-install: