aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/nemo
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2014-12-30 20:13:46 +0000
committerKoop Mast <kwm@FreeBSD.org>2014-12-30 20:13:46 +0000
commitb28f4972855f1b355b5b156ffca59f4135e0e4c8 (patch)
treef8d16b26e7f6882796704c78c3316de2d96ca435 /x11-fm/nemo
parent83b4f7b7528232f46a80c28193ac942e4e8c2f83 (diff)
downloadports-b28f4972855f1b355b5b156ffca59f4135e0e4c8.tar.gz
ports-b28f4972855f1b355b5b156ffca59f4135e0e4c8.zip
Update cinnamon to 2.4, this should fix [1] and [2].
Update totem to 3.14 now that we have gstreamer 1.4 and minor gnome updates. Update evolution suite to 3.12.9. Make sure gtk30 pulls in adwait-icon-theme, since it now the default theme [3]. PR: 195290 [1], 195289 [2], 195455 [3] Obtained from: gnome devel repo
Notes
Notes: svn path=/head/; revision=375852
Diffstat (limited to 'x11-fm/nemo')
-rw-r--r--x11-fm/nemo/Makefile7
-rw-r--r--x11-fm/nemo/distinfo4
-rw-r--r--x11-fm/nemo/files/patch-libnemo-private_nemo-action.c27
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-bookmark-list.c11
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-icon-view.c11
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-list-view.c11
-rw-r--r--x11-fm/nemo/files/patch-src_nemo-notebook.c6
-rw-r--r--x11-fm/nemo/pkg-plist29
8 files changed, 34 insertions, 72 deletions
diff --git a/x11-fm/nemo/Makefile b/x11-fm/nemo/Makefile
index 9d3b7eb2f72e..00cabb2113ac 100644
--- a/x11-fm/nemo/Makefile
+++ b/x11-fm/nemo/Makefile
@@ -1,10 +1,8 @@
# Created by: Gustau Perez i Querol <gustau.perez@gmail.com>
# $FreeBSD$
-# $MCom: ports/trunk/x11-fm/nemo/Makefile 20008 2014-10-21 15:13:35Z gusi $
PORTNAME= nemo
-PORTVERSION= 2.2.4
-PORTREVISION= 1
+PORTVERSION= 2.4.4
CATEGORIES= x11-fm gnome
MASTER_SITES= http://github.com/linuxmint/${PORTNAME}/archive/${PORTVERSION}.tar.gz?dummy=/
DIST_SUBDIR= gnome3
@@ -74,9 +72,6 @@ post-patch:
${WRKSRC}/data/nemo.xml.in \
${WRKSRC}/libnemo-private/nemo-file-utilities.h
-# @${REINPLACE_CMD} '/merge_action/d' \
-# ${WRKSRC}/files/Makefile.in
-
@${FIND} ${WRKSRC} -name \* | ${XARGS} ${EGREP} -l "#!.*\/usr\/bin\/python" | \
${XARGS} ${REINPLACE_CMD} -I "" -e "s|#!.*python.*|#!${PYTHON_CMD}|g"
diff --git a/x11-fm/nemo/distinfo b/x11-fm/nemo/distinfo
index 327555d29ee3..b8b9a452f2ee 100644
--- a/x11-fm/nemo/distinfo
+++ b/x11-fm/nemo/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnome3/nemo-2.2.4.tar.gz) = c05cccde1f84f8136a76c1a4b12054fb5ea38c1082747a6c32588c11ae0be72a
-SIZE (gnome3/nemo-2.2.4.tar.gz) = 1343344
+SHA256 (gnome3/nemo-2.4.4.tar.gz) = 3f42a3153bbd3b03035a53a258eca94e172f80c74800972d61c462119a3c03ee
+SIZE (gnome3/nemo-2.4.4.tar.gz) = 1356359
diff --git a/x11-fm/nemo/files/patch-libnemo-private_nemo-action.c b/x11-fm/nemo/files/patch-libnemo-private_nemo-action.c
deleted file mode 100644
index a1f883e03ed0..000000000000
--- a/x11-fm/nemo/files/patch-libnemo-private_nemo-action.c
+++ /dev/null
@@ -1,27 +0,0 @@
---- libnemo-private/nemo-action.c.orig 2013-11-25 10:51:16.047414327 +0000
-+++ libnemo-private/nemo-action.c 2013-11-25 10:53:12.539547401 +0000
-@@ -1083,7 +1083,7 @@
- const gchar *orig_label = nemo_action_get_orig_label (action);
-
- if (orig_label == NULL)
-- return;
-+ return NULL;
-
- action->escape_underscores = TRUE;
-
-@@ -1106,7 +1106,7 @@
- const gchar *orig_tt = nemo_action_get_orig_tt (action);
-
- if (orig_tt == NULL)
-- return;
-+ return NULL;
-
- action->escape_underscores = FALSE;
-
-@@ -1350,4 +1350,4 @@
- out:
-
- return selection_type_show && extension_type_show && condition_type_show;
--}
-\ No newline at end of file
-+}
diff --git a/x11-fm/nemo/files/patch-src_nemo-bookmark-list.c b/x11-fm/nemo/files/patch-src_nemo-bookmark-list.c
new file mode 100644
index 000000000000..6b7d5a5f16ba
--- /dev/null
+++ b/x11-fm/nemo/files/patch-src_nemo-bookmark-list.c
@@ -0,0 +1,11 @@
+--- src/nemo-bookmark-list.c.orig 2014-11-25 08:21:31.872596499 +0100
++++ src/nemo-bookmark-list.c 2014-11-25 08:22:26.313236268 +0100
+@@ -448,7 +448,7 @@
+ nemo_bookmark_list_get_for_uri (NemoBookmarkList *bookmarks,
+ const char *uri)
+ {
+- g_return_if_fail (NEMO_IS_BOOKMARK_LIST (bookmarks));
++ g_return_val_if_fail (NEMO_IS_BOOKMARK_LIST (bookmarks), NULL);
+
+ GList *iter;
+ GList *results = NULL;
diff --git a/x11-fm/nemo/files/patch-src_nemo-icon-view.c b/x11-fm/nemo/files/patch-src_nemo-icon-view.c
deleted file mode 100644
index 53f37fd24420..000000000000
--- a/x11-fm/nemo/files/patch-src_nemo-icon-view.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/nemo-icon-view.orig.c 2013-03-02 09:06:43.664571510 +0100
-+++ src/nemo-icon-view.c 2013-03-02 09:06:59.822567644 +0100
-@@ -1197,7 +1197,7 @@
- static NemoZoomLevel
- nemo_icon_view_get_default_zoom_level (NemoView *view)
- {
-- g_return_if_fail (NEMO_IS_ICON_VIEW (view));
-+ g_return_val_if_fail (NEMO_IS_ICON_VIEW (view), NEMO_ZOOM_LEVEL_STANDARD);
-
- return get_default_zoom_level(NEMO_ICON_VIEW (view));
- }
diff --git a/x11-fm/nemo/files/patch-src_nemo-list-view.c b/x11-fm/nemo/files/patch-src_nemo-list-view.c
deleted file mode 100644
index 40fac57d5f12..000000000000
--- a/x11-fm/nemo/files/patch-src_nemo-list-view.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/nemo-list-view.orig.c 2013-03-02 09:13:21.519569837 +0100
-+++ src/nemo-list-view.c 2013-03-02 09:13:41.166572327 +0100
-@@ -2846,7 +2846,7 @@
- static NemoZoomLevel
- nemo_list_view_get_default_zoom_level (NemoView *view)
- {
-- g_return_if_fail (NEMO_IS_LIST_VIEW (view));
-+ g_return_val_if_fail (NEMO_IS_LIST_VIEW (view), NEMO_ZOOM_LEVEL_STANDARD);
-
- return get_default_zoom_level();
- }
diff --git a/x11-fm/nemo/files/patch-src_nemo-notebook.c b/x11-fm/nemo/files/patch-src_nemo-notebook.c
index ab2667b41416..5b26b3391cab 100644
--- a/x11-fm/nemo/files/patch-src_nemo-notebook.c
+++ b/x11-fm/nemo/files/patch-src_nemo-notebook.c
@@ -1,10 +1,10 @@
---- src/nemo-notebook.c.orig 2014-03-08 01:46:16.347348229 +0000
-+++ src/nemo-notebook.c 2014-03-08 01:56:25.092307128 +0000
+--- src/nemo-notebook.c.orig 2014-11-25 08:15:15.798622291 +0100
++++ src/nemo-notebook.c 2014-11-25 08:15:25.754624581 +0100
@@ -51,12 +51,6 @@
static void nemo_notebook_remove (GtkContainer *container,
GtkWidget *tab_widget);
--static const GtkTargetEntry url_drag_types[] =
+-static const GtkTargetEntry url_drag_types[] =
-{
- { NEMO_ICON_DND_GNOME_ICON_LIST_TYPE, 0, NEMO_ICON_DND_GNOME_ICON_LIST },
- { NEMO_ICON_DND_URI_LIST_TYPE, 0, NEMO_ICON_DND_URI_LIST },
diff --git a/x11-fm/nemo/pkg-plist b/x11-fm/nemo/pkg-plist
index fa19b2357b79..e975acbb1052 100644
--- a/x11-fm/nemo/pkg-plist
+++ b/x11-fm/nemo/pkg-plist
@@ -1,6 +1,7 @@
bin/nemo
bin/nemo-autorun-software
bin/nemo-connect-server
+bin/nemo-open-with
include/nemo/libnemo-extension/nemo-column-provider.h
include/nemo/libnemo-extension/nemo-column.h
include/nemo/libnemo-extension/nemo-extension-types.h
@@ -12,6 +13,7 @@ include/nemo/libnemo-extension/nemo-menu-provider.h
include/nemo/libnemo-extension/nemo-menu.h
include/nemo/libnemo-extension/nemo-property-page-provider.h
include/nemo/libnemo-extension/nemo-property-page.h
+include/nemo/libnemo-extension/nemo-simple-button.h
lib/girepository-1.0/Nemo-3.0.typelib
lib/libnemo-extension.a
lib/libnemo-extension.so
@@ -56,16 +58,19 @@ share/icons/hicolor/scalable/apps/nemo.svg
share/mime/application/nemo-action.xml
share/mime/application/x-nemo-saved-search.xml
share/mime/packages/nemo.xml
-%%DATADIR%%/actions/add-desklets.nemo_action
-%%DATADIR%%/actions/change-background.nemo_action
-%%DATADIR%%/actions/mount-archive.nemo_action
-%%DATADIR%%/actions/myaction.py
-%%DATADIR%%/actions/new-launcher.nemo_action
-%%DATADIR%%/actions/sample.nemo_action
-%%DATADIR%%/actions/set-as-background.nemo_action
-%%DATADIR%%/icons/hicolor/16x16/emblems/emblem-note.png
-%%DATADIR%%/icons/hicolor/24x24/emblems/emblem-note.png
-%%DATADIR%%/icons/hicolor/48x48/emblems/emblem-note.png
-%%DATADIR%%/nemo-extras.placeholder
-%%DATADIR%%/nemo-suggested.placeholder
+share/nemo/actions/90_new-workspace.nemo_action
+share/nemo/actions/91_delete-workspace.nemo_action
+share/nemo/actions/92_show-expo.nemo_action
+share/nemo/actions/add-desklets.nemo_action
+share/nemo/actions/change-background.nemo_action
+share/nemo/actions/mount-archive.nemo_action
+share/nemo/actions/myaction.py
+share/nemo/actions/new-launcher.nemo_action
+share/nemo/actions/sample.nemo_action
+share/nemo/actions/set-as-background.nemo_action
+share/nemo/icons/hicolor/16x16/emblems/emblem-note.png
+share/nemo/icons/hicolor/24x24/emblems/emblem-note.png
+share/nemo/icons/hicolor/48x48/emblems/emblem-note.png
+share/nemo/nemo-extras.placeholder
+share/nemo/nemo-suggested.placeholder
share/polkit-1/actions/org.nemo.root.policy