aboutsummaryrefslogtreecommitdiff
path: root/x11-fm/xdiskusage/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-06-21 23:13:11 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-06-21 23:13:11 +0000
commitbdd46fe0d99a5dd3023c95b9ca110135929f8723 (patch)
treeeaa3b42ca7462fcb3fc0da7b8a914823c5cb3e22 /x11-fm/xdiskusage/Makefile
parentf53471895d3c19d99c4b01f64fa51c82f939136a (diff)
downloadports-bdd46fe0d99a5dd3023c95b9ca110135929f8723.tar.gz
ports-bdd46fe0d99a5dd3023c95b9ca110135929f8723.zip
Make port build with clang. While we're here add an additional distfile
mirror and get rid of custom do-build target. PR: 158136 Submitted by: Niclas Zeising <niclas.zeising@gmail.com>
Notes
Notes: svn path=/head/; revision=276043
Diffstat (limited to 'x11-fm/xdiskusage/Makefile')
-rw-r--r--x11-fm/xdiskusage/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-fm/xdiskusage/Makefile b/x11-fm/xdiskusage/Makefile
index fbef0fddf3f5..766dfb74b6c7 100644
--- a/x11-fm/xdiskusage/Makefile
+++ b/x11-fm/xdiskusage/Makefile
@@ -9,7 +9,8 @@ PORTNAME= xdiskusage
PORTVERSION= 1.48
PORTREVISION= 6
CATEGORIES= x11-fm
-MASTER_SITES= http://xdiskusage.sourceforge.net/
+MASTER_SITES= http://xdiskusage.sourceforge.net/ \
+ http://www.gnu-darwin.org/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
@@ -19,15 +20,17 @@ LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
USE_GMAKE= yes
+CXXFLAGS+= `fltk-config --cxxflags`
+LDFLAGS+= `fltk-config --ldflags`
+
+MAKE_ENV+= LDFLAGS="${LDFLAGS}"
+
PLIST_FILES= bin/xdiskusage
MAN1= xdiskusage.1
post-patch:
${REINPLACE_CMD} -e '22,24d' ${WRKSRC}/Makefile
-do-build:
- cd ${WRKSRC} && ${GMAKE} CXXFLAGS="`fltk-config --cxxflags`" LDFLAGS="`fltk-config --ldflags`"
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/xdiskusage ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/xdiskusage.1 ${MANPREFIX}/man/man1