aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-31 07:25:25 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-31 07:25:25 +0000
commited1050ad9ccc80248ab5f06be4468e31d03529ba (patch)
treec4ed00c986170ee9f3bfdeeb1b7af596a72bd3ed /x11-fm
parent1b4b5c15680891d127847fbec6484564a7610956 (diff)
downloadports-ed1050ad9ccc80248ab5f06be4468e31d03529ba.tar.gz
ports-ed1050ad9ccc80248ab5f06be4468e31d03529ba.zip
- Trim Makefile header, comment out dead MASTER_SITES
- Patch internal makefiles to allow parallel (-jX) builds - Touch COMMENT and port description, remove dead URL - Wrap one overly long line; miscellaneous port cleanups
Notes
Notes: svn path=/head/; revision=324013
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/xnc/Makefile60
-rw-r--r--x11-fm/xnc/files/patch-make-jobs-safe183
-rw-r--r--x11-fm/xnc/pkg-descr4
3 files changed, 220 insertions, 27 deletions
diff --git a/x11-fm/xnc/Makefile b/x11-fm/xnc/Makefile
index cc40b0328fd2..eeecb9b46f35 100644
--- a/x11-fm/xnc/Makefile
+++ b/x11-fm/xnc/Makefile
@@ -1,49 +1,61 @@
-# New ports collection makefile for: xnc
-# Date created: 5 February 1999
-# Whom: Dima Sivachenko <dima@chg.ru>
-#
+# Created by: Dima Sivachenko <dima@chg.ru>
# $FreeBSD$
-#
PORTNAME= xnc
PORTVERSION= 5.0.4
PORTREVISION= 8
CATEGORIES= x11-fm
-MASTER_SITES= http://www.xnc.dubna.su/src-5/
+MASTER_SITES= # http://www.xnc.dubna.su/src-5/
DISTNAME= ${PORTNAME}-${PORTVERSION}.src
MAINTAINER= demon@FreeBSD.org
-COMMENT= File manager for X Window
-
-# xnc will use the following programs if you have them installed.
-#RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
-# unzip:${PORTSDIR}/archivers/unzip \
-# rpm:${PORTSDIR}/archivers/rpm \
-# rar:${PORTSDIR}/archivers/rar \
-# unarj:${PORTSDIR}/archivers/unarj \
+COMMENT= File manager for X11 similar to Norton Commander
+
+LICENSE= GPLv2
+
+# xnc will use the following programs if you have them installed:
+#RUN_DEPENDS= zip:${PORTSDIR}/archivers/zip \
+# unzip:${PORTSDIR}/archivers/unzip \
+# rpm:${PORTSDIR}/archivers/rpm \
+# rar:${PORTSDIR}/archivers/rar \
+# unarj:${PORTSDIR}/archivers/unarj \
# lha:${PORTSDIR}/archivers/lha
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- tiff.4:${PORTSDIR}/graphics/tiff
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libtiff.so:${PORTSDIR}/graphics/tiff
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= gettext
GNU_CONFIGURE= yes
USE_XORG= x11 xext xt
-CONFIGURE_ARGS+=--with-pty=BSD --with-libintl-prefix=${LOCALBASE}
+CONFIGURE_ARGS= --with-pty=BSD --with-libintl-prefix=${LOCALBASE}
CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
+
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
MAN1= ives.1 xjpegroot.1 xnc.1 xnlaunch.1 iedit.1 iview.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|make |$$(MAKE) |' \
+ ${WRKSRC}/src/launch/makefile.in \
+ ${WRKSRC}/src/plugins/aqua/makefile.in \
+ ${WRKSRC}/src/plugins/five/makefile.in \
+ ${WRKSRC}/src/plugins/theme/makefile.in \
+ ${WRKSRC}/src/xjroot/makefile.in \
+ ${WRKSRC}/src/xsetup/makefile.in
+
post-configure:
- ${REINPLACE_CMD} -e 's|-I$$(MYSRCDIR)/intl||;s|$${top_builddir}/intl/libintl.a|-lintl|' \
- ${WRKSRC}/src/ives/makefile \
- ${WRKSRC}/src/launch/makefile \
- ${WRKSRC}/src/xsetup/makefile \
- ${WRKSRC}/src/makefile
+ @${REINPLACE_CMD} -e 's|-I$$(MYSRCDIR)/intl|| ; \
+ s|$${top_builddir}/intl/libintl.a|-lintl|' \
+ ${WRKSRC}/src/ives/makefile \
+ ${WRKSRC}/src/launch/makefile \
+ ${WRKSRC}/src/xsetup/makefile \
+ ${WRKSRC}/src/makefile
post-install:
+ @${ECHO_MSG}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_MSG}
.include <bsd.port.mk>
diff --git a/x11-fm/xnc/files/patch-make-jobs-safe b/x11-fm/xnc/files/patch-make-jobs-safe
new file mode 100644
index 000000000000..b02a6d0dfdab
--- /dev/null
+++ b/x11-fm/xnc/files/patch-make-jobs-safe
@@ -0,0 +1,183 @@
+--- src/lib/makefile.in.orig 2002-09-19 22:36:34.000000000 +0800
++++ src/lib/makefile.in 2013-07-31 14:57:28.000000000 +0800
+@@ -34,10 +34,10 @@
+ all:: compile
+
+ compile:
+- for i in $(PDIRS); do cd $$i && make compile; cd ..; done
++ for i in $(PDIRS); do $(MAKE) -C $$i compile; done
+
+ clean:
+- for i in $(PDIRS); do cd $$i && make clean; cd ..; done
++ for i in $(PDIRS); do $(MAKE) -C $$i clean; done
+
+ FORCE:
+
+--- src/plugins/makefile.in.orig 2002-07-08 23:21:54.000000000 +0800
++++ src/plugins/makefile.in 2013-07-31 14:59:12.000000000 +0800
+@@ -5,15 +5,11 @@
+
+ plugins:
+ @for dir in ${ALLDIRS}; do \
+- cd $$dir; \
+- ${MAKE} all || exit 1; \
+- cd .. ;\
++ ${MAKE} -C $$dir all || exit 1; \
+ done
+
+ clean:
+ @for dir in ${ALLDIRS}; do \
+- cd $$dir; \
+- ${MAKE} clean || exit 1; \
+- cd .. ;\
++ ${MAKE} -C $$dir clean || exit 1; \
+ done
+
+--- src/makefile.in.orig 2003-01-30 22:52:43.000000000 +0800
++++ src/makefile.in 2013-07-31 14:59:54.000000000 +0800
+@@ -101,16 +101,16 @@
+ all:: compile
+
+ compile:
+- for i in $(PDIRS); do cd $$i && make compile; cd ..; done
+- make $(MYBINDIR)/xnc
+- make $(MYBINDIR)/xncloader
+- make compile-$(PLUGINS)
++ for i in $(PDIRS); do $(MAKE) -C $$i compile; done
++ $(MAKE) $(MYBINDIR)/xnc
++ $(MAKE) $(MYBINDIR)/xncloader
++ $(MAKE) compile-$(PLUGINS)
+
+ compile-:
+ echo nothing
+
+ compile-gui_plugins:
+- cd plugins && make
++ $(MAKE) -C plugins
+
+ config: FORCE
+ ./configure
+@@ -135,21 +135,21 @@
+
+ clean:
+ pwd_v=`pwd`; \
+- for i in $(PDIRS); do cd $$i && make clean; cd $$pwd_v; done
++ for i in $(PDIRS); do $(MAKE) -C $$i clean; done
+ $(RMF) $(MYBINDIR)/xnc
+ $(RMF) $(XNCOBJS)
+ $(RMF) helpers/resloader.o
+- make clean-$(PLUGINS)
++ $(MAKE) clean-$(PLUGINS)
+
+ clean-:
+ echo nothing
+
+ clean-gui_plugins:
+- cd plugins && make clean
++ $(MAKE) -C plugins clean
+
+ fast:
+ $(RMF) *.o
+- make compile
++ $(MAKE) compile
+
+ tags:
+ etags $(TAGFILES)
+--- Makefile.in.orig 2003-02-04 20:52:38.000000000 +0800
++++ Makefile.in 2013-07-31 15:00:18.000000000 +0800
+@@ -31,15 +31,15 @@
+
+ compile:
+ ./newcomp $(XNCVERSION)
+- cd intl && make
+- for i in $(PDIRS); do cd $$i && make compile; cd $(FULLDIR); done
+- make compile-$(PO_MAKE_DIR)
++ $(MAKE) -C intl
++ for i in $(PDIRS); do $(MAKE) -C $$i compile; done
++ $(MAKE) compile-$(PO_MAKE_DIR)
+
+ compile-:
+ @echo "Skipping..."
+
+ compile-po:
+- cd po && make compile
++ $(MAKE) -C po compile
+
+ config: FORCE
+ ./configure
+@@ -77,7 +77,7 @@
+ $(INSTALL_DATA) ./desktop/xnc.desktop $(DESTDIR)$(INSTDESKDIR1)
+ $(INSTALL_DATA) ./desktop/X_Northern_Captain.desktop $(DESTDIR)$(INSTDESKDIR2)
+ $(INSTALL_DATA) ./desktop/xnc-gnome2.desktop $(DESTDIR)$(INSTDESKDIR3)
+- make install-$(PO_MAKE_DIR)
++ $(MAKE) install-$(PO_MAKE_DIR)
+ @echo "Don't foget run 'xncsetup' before starting XNC"
+ @echo "And add $(DESTDIR)$(INSTDIR) into your PATH environment variable"
+
+@@ -91,7 +91,7 @@
+ @echo "Skipping..."
+
+ install-po:
+- cd po && make install
++ $(MAKE) -C po install
+
+ uninstall:
+ $(RMF) $(DESTDIR)$(INSTDIR)/users.xnc
+@@ -119,13 +119,13 @@
+
+ clean:
+ pwd_v=`pwd`; \
+- for i in $(PDIRS); do cd $$i && make clean; cd $$pwd_v; done
++ for i in $(PDIRS); do $(MAKE) -C $$i clean; done
+
+ fast:
+- cd src && make fast
++ $(MAKE) -C src fast
+
+ tags:
+- cd src && make tags
++ $(MAKE) -C src tags
+
+ FORCE:
+
+--- src/ives/makefile.in.orig 2003-12-25 20:43:18.000000000 +0800
++++ src/ives/makefile.in 2013-07-31 15:06:35.000000000 +0800
+@@ -54,9 +54,9 @@
+ all:: compile
+
+ compile:
+- make $(MYBINDIR)/iview
+- make $(MYBINDIR)/iedit
+- make $(MYBINDIR)/ives
++ $(MAKE) $(MYBINDIR)/iview
++ $(MAKE) $(MYBINDIR)/iedit
++ $(MAKE) $(MYBINDIR)/ives
+
+ $(MYBINDIR)/ives: $(IVESOBJS) $(IVESLIBS) $(JDEP) $(PNGDEP) $(ZDEP)
+ $(CXX) -o $@ $(IVESOBJS) $(IVESLIBS) $(LOCAL_LIBRARIES) $(JLIB) \
+@@ -72,13 +72,13 @@
+
+
+ $(JDEP):
+- cd $(MYSRCDIR)/lib/jpeg && make
++ $(MAKE) -C $(MYSRCDIR)/lib/jpeg
+
+ $(PNGDEP):
+- cd $(MYSRCDIR)/lib/libpng && make
++ $(MAKE) -C $(MYSRCDIR)/lib/libpng
+
+ $(ZDEP):
+- cd $(MYSRCDIR)/lib/zlib && make
++ $(MAKE) -C $(MYSRCDIR)/lib/zlib
+
+ clean:
+ $(RMF) *.o
+@@ -88,7 +88,7 @@
+
+ fast:
+ $(RMF) *.o
+- make compile
++ $(MAKE) compile
+
+ FORCE:
+
diff --git a/x11-fm/xnc/pkg-descr b/x11-fm/xnc/pkg-descr
index 5e3f3d40722e..58414a62b9fc 100644
--- a/x11-fm/xnc/pkg-descr
+++ b/x11-fm/xnc/pkg-descr
@@ -3,8 +3,6 @@ move, rename, delete, view and edit files in a Virtual File System (VFS).
VFS consists from a normal disk space and a Archive File System (AFS).
All file operations in AFS can be done exactly as in normal file system.
-The IVES - file viewer and editor for X Window included, provides a
+The IVES -- file viewer and editor for X Window included, provides a
comprehensive way to view and edit images in many different formats: GIF,
JPEG, PCX, BMP, XBM, XPM, TIFF, TGA, PCD, PNG.
-
-WWW: http://xnc.dubna.su/