aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /x11-fm
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/dolphin/Makefile4
-rw-r--r--x11-fm/konqueror/Makefile4
-rw-r--r--x11-fm/krusader2-kde4/Makefile4
-rw-r--r--x11-fm/krusader2/Makefile4
-rw-r--r--x11-fm/pcmanfm-qt/Makefile4
-rw-r--r--x11-fm/pcmanfmqt-l10n/Makefile4
-rw-r--r--x11-fm/qtfm/Makefile4
-rw-r--r--x11-fm/ultracopier/Makefile4
8 files changed, 16 insertions, 16 deletions
diff --git a/x11-fm/dolphin/Makefile b/x11-fm/dolphin/Makefile
index 3cd12b1ad019..41f5ffc5095f 100644
--- a/x11-fm/dolphin/Makefile
+++ b/x11-fm/dolphin/Makefile
@@ -15,7 +15,7 @@ RUN_DEPENDS= ${QT_PLUGINDIR}/ffmpegthumbs.so:multimedia/kdemultimedia-ffmpegthum
${QT_PLUGINDIR}/gsthumbnail.so:graphics/kdegraphics-thumbnailers \
${QT_PLUGINDIR}/audiothumbnail.so:devel/kio-extras
-USES= cmake:outsource compiler:c++11-lib gettext kde:5 tar:xz
+USES= cmake:outsource compiler:c++11-lib gettext kde:5 qt:5 tar:xz
USE_KDE= activities attica auth baloo baloo-widgets bookmarks codecs \
completion config configwidgets coreaddons crash dbusaddons \
doctools ecm emoticons filemetadata i18n iconthemes init \
@@ -23,7 +23,7 @@ USE_KDE= activities attica auth baloo baloo-widgets bookmarks codecs \
kdelibs4support kio newstuff notifications parts service \
solid sonnet texteditor textwidgets widgetsaddons \
windowsystem xmlgui
-USE_QT5= concurrent core dbus gui network phonon4 widgets xml \
+USE_QT= concurrent core dbus gui network phonon4 widgets xml \
buildtools_build qmake_build
SHLIB_VER= 5.0.0
diff --git a/x11-fm/konqueror/Makefile b/x11-fm/konqueror/Makefile
index cf2948f88bdb..d22d35e1b2b6 100644
--- a/x11-fm/konqueror/Makefile
+++ b/x11-fm/konqueror/Makefile
@@ -9,13 +9,13 @@ COMMENT= KDE system log application
LIB_DEPENDS= libtidy.so:www/tidy-lib
-USES= cmake:outsource desktop-file-utils gettext kde:5 pkgconfig tar:xz
+USES= cmake:outsource desktop-file-utils gettext kde:5 pkgconfig qt:5 tar:xz
USE_KDE= activities archive auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons guiaddons i18n iconthemes \
itemviews jobwidgets js kcmutils kdelibs4support \
kdesu khtml kio notifications parts pty service solid sonnet \
textwidgets unitconversion widgetsaddons windowsystem xmlgui
-USE_QT5= core dbus gui location network printsupport qml quick script \
+USE_QT= core dbus gui location network printsupport qml quick script \
speech webchannel webengine widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= ice sm x11 xext
diff --git a/x11-fm/krusader2-kde4/Makefile b/x11-fm/krusader2-kde4/Makefile
index dc497768be8a..8227a8a60b95 100644
--- a/x11-fm/krusader2-kde4/Makefile
+++ b/x11-fm/krusader2-kde4/Makefile
@@ -16,8 +16,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS_INSTALL= krusader2-2.*
-USES= cmake:outsource gettext kde:4 tar:bzip2
+USES= cmake:outsource gettext kde:4 qt:4 tar:bzip2
USE_KDE= kdelibs automoc4
-USE_QT4= moc_build qmake_build rcc_build uic_build
+USE_QT= moc_build qmake_build rcc_build uic_build
.include <bsd.port.mk>
diff --git a/x11-fm/krusader2/Makefile b/x11-fm/krusader2/Makefile
index c467c81fb79b..1e449a3aef12 100644
--- a/x11-fm/krusader2/Makefile
+++ b/x11-fm/krusader2/Makefile
@@ -14,13 +14,13 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS_INSTALL= krusader2-kde4
-USES= cmake:outsource gettext kde:5 tar:xz
+USES= cmake:outsource gettext kde:5 qt:5 tar:xz
USE_KDE= archive auth auth bookmarks codecs completion config \
configwidgets coreaddons doctools ecm guiaddons i18n \
iconthemes itemviews jobwidgets kio notifications parts \
service solid sonnet textwidgets wallet widgetsaddons \
windowsystem xmlgui
-USE_QT5= concurrent core dbus gui network printsupport xml widgets \
+USE_QT= concurrent core dbus gui network printsupport xml widgets \
buildtools_build qmake_build
.include <bsd.port.mk>
diff --git a/x11-fm/pcmanfm-qt/Makefile b/x11-fm/pcmanfm-qt/Makefile
index a8fbbe671c87..6eeab23c3bb5 100644
--- a/x11-fm/pcmanfm-qt/Makefile
+++ b/x11-fm/pcmanfm-qt/Makefile
@@ -16,8 +16,8 @@ LIB_DEPENDS= libmenu-cache.so:x11/menu-cache \
libexif.so:graphics/libexif
USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
- gettext-runtime localbase:ldflags lxqt pkgconfig kde:5 tar:xz
-USE_QT5= buildtools_build qmake_build core dbus gui linguisttools \
+ gettext-runtime localbase:ldflags lxqt pkgconfig kde:5 qt:5 tar:xz
+USE_QT= buildtools_build qmake_build core dbus gui linguisttools \
widgets x11extras
USE_KDE= oxygen-icons5
USE_LXQT= buildtools libfmqt
diff --git a/x11-fm/pcmanfmqt-l10n/Makefile b/x11-fm/pcmanfmqt-l10n/Makefile
index 608cfba37cb4..b9b025994bbb 100644
--- a/x11-fm/pcmanfmqt-l10n/Makefile
+++ b/x11-fm/pcmanfmqt-l10n/Makefile
@@ -17,8 +17,8 @@ DISTINFO_FILE= ${MASTERDIR}/distinfo
DESCR= ${MASTERDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
-USES= cmake:outsource lxqt pkgconfig tar:xz
-USE_QT5= buildtools_build qmake_build linguisttools
+USES= cmake:outsource lxqt pkgconfig qt:5 tar:xz
+USE_QT= buildtools_build qmake_build linguisttools
USE_LXQT= buildtools
CMAKE_ARGS+= -DWITH_COMPTON_CONF:BOOL=OFF \
diff --git a/x11-fm/qtfm/Makefile b/x11-fm/qtfm/Makefile
index a34a7c2d7a77..b098ed811756 100644
--- a/x11-fm/qtfm/Makefile
+++ b/x11-fm/qtfm/Makefile
@@ -12,9 +12,9 @@ COMMENT= Small, lightweight file manager based on pure Qt
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= dos2unix qmake
+USES= dos2unix qmake qt:4
DOS2UNIX_REGEX= .*\.(h|cpp)
-USE_QT4= gui network moc_build rcc_build \
+USE_QT= gui network moc_build rcc_build \
imageformats_run
post-patch:
diff --git a/x11-fm/ultracopier/Makefile b/x11-fm/ultracopier/Makefile
index d3465dff5559..7cc05ab9d1b7 100644
--- a/x11-fm/ultracopier/Makefile
+++ b/x11-fm/ultracopier/Makefile
@@ -13,8 +13,8 @@ COMMENT= Advanced file copier
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake tar:xz
-USE_QT5= buildtools_build linguisttools_build \
+USES= qmake qt:5 tar:xz
+USE_QT= buildtools_build linguisttools_build \
core gui network widgets xml
QMAKE_ARGS= LRELEASE="${LRELEASE}" ultracopier-core.pro