aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2008-01-06 15:20:58 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2008-01-06 15:20:58 +0000
commit9698a97592093862a5c0bb6e66adb408337bad60 (patch)
treedc61414fe243dfbc101ebe677cea3b9e381e2d52 /x11-fm
parent348ae1db44901d850fe9e827ae6443c69a183f18 (diff)
downloadports-9698a97592093862a5c0bb6e66adb408337bad60.tar.gz
ports-9698a97592093862a5c0bb6e66adb408337bad60.zip
- Add patch to prevent a crashed when allocate dynamic memory. [1]
- Change BROKEN message to better show the problem. - Bump PORTREVISION. Submitted by: Jens Rehsack <rehsack@web.de> [1] Approved by: stas (mentor, implicit) Obtained from: http://bugzilla.gnome.org/show_bug.cgi?id=468685
Notes
Notes: svn path=/head/; revision=205105
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/gnome-commander2/Makefile6
-rw-r--r--x11-fm/gnome-commander2/files/patch-gnome-cmd-python-plugin.cc15
2 files changed, 18 insertions, 3 deletions
diff --git a/x11-fm/gnome-commander2/Makefile b/x11-fm/gnome-commander2/Makefile
index 5fa380ee1134..348ccc0f7937 100644
--- a/x11-fm/gnome-commander2/Makefile
+++ b/x11-fm/gnome-commander2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gnome-commander
PORTVERSION= 1.2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/gnome-commander/1.2
@@ -37,8 +37,8 @@ MAN1= gnome-commander.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 700000 && ${ARCH} == "amd64"
-BROKEN= Does not compile
+.if ${OSVERSION} >= 700000 && ${ARCH} == "amd64"
+BROKEN= Does not run on amd64 and 7.X or greater
.endif
.include <bsd.port.post.mk>
diff --git a/x11-fm/gnome-commander2/files/patch-gnome-cmd-python-plugin.cc b/x11-fm/gnome-commander2/files/patch-gnome-cmd-python-plugin.cc
new file mode 100644
index 000000000000..53489317e203
--- /dev/null
+++ b/x11-fm/gnome-commander2/files/patch-gnome-cmd-python-plugin.cc
@@ -0,0 +1,15 @@
+--- ./src/gnome-cmd-python-plugin.cc.orig 2007-09-10 07:38:08.000000000
++0000
++++ ./src/gnome-cmd-python-plugin.cc 2007-09-11 00:29:03.000000000 +0000
+@@ -54,6 +54,11 @@
+ }
+
+ long dir_size = pathconf(".", _PC_PATH_MAX);
++ if( -1 == dir_size )
++ {
++ g_warning ( "pathconf(.): %s", strerror(errno) );
++ return;
++ }
+ gchar *prev_dir = (gchar *) g_malloc (dir_size);
+
+ if (!prev_dir)