aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-06-09 22:25:05 +0000
committerWill Andrews <will@FreeBSD.org>2000-06-09 22:25:05 +0000
commit552aef967333c06c5120c84cbdc53184b32c566c (patch)
tree41d6282b4500d48cc1a4e3db4fdfea6eeabfa551 /x11-fm
parenta18646a21e3ff1eecf908859befd4ce437e62021 (diff)
downloadports-552aef967333c06c5120c84cbdc53184b32c566c.tar.gz
ports-552aef967333c06c5120c84cbdc53184b32c566c.zip
Add vide, a simple filemanager with vi-like keybindings.
PR: 18649 Submitted by: Colman Reilly <careilly@thecia.ie>
Notes
Notes: svn path=/head/; revision=29480
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/Makefile1
-rw-r--r--x11-fm/vide/Makefile23
-rw-r--r--x11-fm/vide/distinfo1
-rw-r--r--x11-fm/vide/files/patch-aa16
-rw-r--r--x11-fm/vide/pkg-comment1
-rw-r--r--x11-fm/vide/pkg-descr10
-rw-r--r--x11-fm/vide/pkg-plist1
7 files changed, 53 insertions, 0 deletions
diff --git a/x11-fm/Makefile b/x11-fm/Makefile
index d444370261d2..f91c1d3a0d14 100644
--- a/x11-fm/Makefile
+++ b/x11-fm/Makefile
@@ -13,6 +13,7 @@
SUBDIR += mfm
SUBDIR += offix-files
SUBDIR += tkdesk
+ SUBDIR += vide
SUBDIR += workplace
SUBDIR += x-files
SUBDIR += xcruise
diff --git a/x11-fm/vide/Makefile b/x11-fm/vide/Makefile
new file mode 100644
index 000000000000..e5a9677b993a
--- /dev/null
+++ b/x11-fm/vide/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: vide
+# Date created: May 17 2000
+# Whom: careilly
+#
+# $FreeBSD$
+#
+
+PORTNAME= vide
+PORTVERSION= 0.2.6
+CATEGORIES= x11-fm
+MASTER_SITES= http://vide.sourceforge.net/
+
+MAINTAINER= careilly@thecia.ie
+
+LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12
+
+CFLAGS+= -DHAVE_SYS_PARAM_H
+MANCOMPRESSED= yes
+USE_XLIB= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+
+.include <bsd.port.mk>
diff --git a/x11-fm/vide/distinfo b/x11-fm/vide/distinfo
new file mode 100644
index 000000000000..a9c4588e1124
--- /dev/null
+++ b/x11-fm/vide/distinfo
@@ -0,0 +1 @@
+MD5 (vide-0.2.6.tar.gz) = cb8479b92e169e15035efa5f9c71c5f3
diff --git a/x11-fm/vide/files/patch-aa b/x11-fm/vide/files/patch-aa
new file mode 100644
index 000000000000..8cfa403280c5
--- /dev/null
+++ b/x11-fm/vide/files/patch-aa
@@ -0,0 +1,16 @@
+--- src/search_mode.c.orig Wed May 17 20:28:02 2000
++++ src/search_mode.c Wed May 17 20:30:57 2000
+@@ -16,6 +16,13 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
++#ifdef HAVE_SYS_PARAM_H
++#include <sys/param.h>
++#endif
++
++#if (defined(BSD) && (BSD>=199103))
++#include <sys/types.h>
++#endif
+ #include <fnmatch.h>
+ #include<stdio.h>
+ #include<string.h>
diff --git a/x11-fm/vide/pkg-comment b/x11-fm/vide/pkg-comment
new file mode 100644
index 000000000000..bb0824d758b9
--- /dev/null
+++ b/x11-fm/vide/pkg-comment
@@ -0,0 +1 @@
+Simple Gtk+ based filemanager with vi keybindings
diff --git a/x11-fm/vide/pkg-descr b/x11-fm/vide/pkg-descr
new file mode 100644
index 000000000000..0731622486e8
--- /dev/null
+++ b/x11-fm/vide/pkg-descr
@@ -0,0 +1,10 @@
+Vide is a simple filemanager with vi keybindings. If you already
+use vi, Vide enables you to have complete keyboard control over
+your filemanager without having to learn a new set of commands.
+
+Vide runs under X11 and is based on Gtk+
+
+WWW: http://vide.sourceforge.net/
+
+- Colman
+careilly@thecia.ie
diff --git a/x11-fm/vide/pkg-plist b/x11-fm/vide/pkg-plist
new file mode 100644
index 000000000000..7e2e219bb21e
--- /dev/null
+++ b/x11-fm/vide/pkg-plist
@@ -0,0 +1 @@
+bin/vide