aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorKurt Jaeger <pi@FreeBSD.org>2015-10-14 17:36:15 +0000
committerKurt Jaeger <pi@FreeBSD.org>2015-10-14 17:36:15 +0000
commit6d376126f0da7fcf51e9c47b8a1f291a5dd4834c (patch)
treee52d8d4e874cb9b862cc1901235cbc5731260df9 /x11-fm
parent6a0b7ecd8f2d46d272fe4c3003dc4865054f77e6 (diff)
downloadports-6d376126f0da7fcf51e9c47b8a1f291a5dd4834c.tar.gz
ports-6d376126f0da7fcf51e9c47b8a1f291a5dd4834c.zip
x11-fm/xfe: 1.40 -> 1.40.1
Version 1.40.1 (released 11/08/2015) - fixed archive extensions like tar.gz, tar.bz2, tar.xz that were uncorrectly displayed as gz, bz2 and xz in file lists - applied fixes from Coverity analysis - fixed bug #181 (USB drive requires manual refresh on re-mount) - fixed a bug in the PathLinker where a path such as /test was incorrectly found as being a part of a path like /home/test/temp - fixed bug #204 (Can't overwrite folders ). The rename command now forbids renaming files or directories to a destination that already exists - set focus on the cancel button in some confirmation dialogs - when pressing the return key on a multiple selection of files and directories, the files are now opened and the directories are ignored - fixed missing suffixes when creating directory copies from copy / paste operation - fixed the user and group combo box sizes in the Properties dialog - fixed wrong icon size in xferc for aac and flac types - fixed wrong if test in onCmdPopupMenu() for FilePanel.cpp and SearchPanel.cpp (Coverity) - fixed the path linker button text when the directory name contains '&' characters - implemented natural sorting in DirList - fixed natural file sorting in compare_locale() and compare_nolocale() (bug #203) - updated spanish translation (thanks to jcsl <trcs@gmx.com>) - fixed a bash-ism in configure.ac (bug #200) - fixed Ctrl-C, Ctrl-V, Ctrl-X and Ctrl-A shortcuts that didn't work in text fields with caps lock enabled - in the search window, pressing the Return key does not launch another search when the panel has the focus - fixed a problem where data count is wrongly reset when moving files between different file systems - updated hungarian translation (thanks to Sndor Sipos <ss1978@freestart.hu>) - fixed a freeze problem with the uim input method and changed the way input methods are detected. We now use the XMODIFIERS environment variable. This works well with ibus, uim and fcitx input methods. There remains a problem where composed characters don't work with the SCIM input method, can't find why - fixed a compilation problem in non Linux systems (cmd variable not declared in main.cpp, bug #198) PR: 203762 Submitted by: Walter Schwarzenfeld <w.litter@aon.at>
Notes
Notes: svn path=/head/; revision=399284
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/xfe/Makefile8
-rw-r--r--x11-fm/xfe/distinfo4
-rw-r--r--x11-fm/xfe/files/patch-src__main.cpp19
-rw-r--r--x11-fm/xfe/files/patch-xfeutils_cpp39
4 files changed, 46 insertions, 24 deletions
diff --git a/x11-fm/xfe/Makefile b/x11-fm/xfe/Makefile
index 604a3a084e95..5b5bae3b31f8 100644
--- a/x11-fm/xfe/Makefile
+++ b/x11-fm/xfe/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xfe
-PORTVERSION= 1.40
+PORTVERSION= 1.40.1
CATEGORIES= x11-fm
MASTER_SITES= SF
@@ -16,13 +16,15 @@ LIB_DEPENDS= libFOX-1.6.so:${PORTSDIR}/x11-toolkits/fox16
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
-NLS_CONFIGURE_ENABLE= nls
-USES= desktop-file-utils gettext gmake pathfix
+USES= desktop-file-utils gmake pathfix
USE_XORG= xft
USE_GNOME= intltool
GNU_CONFIGURE= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib -pthread
diff --git a/x11-fm/xfe/distinfo b/x11-fm/xfe/distinfo
index c9165a0455cf..a98e5d130ea6 100644
--- a/x11-fm/xfe/distinfo
+++ b/x11-fm/xfe/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfe-1.40.tar.gz) = 2b476f15beff1a1ce85dd4ce6559bb7ceca78b866c63fb4986456862a36862a8
-SIZE (xfe-1.40.tar.gz) = 2574477
+SHA256 (xfe-1.40.1.tar.gz) = ec3d9495bb329c6199f6265dbfb514ffd3bdb8801e36ccc4e8fac6cea15bcc71
+SIZE (xfe-1.40.1.tar.gz) = 2627754
diff --git a/x11-fm/xfe/files/patch-src__main.cpp b/x11-fm/xfe/files/patch-src__main.cpp
deleted file mode 100644
index 351e4fe12be6..000000000000
--- a/x11-fm/xfe/files/patch-src__main.cpp
+++ /dev/null
@@ -1,19 +0,0 @@
---- src/main.cpp.orig
-+++ src/main.cpp
-@@ -270,6 +270,7 @@
- const char *vdrname = "Xfe";
- int i;
- FXbool loadicons;
-+ FXString cmd;
- FXString startfiledir1="";
- FXString startdir2="";
- FXbool iconic=false;
-@@ -307,7 +308,7 @@
- // - if dpkg exists then the system uses deb packages
- // - else if rpm exists, then the system uses rpm packages
- // - else another (unsupported) package manager is used
-- FXString cmd, str;
-+ FXString str;
-
- cmd="dpkg --version";
- str=getCommandOutput(cmd);
diff --git a/x11-fm/xfe/files/patch-xfeutils_cpp b/x11-fm/xfe/files/patch-xfeutils_cpp
new file mode 100644
index 000000000000..286320dba996
--- /dev/null
+++ b/x11-fm/xfe/files/patch-xfeutils_cpp
@@ -0,0 +1,39 @@
+--- src/xfeutils.cpp.orig 2015-09-07 15:32:21 UTC
++++ src/xfeutils.cpp
+@@ -563,36 +563,6 @@ int lstatmt(const char* filename, struct
+ #endif
+
+
+-// Safe strcpy function (Public domain, by C.B. Falconer)
+-// The destination string is always null terminated
+-// Size sz must be equal to strlen(src)+1
+-size_t strlcpy(char* dst, const char* src, size_t sz)
+-{
+- const char *start = src;
+-
+- if (src && sz--)
+- {
+- while ((*dst++ = *src))
+- if (sz--)
+- src++;
+- else
+- {
+- *(--dst) = '\0';
+- break;
+- }
+- }
+- if (src)
+- {
+- while (*src++)
+- continue;
+- return src - start - 1;
+- }
+- else if (sz)
+- *dst = '\0';
+- return 0;
+-}
+-
+-
+ // Safe strcat function (Public domain, by C.B. Falconer)
+ // The destination string is always null terminated
+ size_t strlcat(char* dst, const char* src, size_t sz)