aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-10-10 07:51:50 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-10-10 07:51:50 +0000
commit7ea932b69714377fbe36d805228d57f52d9eb957 (patch)
treec8ae9c855810b1eb38f9e8fe11072d2c0faaf53f /x11-fm
parente45344bedec401c23a32a05d9b3065d34e20e8d4 (diff)
downloadports-7ea932b69714377fbe36d805228d57f52d9eb957.tar.gz
ports-7ea932b69714377fbe36d805228d57f52d9eb957.zip
Add upstream patch to fix that the first symbol in directory's name can't
be changed in the new directory dialog. PR: 201336 Submitted by: Andriy Solonenko <ap_berzerk@yahoo.com> Tested by: Tobias Berner <tcberner@gmail.com> Obtained from: krusader upstream
Notes
Notes: svn path=/head/; revision=398980
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/krusader2/Makefile2
-rw-r--r--x11-fm/krusader2/files/patch-git-5cb23ac20
2 files changed, 21 insertions, 1 deletions
diff --git a/x11-fm/krusader2/Makefile b/x11-fm/krusader2/Makefile
index 9013ad824640..ee5f61205f98 100644
--- a/x11-fm/krusader2/Makefile
+++ b/x11-fm/krusader2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= krusader
DISTVERSION= 2.4.0-beta3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= x11-fm kde
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTVERSION}/
diff --git a/x11-fm/krusader2/files/patch-git-5cb23ac b/x11-fm/krusader2/files/patch-git-5cb23ac
new file mode 100644
index 000000000000..c713573003a6
--- /dev/null
+++ b/x11-fm/krusader2/files/patch-git-5cb23ac
@@ -0,0 +1,20 @@
+commit 5cb23ac98046a07d5db3a52b41e3a42544eb13f9
+Author: Jan Lepper <jan_lepper@gmx.de>
+Date: Wed Jan 2 21:38:52 2013 +0100
+
+ FIXED: [ 309119 ] Wrong "New directory" dialog behavior: can't clear all typed text
+ return QValidator::Intermediate instead of Invalid when input is empty
+ BUG: 309119
+
+
+--- krusader/Panel/panelfunc.cpp.orig 2012-10-21 12:55:54.000000000 +0200
++++ krusader/Panel/panelfunc.cpp 2015-10-09 17:43:53.794177000 +0200
+@@ -100,7 +100,7 @@
+ {
+ public:
+ virtual State validate(QString &input, int &pos) const {
+- return input.isEmpty() ? Invalid : Acceptable;
++ return input.isEmpty() ? Intermediate : Acceptable;
+ }
+ };
+