aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-08-10 00:03:14 +0000
committerSteve Price <steve@FreeBSD.org>1998-08-10 00:03:14 +0000
commit21704cd5242b6340e006490704c9b33a26288b59 (patch)
tree1f8ec9f5968ef3b807611035f14f2a57faf563b4 /x11-fm
parent4405a46523922b6b8e8bcb554ebd4350ead9d2b5 (diff)
downloadports-21704cd5242b6340e006490704c9b33a26288b59.tar.gz
ports-21704cd5242b6340e006490704c9b33a26288b59.zip
strtol -> strtoul so the 'magic' file is parsed correctly.
PR: 7535 Submitted by: Sergey Shkonda <serg@bcs.zp.ua>
Notes
Notes: svn path=/head/; revision=12388
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/xfm/Makefile4
-rw-r--r--x11-fm/xfm/files/patch-ab11
-rw-r--r--x11-fm/xfm/pkg-descr1
3 files changed, 14 insertions, 2 deletions
diff --git a/x11-fm/xfm/Makefile b/x11-fm/xfm/Makefile
index 67a2ac37fc74..2197e8e39393 100644
--- a/x11-fm/xfm/Makefile
+++ b/x11-fm/xfm/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 December 1994
# Whom: jc@irbs.com John Capo
#
-# $Id: Makefile,v 1.7 1996/11/18 09:56:20 asami Exp $
+# $Id: Makefile,v 1.8 1998/08/07 22:33:12 asami Exp $
#
DISTNAME= xfm-1.3.2
@@ -11,6 +11,8 @@ CATEGORIES= x11-fm
MASTER_SITES= ${MASTER_SITE_XCONTRIB}
MASTER_SITE_SUBDIR= applications
+MAINTAINER= ports@FreeBSD.ORG
+
LIB_DEPENDS= Xpm\\.4\\.:${PORTSDIR}/graphics/xpm
USE_IMAKE= yes
diff --git a/x11-fm/xfm/files/patch-ab b/x11-fm/xfm/files/patch-ab
new file mode 100644
index 000000000000..c0fdb1311d5c
--- /dev/null
+++ b/x11-fm/xfm/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/magic.c.orig Sun Aug 9 13:47:06 1998
++++ src/magic.c Sun Aug 9 13:47:18 1998
+@@ -227,7 +227,7 @@
+ default:
+ mtypes[count].flags |= M_EQ;
+ }
+- mtypes[count].value.number = strtol(cptr, &cptr, 0);
++ mtypes[count].value.number = strtoul(cptr, &cptr, 0);
+ }
+ while(isspace(*cptr))
+ cptr++;
diff --git a/x11-fm/xfm/pkg-descr b/x11-fm/xfm/pkg-descr
index 34feeceea026..fac60d90369d 100644
--- a/x11-fm/xfm/pkg-descr
+++ b/x11-fm/xfm/pkg-descr
@@ -66,4 +66,3 @@ configuration options. If you are not addicted to the shell and like to
shuffle around files with one hand in order to perform tasks such as moving,
copying, deleting, compiling, formatting, archiving, compressing, etc. etc.,
then xfm is certainly for you.
-