aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>2001-02-26 05:23:40 +0000
committerSteve Price <steve@FreeBSD.org>2001-02-26 05:23:40 +0000
commit61d18b441ea9314e00c4b6330cc825de794c6a60 (patch)
tree543eaddf7b58b1500458bf891e7b6efdd5c169fd /x11-fm
parent251624ffe21d43e04f264c1bab046eda22c7e44d (diff)
downloadports-61d18b441ea9314e00c4b6330cc825de794c6a60.tar.gz
ports-61d18b441ea9314e00c4b6330cc825de794c6a60.zip
Update to version 0.5.
PR: 25294 Submitted by: Sergei Gnezdov <sergeiga@yahoo.com>
Notes
Notes: svn path=/head/; revision=38773
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/vide/Makefile8
-rw-r--r--x11-fm/vide/distinfo2
-rw-r--r--x11-fm/vide/files/patch-aa16
-rw-r--r--x11-fm/vide/files/patch-ac73
-rw-r--r--x11-fm/vide/files/patch-ad29
-rw-r--r--x11-fm/vide/files/patch-ae11
-rw-r--r--x11-fm/vide/files/patch-af11
-rw-r--r--x11-fm/vide/files/patch-config_files.c25
-rw-r--r--x11-fm/vide/files/patch-search_mode.c15
-rw-r--r--x11-fm/vide/files/patch-vide.c45
-rw-r--r--x11-fm/vide/pkg-plist4
11 files changed, 94 insertions, 145 deletions
diff --git a/x11-fm/vide/Makefile b/x11-fm/vide/Makefile
index 2f9de2c88e63..27d3d7594bb2 100644
--- a/x11-fm/vide/Makefile
+++ b/x11-fm/vide/Makefile
@@ -6,20 +6,24 @@
#
PORTNAME= vide
-PORTVERSION= 0.2.6
+PORTVERSION= 0.5
CATEGORIES= x11-fm
MASTER_SITES= http://vide.sourceforge.net/
MAINTAINER= careilly@thecia.ie
+RUN_DEPENDS= vim:${PORTSDIR}/editors/vim5
+
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMELIBS= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-DHAVE_SYS_PARAM_H"
PLIST_SUB= VERSION=${PORTVERSION}
+PATCH_WRKSRC= ${WRKSRC}/src
+
post-patch:
@${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/src/*.c
diff --git a/x11-fm/vide/distinfo b/x11-fm/vide/distinfo
index a9c4588e1124..980ae16975ec 100644
--- a/x11-fm/vide/distinfo
+++ b/x11-fm/vide/distinfo
@@ -1 +1 @@
-MD5 (vide-0.2.6.tar.gz) = cb8479b92e169e15035efa5f9c71c5f3
+MD5 (vide-0.5.tar.gz) = e2141aea2576157e9df4f7a94aa3a8b2
diff --git a/x11-fm/vide/files/patch-aa b/x11-fm/vide/files/patch-aa
deleted file mode 100644
index 8cfa403280c5..000000000000
--- a/x11-fm/vide/files/patch-aa
+++ /dev/null
@@ -1,16 +0,0 @@
---- src/search_mode.c.orig Wed May 17 20:28:02 2000
-+++ src/search_mode.c Wed May 17 20:30:57 2000
-@@ -16,6 +16,13 @@
- * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
- */
-
-+#ifdef HAVE_SYS_PARAM_H
-+#include <sys/param.h>
-+#endif
-+
-+#if (defined(BSD) && (BSD>=199103))
-+#include <sys/types.h>
-+#endif
- #include <fnmatch.h>
- #include<stdio.h>
- #include<string.h>
diff --git a/x11-fm/vide/files/patch-ac b/x11-fm/vide/files/patch-ac
deleted file mode 100644
index 951885707603..000000000000
--- a/x11-fm/vide/files/patch-ac
+++ /dev/null
@@ -1,73 +0,0 @@
---- src/vide.c.orig Thu May 11 03:04:39 2000
-+++ src/vide.c Sat Jun 17 15:19:25 2000
-@@ -224,6 +224,9 @@
-
- getcwd(current_dir, sizeof(current_dir));
-
-+ /* i18n support */
-+ gtk_set_locale();
-+
- /* Set up handler for sigchild so that we don't get zombies */
- new_action.sa_handler = received_sigchild;
- sigemptyset (&new_action.sa_mask);
-@@ -243,7 +246,7 @@
- gdk_color_parse ("yellow", &TAG_COLOR);
- gdk_color_parse ("wheat", &DRAG_HILIGHT);
- COMMAND_TEXT_FONT =
-- gdk_font_load ("-adobe-courier-medium-r-normal-*-12-*-*-*-*-*-*-*");
-+ gdk_fontset_load ("-adobe-courier-medium-r-normal-*-12-*-*-*-*-*-*-*,*");
-
- cfg.filetypes = NULL;
- cfg.bookmarks = NULL;
-@@ -259,7 +262,7 @@
- cfg.confirm_delete = TRUE; // not used
- cfg.confirm_overwrite = TRUE; // not used
- cfg.start_with_cwd = FALSE;
-- strncpy (cfg.viewer_command, "rxvt -e vim",
-+ strncpy (cfg.viewer_command, "xterm -e vi",
- sizeof (cfg.viewer_command));
- cfg.window_width = 640;
- cfg.window_height = 480;
-@@ -268,7 +271,7 @@
- cfg.divide_popup_menu = FALSE; // not used
- cfg.dir_history_max_length = 15;
- cfg.command_history_max_length = 10;
-- strncpy (cfg.xterm_command, "rxvt", sizeof (cfg.xterm_command));
-+ strncpy (cfg.xterm_command, "xterm", sizeof (cfg.xterm_command));
- chdir (getenv ("HOME"));
- getcwd (app.left_view.dir, PATH_MAX);
- strncpy (app.right_view.dir, app.left_view.dir, PATH_MAX);
-@@ -280,9 +283,9 @@
- {
- /* Setup some default filetypes */
- add_filetype ("jpeg,jpg,png,xpm,gif", "xv,gimp", "Image Files");
-- add_filetype ("c,cpp,h,pl,java, py", "x vim", "Source Code Files");
-+ add_filetype ("c,cpp,h,pl,java, py", "x vi", "Source Code Files");
- add_filetype ("o,so,a", "x nm %f | less", "Object Files");
-- add_filetype ("htm,html,php", "netscape,x vim", "HTML Documents");
-+ add_filetype ("htm,html,php", "netscape,x vi", "HTML Documents");
- add_filetype ("tar.gz,tgz", "x tar xzvf %f ,x tar tzvf %f | less",
- "Gzipped Tarballs");
- add_filetype("zip, Z", "x unzip %f", "Zip");
-@@ -310,7 +313,7 @@
- gchar trash_com[128];
- gchar memo_com[128];
- g_snprintf (trash_com, 128, "mv %%f %s", cfg.trash);
-- g_snprintf (memo_com, 128, "rxvt -e vim %s/memo", cfg.config_dir);
-+ g_snprintf (memo_com, 128, "xterm -e vi %s/memo", cfg.config_dir);
-
- add_user_command (" ", "NULL");
- add_user_command ("Memo", memo_com);
-@@ -332,9 +335,9 @@
- }
- if(!read_command_mode_file())
- {
-- add_command("mutt", "exe rxvt -e mutt");
-- add_command("ps", "exe rxvt -e top");
-- add_command("vi", "exe rxvt -e vim");
-+ add_command("mutt", "exe xterm -e mutt");
-+ add_command("ps", "exe xterm -e top");
-+ add_command("vi", "exe xterm -e vi");
- add_command("Backup", "/~$");
- add_command("touch", "exe touch %{Name of new file.}");
- }
diff --git a/x11-fm/vide/files/patch-ad b/x11-fm/vide/files/patch-ad
deleted file mode 100644
index 1d6c7f28b4eb..000000000000
--- a/x11-fm/vide/files/patch-ad
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/command_mode.c.orig Sat Jun 17 15:24:19 2000
-+++ src/command_mode.c Sat Jun 17 15:57:34 2000
-@@ -201,7 +201,7 @@
- buf[4] = '\0';
- if(!strcmp(buf, "grep"))
- {
-- g_snprintf(buf, sizeof(buf), "vim \"+ grep %s\"", command);
-+ g_snprintf(buf, sizeof(buf), "vi \"+ grep %s\"", command);
- exec_in_xterm(buf);
- }
-
-@@ -280,7 +280,7 @@
-
- if(!strcmp(command, "h"))
- {
-- g_snprintf(buf, sizeof(buf), "%s -e vim %s/vide%s.txt",
-+ g_snprintf(buf, sizeof(buf), "%s -e vi %s/vide%s.txt",
- cfg.xterm_command, cfg.config_dir, VERSION);
- file_exec(buf);
- }
-@@ -363,7 +363,7 @@
- /* load file into vi */
- if(!strcmp(command, "e"))
- {
-- g_snprintf(buf, sizeof(buf), "%s -e vim \"%s\"", cfg.xterm_command, file);
-+ g_snprintf(buf, sizeof(buf), "%s -e vi \"%s\"", cfg.xterm_command, file);
- file_exec(buf);
-
- /* g_snprintf(buf, sizeof(buf), ":e %s/%s\r", curr_view->dir, file);
diff --git a/x11-fm/vide/files/patch-ae b/x11-fm/vide/files/patch-ae
deleted file mode 100644
index d91bc1a345a2..000000000000
--- a/x11-fm/vide/files/patch-ae
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/config_files.c.orig Thu Apr 27 04:12:22 2000
-+++ src/config_files.c Sat Jun 17 14:26:55 2000
-@@ -60,7 +60,7 @@
- {
- gchar command[PATH_MAX];
-
-- g_snprintf(command, sizeof(command), "cp /usr/local/share/vide/vide%s.txt %s",
-+ g_snprintf(command, sizeof(command), "cp %%PREFIX%%/share/vide/vide%s.txt %s",
- VERSION, help_file);
- file_exec(command);
-
diff --git a/x11-fm/vide/files/patch-af b/x11-fm/vide/files/patch-af
deleted file mode 100644
index b8de139a6b0d..000000000000
--- a/x11-fm/vide/files/patch-af
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/main_menu.c.orig Sat Jun 17 15:24:20 2000
-+++ src/main_menu.c Sat Jun 17 15:56:55 2000
-@@ -27,7 +27,7 @@
- help_cb(GtkWidget *widget, gpointer data)
- {
- gchar help_command[NAME_MAX];
-- g_snprintf(help_command, sizeof(help_command), "%s -e vim %s/vide%s.txt",
-+ g_snprintf(help_command, sizeof(help_command), "%s -e vi %s/vide%s.txt",
- cfg.xterm_command, cfg.config_dir, VERSION);
- file_exec(help_command);
-
diff --git a/x11-fm/vide/files/patch-config_files.c b/x11-fm/vide/files/patch-config_files.c
new file mode 100644
index 000000000000..fd2ded7da331
--- /dev/null
+++ b/x11-fm/vide/files/patch-config_files.c
@@ -0,0 +1,25 @@
+--- config_files.c.orig Tue Jan 30 12:58:08 2001
++++ config_files.c Sat Feb 24 15:14:46 2001
+@@ -16,6 +16,12 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
++#include<sys/param.h>
++#if defined(__FreeBSD_version)
++ #define CP_HELP "cp /usr/X11R6/share/vide/vide%s.txt %s"
++#else
++ #define CP_HELP "cp /usr/local/share/vide/vide%s.txt %s"
++#endif
+
+ #include <stdlib.h>
+ #include <stdio.h>
+@@ -60,8 +66,7 @@
+ {
+ gchar command[PATH_MAX];
+
+- g_snprintf(command, sizeof(command), "cp /usr/local/share/vide/vide%s.txt %s",
+- VERSION, help_file);
++ g_snprintf(command, sizeof(command), CP_HELP, VERSION, help_file);
+ file_exec(command);
+
+ }
diff --git a/x11-fm/vide/files/patch-search_mode.c b/x11-fm/vide/files/patch-search_mode.c
new file mode 100644
index 000000000000..fd43c645c886
--- /dev/null
+++ b/x11-fm/vide/files/patch-search_mode.c
@@ -0,0 +1,15 @@
+--- search_mode.c.orig Thu Oct 12 23:36:05 2000
++++ search_mode.c Sat Feb 24 15:14:47 2001
+@@ -16,6 +16,12 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
++#include<sys/param.h>
++#if (defined(BSD) && (BSD>=199103))
++ /* Required by regex.h on FreeBSD 4.2 at least. */
++ #include<sys/types.h>
++#endif
++
+ #include <fnmatch.h>
+ #include<stdio.h>
+ #include<string.h>
diff --git a/x11-fm/vide/files/patch-vide.c b/x11-fm/vide/files/patch-vide.c
new file mode 100644
index 000000000000..e7543b2bc261
--- /dev/null
+++ b/x11-fm/vide/files/patch-vide.c
@@ -0,0 +1,45 @@
+--- vide.c.orig Sun Feb 18 15:43:10 2001
++++ vide.c Sat Feb 24 15:14:47 2001
+@@ -16,7 +16,14 @@
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ */
+
+-
++#include<sys/param.h>
++#if defined(__FreeBSD_version)
++ #define RXVT_VIM "xterm -e vim"
++ #define RXVT "xterm"
++#else
++ #define RXVT_VIM "rxvt -e vim"
++ #define RXVT "rxvt"
++#endif
+
+ #include <string.h>
+ #include <unistd.h>
+@@ -280,6 +287,8 @@
+
+ getcwd(current_dir, sizeof(current_dir));
+
++ /* i18n support */
++ gtk_set_locale();
+
+ /* Set up handler for sigchild so that we don't get zombies */
+ new_action.sa_handler = received_sigchild;
+@@ -329,7 +338,7 @@
+ cfg.start_with_cwd = FALSE;
+ strncpy(cfg.vi_clone, "vim", sizeof(cfg.vi_clone));
+ strncpy(cfg.vi_command, "vim", sizeof(cfg.vi_command));
+- strncpy (cfg.viewer_command, "rxvt -e vim",
++ strncpy (cfg.viewer_command, RXVT_VIM,
+ sizeof (cfg.viewer_command));
+ cfg.window_width = 640;
+ cfg.window_height = 480;
+@@ -337,7 +346,7 @@
+ cfg.window_ypos = 0;
+ cfg.dir_history_max_length = 15;
+ cfg.command_history_max_length = 10;
+- strncpy (cfg.xterm_command, "rxvt", sizeof (cfg.xterm_command));
++ strncpy (cfg.xterm_command, RXVT, sizeof (cfg.xterm_command));
+ chdir (getenv ("HOME"));
+ getcwd (app.left_view.dir, PATH_MAX);
+ strncpy (app.right_view.dir, app.left_view.dir, PATH_MAX);
diff --git a/x11-fm/vide/pkg-plist b/x11-fm/vide/pkg-plist
index 1db7386e3758..d5e50b563b09 100644
--- a/x11-fm/vide/pkg-plist
+++ b/x11-fm/vide/pkg-plist
@@ -1,4 +1,4 @@
bin/pauseme
bin/vide
-share/vide/vide%%VERSION%%.txt
-@dirrm share/vide
+share/gnome/vide/vide%%VERSION%%.txt
+@dirrm share/gnome/vide