aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2009-09-14 18:11:55 +0000
committerRenato Botelho <garga@FreeBSD.org>2009-09-14 18:11:55 +0000
commit450ab95645d1e38f04a2057ba1c419a117113b85 (patch)
tree9db5c060cc0434fe1d1278d6522a244a3a29a14f /x11-fm
parentc3b458bce6af83b5f3460eced95fe4ba2ea1c75c (diff)
downloadports-450ab95645d1e38f04a2057ba1c419a117113b85.tar.gz
ports-450ab95645d1e38f04a2057ba1c419a117113b85.zip
- Bump PORTREVISION PR: ports/137684 Submitted by: maintainer Obtained from: https://bugzilla.gnome.org/show_bug.cgi?id=591206
Notes
Notes: svn path=/head/; revision=241413
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/gnome-commander2/Makefile1
-rw-r--r--x11-fm/gnome-commander2/files/patch-src-owner.cc17
2 files changed, 18 insertions, 0 deletions
diff --git a/x11-fm/gnome-commander2/Makefile b/x11-fm/gnome-commander2/Makefile
index 7f2d05983393..2af193a619b9 100644
--- a/x11-fm/gnome-commander2/Makefile
+++ b/x11-fm/gnome-commander2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gnome-commander
PORTVERSION= 1.2.8
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= x11-fm gnome
MASTER_SITES= GNOME
diff --git a/x11-fm/gnome-commander2/files/patch-src-owner.cc b/x11-fm/gnome-commander2/files/patch-src-owner.cc
new file mode 100644
index 000000000000..b125bfe47565
--- /dev/null
+++ b/x11-fm/gnome-commander2/files/patch-src-owner.cc
@@ -0,0 +1,17 @@
+--- src/owner.cc.orig 2009-06-29 06:57:46.000000000 -0300
++++ src/owner.cc 2009-08-10 20:51:05.000000000 -0300
+@@ -62,7 +62,13 @@
+
+ if (!buff)
+ {
+- buffsize = max(sysconf(_SC_GETPW_R_SIZE_MAX), sysconf(_SC_GETGR_R_SIZE_MAX));
++ long int pw_size = sysconf(_SC_GETPW_R_SIZE_MAX);
++ long int gr_size = sysconf(_SC_GETGR_R_SIZE_MAX);
++
++ if (pw_size==-1) pw_size = 4096; // `sysconf' does not support _SC_GETPW_R_SIZE_MAX. Try a moderate value.
++ if (gr_size==-1) gr_size = 4096; // `sysconf' does not support _SC_GETGR_R_SIZE_MAX. Try a moderate value.
++
++ buffsize = max(pw_size, gr_size);
+ buff = g_new0 (char, buffsize);
+ }
+