aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-07-25 13:41:22 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-07-25 13:41:22 +0000
commit6b15f6bdf40e4a0160afbdcda4b50e1fdf71ee77 (patch)
tree055afd27fb33e0ec31608f0b575080c9d1a539b8 /x11-fm
parent37b37f0ed27414d0f8620baa24de34cb44152058 (diff)
downloadports-6b15f6bdf40e4a0160afbdcda4b50e1fdf71ee77.tar.gz
ports-6b15f6bdf40e4a0160afbdcda4b50e1fdf71ee77.zip
Fix the recent problem with list view. You need at least 2.0.1_1 for
this to work. Obrained from GNOME cvs, therefore the patch will go away during the next version update. Bump PORTREVISION. Update to GNOMENG while I am here.
Notes
Notes: svn path=/head/; revision=63529
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/nautilus2/Makefile15
-rw-r--r--x11-fm/nautilus2/files/patch-cvs118
-rw-r--r--x11-fm/nautilus2/pkg-plist26
3 files changed, 123 insertions, 36 deletions
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index aabdc80b2d30..64dfda972623 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nautilus2
PORTVERSION= 2.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= 2.0.0/sources/${PORTNAME:S/2$//}
@@ -24,24 +24,19 @@ LIB_DEPENDS= rsvg-2.2:${PORTSDIR}/graphics/librsvg2 \
USE_BZIP2= yes
USE_GMAKE= yes
USE_X_PREFIX= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomehier
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -fno-rtti -fno-exceptions" \
LIBS="${PTHREAD_LIBS} -L${LOCALBASE}/lib -L${X11BASE}/lib -liconv" \
LIBPNG="-L${LOCALBASE}/lib -lpng -lz ${MOZILLA_LIBS}"
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome \
- --with-freetype2-lib-place=${LOCALBASE}/lib \
+CONFIGURE_ARGS= --with-freetype2-lib-place=${LOCALBASE}/lib \
--with-freetype2-include-place=${LOCALBASE}/include/freetype2
-pre-patch:
+post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${REINPLACE_CMD} -e \
- 's|[(]datadir[)]/gnome/|(datadir)/|g ; \
- s|[(]datadir[)]/locale|(prefix)/share/locale|g ; \
- s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
- s|[(]libdir[)]/bonobo/servers|(prefix)/libdata/bonobo/servers|g'
.include <bsd.port.mk>
diff --git a/x11-fm/nautilus2/files/patch-cvs b/x11-fm/nautilus2/files/patch-cvs
new file mode 100644
index 000000000000..487844a73147
--- /dev/null
+++ b/x11-fm/nautilus2/files/patch-cvs
@@ -0,0 +1,118 @@
+Index: src/nautilus-sidebar.c
+===================================================================
+RCS file: /cvs/gnome/nautilus/src/nautilus-sidebar.c,v
+retrieving revision 1.214
+retrieving revision 1.215
+diff -d -u -r1.214 -r1.215
+--- src/nautilus-sidebar.c 22 Jul 2002 18:03:44 -0000 1.214
++++ src/nautilus-sidebar.c 24 Jul 2002 20:20:51 -0000 1.215
+@@ -38,7 +38,6 @@
+ #include <bonobo/bonobo-exception.h>
+
+ #include <eel/eel-background.h>
+-#include <eel/eel-background-style.h>
+ #include <eel/eel-glib-extensions.h>
+ #include <eel/eel-gtk-extensions.h>
+ #include <eel/eel-gtk-macros.h>
+@@ -178,7 +177,7 @@
+ TABS_PART
+ } SidebarPart;
+
+-EEL_CLASS_BOILERPLATE (NautilusSidebar, nautilus_sidebar, GTK_TYPE_EVENT_BOX)
++EEL_CLASS_BOILERPLATE (NautilusSidebar, nautilus_sidebar, EEL_TYPE_BACKGROUND_BOX)
+
+ /* initializing the class object by installing the operations we override */
+ static void
+@@ -1713,15 +1712,10 @@
+ nautilus_sidebar_style_set (GtkWidget *widget, GtkStyle *previous_style)
+ {
+ NautilusSidebar *sidebar;
+- GtkStyle *style;
+
+ sidebar = NAUTILUS_SIDEBAR (widget);
+
+- style = gtk_widget_get_style (widget);
+-
+- /* This is slightly hackish */
+- if (!EEL_IS_BACKGROUND_STYLE (style))
+- nautilus_sidebar_theme_changed (sidebar);
++ nautilus_sidebar_theme_changed (sidebar);
+ }
+
+ void
+Index: src/nautilus-sidebar.h
+===================================================================
+RCS file: /cvs/gnome/nautilus/src/nautilus-sidebar.h,v
+retrieving revision 1.15
+retrieving revision 1.16
+diff -d -u -r1.15 -r1.16
+--- src/nautilus-sidebar.h 7 Mar 2002 14:02:19 -0000 1.15
++++ src/nautilus-sidebar.h 24 Jul 2002 20:20:51 -0000 1.16
+@@ -28,7 +28,8 @@
+ #ifndef NAUTILUS_SIDEBAR_H
+ #define NAUTILUS_SIDEBAR_H
+
+-#include <gtk/gtkeventbox.h>
++#include <eel/eel-background-box.h>
++
+ #include "nautilus-view-frame.h"
+
+ #define NAUTILUS_TYPE_SIDEBAR \
+@@ -45,12 +46,12 @@
+ typedef struct NautilusSidebarDetails NautilusSidebarDetails;
+
+ typedef struct {
+- GtkEventBox parent_slot;
++ EelBackgroundBox parent_slot;
+ NautilusSidebarDetails *details;
+ } NautilusSidebar;
+
+ typedef struct {
+- GtkEventBoxClass parent_slot;
++ EelBackgroundBoxClass parent_slot;
+
+ void (*location_changed) (NautilusSidebar *sidebar,
+ const char *location);
+Index: src/nautilus-window-manage-views.c
+===================================================================
+RCS file: /cvs/gnome/nautilus/src/nautilus-window-manage-views.c,v
+retrieving revision 1.305
+retrieving revision 1.306
+diff -d -u -r1.305 -r1.306
+--- src/nautilus-window-manage-views.c 18 Jul 2002 05:58:20 -0000 1.305
++++ src/nautilus-window-manage-views.c 24 Jul 2002 16:26:19 -0000 1.306
+@@ -231,7 +231,7 @@
+ nautilus_sidebar_set_title (window->sidebar, title);
+ }
+
+- if (title [0] != '\0' &&
++ if (title [0] != '\0' && window->current_location_bookmark &&
+ nautilus_bookmark_set_name (window->current_location_bookmark, title)) {
+ /* Name of item in history list changed, tell listeners. */
+ nautilus_send_history_list_changed ();
+Index: src/nautilus-window.c
+===================================================================
+RCS file: /cvs/gnome/nautilus/src/nautilus-window.c,v
+retrieving revision 1.392
+retrieving revision 1.393
+diff -d -u -r1.392 -r1.393
+--- src/nautilus-window.c 18 Jul 2002 05:58:21 -0000 1.392
++++ src/nautilus-window.c 24 Jul 2002 07:45:10 -0000 1.393
+@@ -788,10 +788,16 @@
+
+ nautilus_window_manage_views_destroy (window);
+
++ window->sidebar = NULL;
+ eel_g_object_list_free (window->sidebar_panels);
+ window->sidebar_panels = NULL;
+
+- if (window->content_view != NULL) {
++ window->view_as_option_menu = NULL;
++ window->navigation_bar = NULL;
++ window->content_hbox = NULL;
++ window->zoom_control = NULL;
++
++ if (window->content_view) {
+ gtk_object_destroy (GTK_OBJECT (window->content_view));
+ window->content_view = NULL;
+ }
diff --git a/x11-fm/nautilus2/pkg-plist b/x11-fm/nautilus2/pkg-plist
index b9632a3138a8..dfbcf74e56fa 100644
--- a/x11-fm/nautilus2/pkg-plist
+++ b/x11-fm/nautilus2/pkg-plist
@@ -584,30 +584,8 @@ share/locale/uk/LC_MESSAGES/nautilus.mo
share/locale/vi/LC_MESSAGES/nautilus.mo
share/locale/zh_CN/LC_MESSAGES/nautilus.mo
share/locale/zh_TW/LC_MESSAGES/nautilus.mo
-@dirrm share/gnome/pixmaps/nautilus/throbber
-@dirrm share/gnome/pixmaps/nautilus/tahoe
-@dirrm share/gnome/pixmaps/nautilus/sierra
-@dirrm share/gnome/pixmaps/nautilus/sidebar_tab_pieces
-@dirrm share/gnome/pixmaps/nautilus/gnome/throbber
-@dirrm share/gnome/pixmaps/nautilus/gnome/sidebar_tab_pieces
-@dirrm share/gnome/pixmaps/nautilus/gnome
@dirrm share/gnome/pixmaps/nautilus/default
-@dirrm share/gnome/pixmaps/nautilus/crux_teal/throbber
-@dirrm share/gnome/pixmaps/nautilus/crux_teal/sidebar_tab_pieces
-@dirrm share/gnome/pixmaps/nautilus/crux_teal/backgrounds
-@dirrm share/gnome/pixmaps/nautilus/crux_teal
-@dirrm share/gnome/pixmaps/nautilus/crux_eggplant/throbber
-@dirrm share/gnome/pixmaps/nautilus/crux_eggplant/sidebar_tab_pieces
-@dirrm share/gnome/pixmaps/nautilus/crux_eggplant/backgrounds
-@dirrm share/gnome/pixmaps/nautilus/crux_eggplant
-@dirrm share/gnome/pixmaps/nautilus
-@dirrm share/gnome/nautilus/services/text
-@dirrm share/gnome/nautilus/services
-@dirrm share/gnome/nautilus/patterns
@dirrm share/gnome/nautilus/glade
-@dirrm share/gnome/nautilus/emblems
-@dirrm share/gnome/nautilus
-@dirrm include/libnautilus
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/nautilus/sidebar_panels/tree
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/nautilus/sidebar_panels
@dirrm etc/gconf/gconf.xml.defaults/schemas/apps/nautilus/preferences
@@ -622,7 +600,3 @@ share/locale/zh_TW/LC_MESSAGES/nautilus.mo
@dirrm etc/gconf/gconf.xml.defaults/apps/nautilus/list_view
@dirrm etc/gconf/gconf.xml.defaults/apps/nautilus/icon_view
@dirrm etc/gconf/gconf.xml.defaults/apps/nautilus
-@dirrm etc/X11/sysconfig
-@dirrm etc/X11/starthere
-@dirrm etc/X11/serverconfig
-@dirrm etc/X11