aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-09-10 20:41:18 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-09-10 20:41:18 +0000
commitedce75347a5bcd4cf5dd750ae810a5b6e881e071 (patch)
treedf3239b8ccbc80af98ef1e30b0f4f6e5fa8f292f /x11-fm
parent18535436dd28e7cd0f67743e503e04b84d10e1d1 (diff)
downloadports-edce75347a5bcd4cf5dd750ae810a5b6e881e071.tar.gz
ports-edce75347a5bcd4cf5dd750ae810a5b6e881e071.zip
Complete the removable media patch as was done in nautilus.
Notes
Notes: svn path=/head/; revision=66088
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/nautilus2/Makefile2
-rw-r--r--x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c27
2 files changed, 23 insertions, 6 deletions
diff --git a/x11-fm/nautilus2/Makefile b/x11-fm/nautilus2/Makefile
index ac261077a6eb..2df134b64570 100644
--- a/x11-fm/nautilus2/Makefile
+++ b/x11-fm/nautilus2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= nautilus2
PORTVERSION= 2.0.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= x11-fm gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= 2.0.1/sources/${PORTNAME:S/2$//}
diff --git a/x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c b/x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c
index a2faedc8c4ea..cedcf1a7285e 100644
--- a/x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c
+++ b/x11-fm/nautilus2/files/patch-libnautilus-private::nautilus-volume-monitor.c
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- libnautilus-private/nautilus-volume-monitor.c.orig Wed Aug 28 16:37:20 2002
-+++ libnautilus-private/nautilus-volume-monitor.c Tue Sep 10 01:42:20 2002
+--- libnautilus-private/nautilus-volume-monitor.c.orig Wed Aug 28 09:37:20 2002
++++ libnautilus-private/nautilus-volume-monitor.c Tue Sep 10 16:37:32 2002
@@ -59,6 +59,18 @@
#include <sys/types.h>
#include <unistd.h>
@@ -190,3 +187,23 @@ $FreeBSD$
/* These are set up by get_current_mount_list for Solaris. */
volume->is_removable = volume_is_removable (volume);
#endif
+@@ -1794,7 +1850,7 @@
+ ok = mount_volume_auto_add (volume);
+ } else if (strcmp (file_system_type_name, "cdda") == 0) {
+ ok = mount_volume_cdda_add (volume);
+- } else if (strcmp (file_system_type_name, "iso9660") == 0) {
++ } else if (strcmp (file_system_type_name, "cd9660") == 0) {
+ ok = mount_volume_iso9660_add (volume);
+ } else if (strcmp (file_system_type_name, "nfs") == 0) {
+ ok = mount_volume_nfs_add (volume);
+@@ -1823,8 +1879,8 @@
+ }
+
+ /* Identify device type */
+- if (eel_str_has_prefix (volume->mount_path, "/mnt/")) {
+- name = volume->mount_path + strlen ("/mnt/");
++ if (eel_str_has_prefix (volume->mount_path, "/")) {
++ name = volume->mount_path + strlen ("/");
+
+ if (eel_str_has_prefix (name, "cdrom")
+ || eel_str_has_prefix (name, "burn")) {