aboutsummaryrefslogtreecommitdiff
path: root/x11-fm
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-03-25 11:19:32 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-03-25 11:19:32 +0000
commit15572d659ec36339a9432364e68add657ef58049 (patch)
treeca7d1365c9ad3c90594327ccdd51feab9c8da4be /x11-fm
parent5014a21d7c94341cc58709475965d8438d06600e (diff)
downloadports-15572d659ec36339a9432364e68add657ef58049.tar.gz
ports-15572d659ec36339a9432364e68add657ef58049.zip
- Update to 10.12.28.23
PR: 155846 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=271675
Diffstat (limited to 'x11-fm')
-rw-r--r--x11-fm/filerunner/Makefile41
-rw-r--r--x11-fm/filerunner/distinfo4
-rw-r--r--x11-fm/filerunner/files/patch-aa17
-rw-r--r--x11-fm/filerunner/files/patch-ab25
-rw-r--r--x11-fm/filerunner/files/patch-ac18
-rw-r--r--x11-fm/filerunner/files/patch-frcolor10
-rw-r--r--x11-fm/filerunner/files/patch-frftp10
-rw-r--r--x11-fm/filerunner/pkg-descr3
-rw-r--r--x11-fm/filerunner/pkg-plist33
9 files changed, 39 insertions, 122 deletions
diff --git a/x11-fm/filerunner/Makefile b/x11-fm/filerunner/Makefile
index 8b638f011c33..a83be6c9d7ad 100644
--- a/x11-fm/filerunner/Makefile
+++ b/x11-fm/filerunner/Makefile
@@ -6,41 +6,34 @@
#
PORTNAME= filerunner
-PORTVERSION= 2.5.1
-PORTREVISION= 2
+PORTVERSION= 10.12.28.23
CATEGORIES= x11-fm tk
-MASTER_SITES= ${MASTER_SITE_NETBSD} \
- http://www.cd.chalmers.se/~hch/
-DISTNAME= FileRunner-${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}
+DISTNAME= fr-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Filemanager with FTP capabilities. Uses Tcl/Tk
-DEPRECATED= Upstream disapear and distfile is no more available
-EXPIRATION_DATE= 2011-05-01
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= tk84.1:${PORTSDIR}/x11-toolkits/tk84
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
-MAKEFILE= Makefile.freebsd_gcc
-
-pre-build:
-# @ ${RM} ${WRKSRC}/ext.so
- @ ${CP} ${WRKSRC}/Makefiles/Makefile.freebsd_gcc ${WRKSRC}
+USE_TK_WRAPPER= yes
do-install:
+ @${MKDIR} ${PREFIX}/lib/FileRunner
+.for file in COPYING FAQ HISTORY README fr frftp tclIndex *.tcl *.txt *.xpm
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/lib/FileRunner
+.endfor
@${MKDIR} ${PREFIX}/lib/FileRunner/bitmaps
- @${INSTALL_SCRIPT} ${WRKSRC}/fr ${PREFIX}/lib/FileRunner
- @${INSTALL_SCRIPT} ${WRKSRC}/frcolor ${PREFIX}/lib/FileRunner
- @${INSTALL_SCRIPT} ${WRKSRC}/frftp ${PREFIX}/lib/FileRunner
- @${LN} -sf ${PREFIX}/lib/FileRunner/fr ${PREFIX}/bin
-.for file in COPYING FAQ HISTORY KnownBugs.txt QuickStart.txt README Tips.txt \
- Users_Guide.txt chmod.tcl cmd.tcl config.tcl dialog.tcl ext.so font.tcl \
- ftp.tcl http.tcl tclIndex
- @${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/lib/FileRunner
+.for file in *.bit
+ ${INSTALL_DATA} ${WRKSRC}/bitmaps/${file} ${PREFIX}/lib/FileRunner/bitmaps
.endfor
-.for map in cross.bit frterm.bit larger.bit left.bit max.bit pgdown.bit pgup.bit \
- right.bit smaller.bit toggle.bit tree.bit up.bit update.bit xterm.bit
- @${INSTALL_DATA} ${WRKSRC}/bitmaps/${map} ${PREFIX}/lib/FileRunner/bitmaps
+.for file in fr frftp frcolor.tcl
+ @${CHMOD} ${BINMODE} ${PREFIX}/lib/FileRunner/${file}
.endfor
+ @${LN} -sf ${PREFIX}/lib/FileRunner/fr ${PREFIX}/bin/fr
.include <bsd.port.mk>
diff --git a/x11-fm/filerunner/distinfo b/x11-fm/filerunner/distinfo
index bf99a1d813aa..76971a7a9a8d 100644
--- a/x11-fm/filerunner/distinfo
+++ b/x11-fm/filerunner/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FileRunner-2.5.1.tar.gz) = 3f1ad9b52cca5d130a1679aaa9ac3d34fd75518d636a2d7f1bf1c841fd54590b
-SIZE (FileRunner-2.5.1.tar.gz) = 122795
+SHA256 (fr-10.12.28.23.tar.gz) = e7021eca56187db5aa8083264810306b1ef2f4b4215a13b4b0cc69a5a0415c50
+SIZE (fr-10.12.28.23.tar.gz) = 354493
diff --git a/x11-fm/filerunner/files/patch-aa b/x11-fm/filerunner/files/patch-aa
deleted file mode 100644
index f83d3e2d1b24..000000000000
--- a/x11-fm/filerunner/files/patch-aa
+++ /dev/null
@@ -1,17 +0,0 @@
---- Makefiles/Makefile.freebsd_gcc.orig Wed Oct 12 17:56:27 2005
-+++ Makefiles/Makefile.freebsd_gcc Thu Dec 30 19:21:49 1999
-@@ -1,10 +1,10 @@
-
- # Change this if you have this stuff somewhere else.
--TCLINC = /usr/local/lib/tcl8.0
--TKINC = /usr/local/lib/tk8.0
--X11INC = /usr/X11/include
-+TCLINC = ${PREFIX}/include/tcl8.4
-+TKINC = ${PREFIX}/include/tk8.4
-+X11INC = ${LOCALBASE}/include
-
--CFLAGS = -Wall -fPIC -O3 -I$(TCLINC) -I$(TKINC) -I$(X11INC)
-+CFLAGS += -Wall -fPIC -I$(TCLINC) -I$(TKINC) -I$(X11INC)
-
- CC = gcc
-
diff --git a/x11-fm/filerunner/files/patch-ab b/x11-fm/filerunner/files/patch-ab
deleted file mode 100644
index beb53d9dd5e1..000000000000
--- a/x11-fm/filerunner/files/patch-ab
+++ /dev/null
@@ -1,25 +0,0 @@
---- fr.orig Wed Oct 12 18:13:36 2005
-+++ fr Wed Oct 12 18:15:47 2005
-@@ -1,6 +1,6 @@
- #! /bin/sh
- # -*- tcl -*- \
--exec wish $0 wish $*
-+exec wish8.4 $0 wish8.4 $*
-
- set glob(version) 2.5.1
-
-@@ -3301,10 +3301,10 @@
- FindLibfr
-
- # Load patches for 8.0...
--if {$tk_patchLevel == "8.0"} {
-- #puts "Buggy 8.0 menu.tcl file, applying patch"
-- source $glob(lib_fr)/menu_80_patch.tcl
--}
-+#if {$tk_patchLevel == "8.0"} {
-+# #puts "Buggy 8.0 menu.tcl file, applying patch"
-+# source $glob(lib_fr)/menu_80_patch.tcl
-+#}
-
- set auto_path [linsert $auto_path 0 $glob(lib_fr) ]
-
diff --git a/x11-fm/filerunner/files/patch-ac b/x11-fm/filerunner/files/patch-ac
deleted file mode 100644
index 1c5a1612a121..000000000000
--- a/x11-fm/filerunner/files/patch-ac
+++ /dev/null
@@ -1,18 +0,0 @@
---- ext.c.orig Sun Nov 13 12:52:16 2005
-+++ ext.c Sun Nov 13 12:52:57 2005
-@@ -123,11 +123,12 @@
- HANDLE2(*p != '\0', "Error converting arg to int");
-
- time_s = localtime(&t);
-+ time_s->tm_year = 1900 + time_s->tm_year;
- if (dateformat)
-- sprintf(interp->result, "%02d%02d%02d %02d:%02d:%02d", time_s->tm_mday, time_s->tm_mon+1,
-- time_s->tm_year % 100, time_s->tm_hour, time_s->tm_min, time_s->tm_sec);
-+ sprintf(interp->result, "%02d%02d%04d %02d:%02d:%02d", time_s->tm_mday, time_s->tm_mon+1,
-+ time_s->tm_year, time_s->tm_hour, time_s->tm_min, time_s->tm_sec);
- else
-- sprintf(interp->result, "%02d%02d%02d %02d:%02d:%02d", time_s->tm_year % 100, time_s->tm_mon+1,
-+ sprintf(interp->result, "%04d%02d%02d %02d:%02d:%02d", time_s->tm_year, time_s->tm_mon+1,
- time_s->tm_mday, time_s->tm_hour, time_s->tm_min, time_s->tm_sec);
- return TCL_OK;
- }
diff --git a/x11-fm/filerunner/files/patch-frcolor b/x11-fm/filerunner/files/patch-frcolor
deleted file mode 100644
index 6d577941148e..000000000000
--- a/x11-fm/filerunner/files/patch-frcolor
+++ /dev/null
@@ -1,10 +0,0 @@
---- frcolor.orig Wed Oct 12 18:25:44 2005
-+++ frcolor Wed Oct 12 18:22:46 2005
-@@ -1,6 +1,6 @@
- #!/bin/sh
- # the next line restarts using wish \
--exec wish8.0 "$0" "$@"
-+exec wish8.4 "$0" "$@"
-
- # tcolor --
- # This script implements a simple color editor, where you can
diff --git a/x11-fm/filerunner/files/patch-frftp b/x11-fm/filerunner/files/patch-frftp
deleted file mode 100644
index d06b3d5adea5..000000000000
--- a/x11-fm/filerunner/files/patch-frftp
+++ /dev/null
@@ -1,10 +0,0 @@
---- frftp.orig Wed Oct 12 18:25:26 2005
-+++ frftp Wed Oct 12 18:22:46 2005
-@@ -1,6 +1,6 @@
- #! /bin/sh
- # the next line restarts using wish \
--exec wish8.0 $0 wish8.0 $*
-+exec wish8.4 $0 wish8.4 $*
-
-
- proc ShowWindow { realhost file } {
diff --git a/x11-fm/filerunner/pkg-descr b/x11-fm/filerunner/pkg-descr
index c85c2a4ab9c2..8c30f0138bdc 100644
--- a/x11-fm/filerunner/pkg-descr
+++ b/x11-fm/filerunner/pkg-descr
@@ -1,4 +1,3 @@
Filemanager with FTP capabilities. Uses Tcl/Tk.
-FileRunner is distributed under the GNU General Public License since
-FileRunner version 2.5.1
+WWW: http://sourceforge.net/projects/filerunner/
diff --git a/x11-fm/filerunner/pkg-plist b/x11-fm/filerunner/pkg-plist
index 13aac8712502..8cb3ccc2c0f6 100644
--- a/x11-fm/filerunner/pkg-plist
+++ b/x11-fm/filerunner/pkg-plist
@@ -1,23 +1,15 @@
+bin/fr
lib/FileRunner/COPYING
lib/FileRunner/FAQ
+lib/FileRunner/FontControl.tcl
lib/FileRunner/HISTORY
lib/FileRunner/KnownBugs.txt
lib/FileRunner/QuickStart.txt
lib/FileRunner/README
lib/FileRunner/Tips.txt
+lib/FileRunner/To_Do.txt
lib/FileRunner/Users_Guide.txt
-lib/FileRunner/chmod.tcl
-lib/FileRunner/cmd.tcl
-lib/FileRunner/config.tcl
-lib/FileRunner/dialog.tcl
-lib/FileRunner/ext.so
-lib/FileRunner/font.tcl
-lib/FileRunner/fr
-lib/FileRunner/frcolor
-lib/FileRunner/frftp
-lib/FileRunner/ftp.tcl
-lib/FileRunner/http.tcl
-lib/FileRunner/tclIndex
+lib/FileRunner/balloon.tcl
lib/FileRunner/bitmaps/cross.bit
lib/FileRunner/bitmaps/frterm.bit
lib/FileRunner/bitmaps/larger.bit
@@ -27,11 +19,24 @@ lib/FileRunner/bitmaps/pgdown.bit
lib/FileRunner/bitmaps/pgup.bit
lib/FileRunner/bitmaps/right.bit
lib/FileRunner/bitmaps/smaller.bit
-lib/FileRunner/bitmaps/tree.bit
lib/FileRunner/bitmaps/toggle.bit
+lib/FileRunner/bitmaps/tree.bit
lib/FileRunner/bitmaps/up.bit
lib/FileRunner/bitmaps/update.bit
lib/FileRunner/bitmaps/xterm.bit
-bin/fr
+lib/FileRunner/chmod.tcl
+lib/FileRunner/cmd.tcl
+lib/FileRunner/config.tcl
+lib/FileRunner/dialog.tcl
+lib/FileRunner/editfont.tcl
+lib/FileRunner/font.tcl
+lib/FileRunner/fr
+lib/FileRunner/frcolor.tcl
+lib/FileRunner/frftp
+lib/FileRunner/ftp.tcl
+lib/FileRunner/ftpcore.tcl
+lib/FileRunner/http.tcl
+lib/FileRunner/icon.xpm
+lib/FileRunner/tclIndex
@dirrm lib/FileRunner/bitmaps
@dirrm lib/FileRunner