aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/libXft
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-27 23:54:40 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2005-03-27 23:54:40 +0000
commitfc86da016cc987c4b71190dc00a3b0d326068355 (patch)
treedb91a4c4830d11555d05c0e3b910afa96de19e35 /x11-fonts/libXft
parent8abecbc13e47906beeb472ef005a20c3df430ec9 (diff)
downloadports-fc86da016cc987c4b71190dc00a3b0d326068355.tar.gz
ports-fc86da016cc987c4b71190dc00a3b0d326068355.zip
Fix a crash that can occur when using TrueType fonts. This should have
gone in with X.Org 6.8.2, but since we're using the external libXft library, it was missed. Reported by: adamw Obtained from: Freedesktop.org CVS Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=132091
Diffstat (limited to 'x11-fonts/libXft')
-rw-r--r--x11-fonts/libXft/Makefile1
-rw-r--r--x11-fonts/libXft/files/patch-xftfreetype.c12
2 files changed, 13 insertions, 0 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
index cf75a4d4dd9d..d20a0946116b 100644
--- a/x11-fonts/libXft/Makefile
+++ b/x11-fonts/libXft/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libXft
PORTVERSION= 2.1.6
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= http://freedesktop.org/~ajax/xlibs-release/
diff --git a/x11-fonts/libXft/files/patch-xftfreetype.c b/x11-fonts/libXft/files/patch-xftfreetype.c
new file mode 100644
index 000000000000..2868f3d52a1f
--- /dev/null
+++ b/x11-fonts/libXft/files/patch-xftfreetype.c
@@ -0,0 +1,12 @@
+--- xftfreetype.c.orig Sun Mar 27 18:51:12 2005
++++ xftfreetype.c Sun Mar 27 18:51:53 2005
+@@ -289,7 +289,8 @@ _XftReleaseFile (XftFtFile *f)
+ if (f->face)
+ FT_Done_Face (f->face);
+ }
+- XftMemFree (XFT_MEM_FILE, sizeof (XftFtFile) + strlen (f->file) + 1);
++ XftMemFree (XFT_MEM_FILE,
++ sizeof (XftFtFile) + (f->file ? strlen (f->file) + 1 : 0));
+ free (f);
+ }
+