aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/libXft
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-06 21:31:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-10-06 21:31:28 +0000
commit81739f4ec535a19d5c3a3efd46388115348fc888 (patch)
tree7e30476852bfeca5fc593e4a6106c8bef43e03c2 /x11-fonts/libXft
parentcdfc1500dd78bc6f016bf33e2cfd1559b98e7234 (diff)
downloadports-81739f4ec535a19d5c3a3efd46388115348fc888.tar.gz
ports-81739f4ec535a19d5c3a3efd46388115348fc888.zip
Add Xft 2.0, a client-sided font rendering engine for X applications.
Notes
Notes: svn path=/head/; revision=67506
Diffstat (limited to 'x11-fonts/libXft')
-rw-r--r--x11-fonts/libXft/Makefile31
-rw-r--r--x11-fonts/libXft/distinfo1
-rw-r--r--x11-fonts/libXft/files/patch-Makefile.in71
-rw-r--r--x11-fonts/libXft/files/patch-xft.pc.in9
-rw-r--r--x11-fonts/libXft/pkg-comment1
-rw-r--r--x11-fonts/libXft/pkg-descr10
-rw-r--r--x11-fonts/libXft/pkg-plist7
7 files changed, 130 insertions, 0 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
new file mode 100644
index 000000000000..ce57e8addf6e
--- /dev/null
+++ b/x11-fonts/libXft/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: Xft
+# Date created: 06 October 2002
+# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Xft
+PORTVERSION= 2.0
+CATEGORIES= x11-fonts
+MASTER_SITES= http://fontconfig.org/release/
+DISTNAME= fcpackage.${PORTVERSION:S/./_/}
+
+MAINTAINER= gnome@FreeBSD.org
+
+LIB_DEPENDS= fontconfig:${PORTSDIR}/x11-fonts/fontconfig
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+INSTALLS_SHLIB= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib"
+WRKSRC= ${WRKDIR}/${DISTNAME}/Xft
+
+pre-patch:
+ @${REINPLACE_CMD} -e 's|[(]LIBDIR[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/libXft/distinfo b/x11-fonts/libXft/distinfo
new file mode 100644
index 000000000000..4666acdee46a
--- /dev/null
+++ b/x11-fonts/libXft/distinfo
@@ -0,0 +1 @@
+MD5 (fcpackage.2_0.tar.gz) = 5ef5c58e501b0cb873ee2b2a04ed74e3
diff --git a/x11-fonts/libXft/files/patch-Makefile.in b/x11-fonts/libXft/files/patch-Makefile.in
new file mode 100644
index 000000000000..3fa9820768b0
--- /dev/null
+++ b/x11-fonts/libXft/files/patch-Makefile.in
@@ -0,0 +1,71 @@
+--- Makefile.in.orig Sun Oct 6 17:20:05 2002
++++ Makefile.in Sun Oct 6 17:24:38 2002
+@@ -60,11 +60,10 @@
+ # programs
+ BINDIR=$(bindir)
+ # include files
+-INCLUDEDIR=$(includedir)/X11/Xft
++INCLUDEDIR=$(includedir)/X11/Xft2
+
+-LIBBASE=libXft.so
+-LIBFILE=$(LIBBASE).@PACKAGE_MAJOR@.@PACKAGE_MINOR@
+-LIBMAJOR=$(LIBBASE).@PACKAGE_MAJOR@
++LIBBASE=libXft2.so
++LIBFILE=$(LIBBASE).@PACKAGE_MAJOR@
+
+ LIBS=@LIBS@
+
+@@ -109,7 +108,7 @@
+ .c.@OBJEXT@:
+ $(CC) $(CFLAGS) $(DSO_PIC_CFLAGS) -c $< -o $@
+
+-all:: $(LIBFILE) $(LIBMAJOR) $(LIBBASE)
++all:: $(LIBFILE) $(LIBBASE)
+
+ #
+ # Build the library
+@@ -118,13 +117,9 @@
+ rm -f $@
+ $(MKSHLIB) $(OBJS) $(LIBS)
+
+-$(LIBMAJOR): $(LIBFILE)
+- rm -f $@
+- $(LN_S) $(LIBFILE) $(LIBMAJOR)
+-
+-$(LIBBASE): $(LIBMAJOR)
++$(LIBBASE): $(LIBFILE)
+ rm -f $@
+- $(LN_S) $(LIBMAJOR) $(LIBBASE)
++ $(LN_S) $(LIBFILE) $(LIBBASE)
+
+ $(OBJS): $(HEADERS)
+
+@@ -151,19 +146,15 @@
+ # install library
+ #
+
+-install:: $(DESTDIR)$(LIBDIR)/$(LIB) $(DESTDIR)$(LIBDIR)/$(LIBMAJOR)
++install:: $(DESTDIR)$(LIBDIR)/$(LIB)
+ install:: $(DESTDIR)$(LIBDIR)/$(LIBBASE)
+
+ $(DESTDIR)$(LIBDIR)/$(LIBFILE): $(LIBFILE)
+ $(INSTALL_PROGRAM) $< $(DESTDIR)$(LIBDIR)
+
+-$(DESTDIR)$(LIBDIR)/$(LIBMAJOR): $(DESTDIR)$(LIBDIR)/$(LIBFILE)
+- rm -f $@
+- $(LN_S) $(LIBFILE) $(DESTDIR)$(LIBDIR)/$(LIBMAJOR)
+-
+-$(DESTDIR)$(LIBDIR)/$(LIBBASE): $(DESTDIR)$(LIBDIR)/$(LIBMAJOR)
++$(DESTDIR)$(LIBDIR)/$(LIBBASE): $(DESTDIR)$(LIBDIR)/$(LIBFILE)
+ rm -f $@
+- $(LN_S) $(LIBMAJOR) $(DESTDIR)$(LIBDIR)/$(LIBBASE)
++ $(LN_S) $(LIBFILE) $(DESTDIR)$(LIBDIR)/$(LIBBASE)
+
+ #
+ # install xft-config script
+@@ -200,4 +191,4 @@
+ # delete generated files
+ #
+ clean::
+- rm -f $(LIBFILE) $(LIBMAJOR) $(LIBBASE) $(OBJS)
++ rm -f $(LIBFILE) $(LIBFILE) $(LIBBASE) $(OBJS)
diff --git a/x11-fonts/libXft/files/patch-xft.pc.in b/x11-fonts/libXft/files/patch-xft.pc.in
new file mode 100644
index 000000000000..9b2456b9f4e5
--- /dev/null
+++ b/x11-fonts/libXft/files/patch-xft.pc.in
@@ -0,0 +1,9 @@
+--- xft.pc.in.orig Sun Oct 6 17:17:59 2002
++++ xft.pc.in Sun Oct 6 17:18:10 2002
+@@ -11,5 +11,5 @@
+ Description: X FreeType library
+ Version: @PACKAGE_VERSION@
+ Requires: fontconfig
+-Libs: -L${libdir} -lXft ${freetypelibs} ${xrenderlibs}
++Libs: -L${libdir} -lXft2 ${freetypelibs} ${xrenderlibs}
+ Cflags: -I${includedir} ${freetypecflags} ${xrendercflags}
diff --git a/x11-fonts/libXft/pkg-comment b/x11-fonts/libXft/pkg-comment
new file mode 100644
index 000000000000..ccac3dc32fa8
--- /dev/null
+++ b/x11-fonts/libXft/pkg-comment
@@ -0,0 +1 @@
+A client-sided font API for X applications
diff --git a/x11-fonts/libXft/pkg-descr b/x11-fonts/libXft/pkg-descr
new file mode 100644
index 000000000000..7ab6d24bb288
--- /dev/null
+++ b/x11-fonts/libXft/pkg-descr
@@ -0,0 +1,10 @@
+The current version of Xft (2.0) provides a client-side font API for X
+applications. It uses Fontconfig to select fonts and the X protocol for
+rendering them. When available, Xft uses the Render extension to accelerate
+text drawing. When Render is not available, Xft uses the core protocol to draw
+client-side glyphs. This provides completely compatible support of client-side
+fonts for all X servers.
+
+-- keithp
+
+WWW: http://fontconfig.org/
diff --git a/x11-fonts/libXft/pkg-plist b/x11-fonts/libXft/pkg-plist
new file mode 100644
index 000000000000..3b7fd1f1c46a
--- /dev/null
+++ b/x11-fonts/libXft/pkg-plist
@@ -0,0 +1,7 @@
+bin/xft-config
+include/X11/Xft2/Xft.h
+include/X11/Xft2/XftCompat.h
+lib/libXft2.so
+lib/libXft2.so.2
+libdata/pkgconfig/xft.pc
+@dirrm include/X11/Xft2