aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts/libXft
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-25 14:55:39 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-04-25 14:55:39 +0000
commite61a47fd5b8007f85e9aff2fe60cbe82da4f505b (patch)
treef5e43e5423aa08eebb4a6cf5e40bfc78e6a63697 /x11-fonts/libXft
parent5f5ce270a7cc3dd8a8972d6f9cbd9a800e0d2285 (diff)
downloadports-e61a47fd5b8007f85e9aff2fe60cbe82da4f505b.tar.gz
ports-e61a47fd5b8007f85e9aff2fe60cbe82da4f505b.zip
Add a patch to fix PCF glyph problems.
Obtained from: Xft CVS
Notes
Notes: svn path=/head/; revision=79636
Diffstat (limited to 'x11-fonts/libXft')
-rw-r--r--x11-fonts/libXft/Makefile2
-rw-r--r--x11-fonts/libXft/files/patch-xftfreetype.c36
2 files changed, 37 insertions, 1 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
index d84dff6988eb..fe1bc43c6dae 100644
--- a/x11-fonts/libXft/Makefile
+++ b/x11-fonts/libXft/Makefile
@@ -7,7 +7,7 @@
PORTNAME= Xft
PORTVERSION= 2.1
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= x11-fonts
MASTER_SITES= http://fontconfig.org/fontconfig/release/
DISTNAME= fcpackage.${PORTVERSION:S/./_/}
diff --git a/x11-fonts/libXft/files/patch-xftfreetype.c b/x11-fonts/libXft/files/patch-xftfreetype.c
new file mode 100644
index 000000000000..20526f36b8c9
--- /dev/null
+++ b/x11-fonts/libXft/files/patch-xftfreetype.c
@@ -0,0 +1,36 @@
+--- xftfreetype.c 2003/04/17 04:29:24 1.31
++++ xftfreetype.c 2003/04/24 16:14:58 1.32
+@@ -638,6 +638,7 @@
+ int alloc_size;
+ int ascent, descent, height;
+ int i;
++ int num_glyphs;
+
+ if (!info)
+ return 0;
+@@ -769,8 +770,13 @@
+ rehash_value = 0;
+ }
+
++ /*
++ * Sometimes the glyphs are numbered 1..n, other times 0..n-1,
++ * accept either numbering scheme by making room in the table
++ */
++ num_glyphs = face->num_glyphs + 1;
+ alloc_size = (sizeof (XftFontInt) +
+- face->num_glyphs * sizeof (XftGlyph *) +
++ num_glyphs * sizeof (XftGlyph *) +
+ hash_value * sizeof (XftUcsHash));
+ font = malloc (alloc_size);
+
+@@ -867,8 +873,8 @@
+ * Per glyph information
+ */
+ font->glyphs = (XftGlyph **) (font + 1);
+- memset (font->glyphs, '\0', face->num_glyphs * sizeof (XftGlyph *));
+- font->num_glyphs = face->num_glyphs;
++ memset (font->glyphs, '\0', num_glyphs * sizeof (XftGlyph *));
++ font->num_glyphs = num_glyphs;
+ /*
+ * Unicode hash table information
+ */