aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2015-12-10 12:27:56 +0000
committerKoop Mast <kwm@FreeBSD.org>2015-12-10 12:27:56 +0000
commit6e1f609d2c6bb13ecc0cdeb615300100a125435e (patch)
tree54bf9edcf99daef32b42739aa5c80fb59bfc0e23 /x11-fonts
parent37fc192fb8983447ffb4f0c7b058cba82b7b04b8 (diff)
downloadports-6e1f609d2c6bb13ecc0cdeb615300100a125435e.tar.gz
ports-6e1f609d2c6bb13ecc0cdeb615300100a125435e.zip
Add libXfont2.
libXfont2 is the same as the old libXfont libary, but has a shiny new API/ABI that avoids referencing symbols in the X server directly. The code for the X server to use this version is awaiting review and merging still. Comment the CPE information out since it unclear which product name will be used.
Notes
Notes: svn path=/head/; revision=403449
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/libXfont2/Makefile26
-rw-r--r--x11-fonts/libXfont2/distinfo2
-rw-r--r--x11-fonts/libXfont2/pkg-descr3
-rw-r--r--x11-fonts/libXfont2/pkg-plist6
5 files changed, 38 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index bba4503ef3cd..73646747f1cd 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -114,6 +114,7 @@
SUBDIR += lfpfonts-var
SUBDIR += libFS
SUBDIR += libXfont
+ SUBDIR += libXfont2
SUBDIR += libXfontcache
SUBDIR += libXft
SUBDIR += liberation-fonts-ttf
diff --git a/x11-fonts/libXfont2/Makefile b/x11-fonts/libXfont2/Makefile
new file mode 100644
index 000000000000..327a6cdc8f2f
--- /dev/null
+++ b/x11-fonts/libXfont2/Makefile
@@ -0,0 +1,26 @@
+# Created by: Eric Anholt <anholt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libXfont2
+PORTVERSION= 2.0.0
+CATEGORIES= x11-fonts
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= X font library
+
+LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
+
+XORG_CAT= lib
+USE_XORG= xproto:both xtrans fontsproto:both fontenc
+INSTALL_TARGET= install-strip
+#USES+= cpe
+#CPE_PRODUCT= libxfont
+#CPE_VENDOR= x
+
+CONFIGURE_ARGS=--without-xmlto --disable-devel-docs --without-fop
+
+# will be removed in the next release
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/include/X11/fonts/fontconf.h
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/libXfont2/distinfo b/x11-fonts/libXfont2/distinfo
new file mode 100644
index 000000000000..ebcd8fa1722e
--- /dev/null
+++ b/x11-fonts/libXfont2/distinfo
@@ -0,0 +1,2 @@
+SHA256 (xorg/lib/libXfont2-2.0.0.tar.bz2) = 49c9bc8bb347890d958cfef2f601246e367caa1e4ab47502a374f8c926a74674
+SIZE (xorg/lib/libXfont2-2.0.0.tar.bz2) = 487706
diff --git a/x11-fonts/libXfont2/pkg-descr b/x11-fonts/libXfont2/pkg-descr
new file mode 100644
index 000000000000..8353c6742ad1
--- /dev/null
+++ b/x11-fonts/libXfont2/pkg-descr
@@ -0,0 +1,3 @@
+This package contains the X font libary
+
+WWW: http://www.freedesktop.org/Software/xlibs
diff --git a/x11-fonts/libXfont2/pkg-plist b/x11-fonts/libXfont2/pkg-plist
new file mode 100644
index 000000000000..e5044e60c437
--- /dev/null
+++ b/x11-fonts/libXfont2/pkg-plist
@@ -0,0 +1,6 @@
+include/X11/fonts/libxfont2.h
+lib/libXfont2.a
+lib/libXfont2.so
+lib/libXfont2.so.2
+lib/libXfont2.so.2.0.0
+libdata/pkgconfig/xfont2.pc