aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2012-06-09 13:01:21 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2012-06-09 13:01:21 +0000
commitd4768e381520babe05b4a68c718d2dbecdcf2071 (patch)
treef79e5eafb9c10ffee82c4fc8d107865d1b94b4ac /x11-fonts
parent7022dee7e221b56835b5671b23f2b2aa1d831d94 (diff)
downloadports-d4768e381520babe05b4a68c718d2dbecdcf2071.tar.gz
ports-d4768e381520babe05b4a68c718d2dbecdcf2071.zip
Add new port x11-fonts/gbdfed:
gbdfed is a GTK-based BDF font editor. It can import: - Metafont PK/GF fonts - Han Bitmap Font Format (HBF) fonts - Linux console (PSF, CP, and EGA/VGA) fonts - Sun VF fonts, OpenType (OTF & TTF) fonts Alternatively it can load a font from the X server. Export is supported to PSF2 Linux console fonts and HEX fonts. WWW: http://sofia.nmsu.edu/~mleisher/Software/gbdfed/ PR: ports/168726 Submitted by: Zhihao Yuan <lichray at gmail.com>
Notes
Notes: svn path=/head/; revision=298847
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/Makefile1
-rw-r--r--x11-fonts/gbdfed/Makefile27
-rw-r--r--x11-fonts/gbdfed/distinfo2
-rw-r--r--x11-fonts/gbdfed/files/patch-Makefile.in13
-rw-r--r--x11-fonts/gbdfed/files/patch-bdf.c12
-rw-r--r--x11-fonts/gbdfed/files/patch-fontgrid.c26
-rw-r--r--x11-fonts/gbdfed/files/patch-glyphedit.c11
-rw-r--r--x11-fonts/gbdfed/files/patch-gtkcompat.h11
-rw-r--r--x11-fonts/gbdfed/pkg-descr9
9 files changed, 112 insertions, 0 deletions
diff --git a/x11-fonts/Makefile b/x11-fonts/Makefile
index f2890d5374ac..73308d5c014c 100644
--- a/x11-fonts/Makefile
+++ b/x11-fonts/Makefile
@@ -80,6 +80,7 @@
SUBDIR += freefont-ttf
SUBDIR += freefonts
SUBDIR += fslsfonts
+ SUBDIR += gbdfed
SUBDIR += geminifonts
SUBDIR += gentium
SUBDIR += gentium-basic
diff --git a/x11-fonts/gbdfed/Makefile b/x11-fonts/gbdfed/Makefile
new file mode 100644
index 000000000000..b0999d219c18
--- /dev/null
+++ b/x11-fonts/gbdfed/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: gbdfed
+# Date created: 2012-06-05
+# Whom: Zhihao Yuan <lichray@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gbdfed
+PORTVERSION= 1.6
+CATEGORIES= x11-fonts
+MASTER_SITES= http://sofia.nmsu.edu/~mleisher/Software/gbdfed/
+
+MAINTAINER= lichray@gmail.com
+COMMENT= A GTK2 bitmap font editor
+
+LICENSE= MIT
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GNOME= gtk20 pkgconfig
+GNU_CONFIGURE= yes
+CPPFLAGS+= -I${LOCALBASE}/include
+
+MAN1= gbdfed.1
+PLIST_FILES= bin/gbdfed
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/gbdfed/distinfo b/x11-fonts/gbdfed/distinfo
new file mode 100644
index 000000000000..ab0033bd027f
--- /dev/null
+++ b/x11-fonts/gbdfed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gbdfed-1.6.tar.bz2) = 5db25d4ce688dcb188dee056e58614a94a5e4fce4b6066fbb310951ab999093c
+SIZE (gbdfed-1.6.tar.bz2) = 236166
diff --git a/x11-fonts/gbdfed/files/patch-Makefile.in b/x11-fonts/gbdfed/files/patch-Makefile.in
new file mode 100644
index 000000000000..fc910a85059a
--- /dev/null
+++ b/x11-fonts/gbdfed/files/patch-Makefile.in
@@ -0,0 +1,13 @@
+--- Makefile.in~ 2010-04-16 09:38:59.000000000 -0500
++++ Makefile.in 2012-06-05 11:54:08.209833058 -0500
+@@ -27,9 +27,7 @@ MKINSTALLDIRS = ./mkinstalldirs
+ CC = @CC@
+ CFLAGS = @XX_CFLAGS@ @CFLAGS@
+
+-DEFINES = @DEFINES@ -DG_DISABLE_DEPRECATED \
+- -DGDK_DISABLE_DEPRECATED -DGDK_PIXBUF_DISABLE_DEPRECATED \
+- -DGTK_DISABLE_DEPRECATED
++DEFINES = @DEFINES@
+
+ SRCS = bdf.c \
+ bdfcons.c \
diff --git a/x11-fonts/gbdfed/files/patch-bdf.c b/x11-fonts/gbdfed/files/patch-bdf.c
new file mode 100644
index 000000000000..f2712f389a6e
--- /dev/null
+++ b/x11-fonts/gbdfed/files/patch-bdf.c
@@ -0,0 +1,12 @@
+--- bdf.c~ 2010-04-16 09:38:59.000000000 -0500
++++ bdf.c 2012-06-05 12:14:59.810640261 -0500
+@@ -1654,6 +1654,9 @@ _bdf_parse_properties(char *line, unsign
+ next = (_bdf_line_func_t *) call_data;
+ p = (_bdf_parse_t *) client_data;
+
++ while (*line == ' ' || *line == '\t')
++ ++line;
++
+ /*
+ * Check for the end of the properties.
+ */
diff --git a/x11-fonts/gbdfed/files/patch-fontgrid.c b/x11-fonts/gbdfed/files/patch-fontgrid.c
new file mode 100644
index 000000000000..5df2b6996f2f
--- /dev/null
+++ b/x11-fonts/gbdfed/files/patch-fontgrid.c
@@ -0,0 +1,26 @@
+--- fontgrid.c~ 2010-04-16 09:39:02.000000000 -0500
++++ fontgrid.c 2012-06-05 12:50:41.558078595 -0500
+@@ -4711,10 +4711,7 @@ fontgrid_select_next_glyph(Fontgrid *fw,
+ return FALSE;
+ }
+
+- if (fw->orientation == GTK_ORIENTATION_VERTICAL)
+- code += (fw->cell_rows * count);
+- else
+- code += count;
++ code += count;
+
+ if (fw->unencoded && code > gp->encoding)
+ code = gp->encoding;
+@@ -4794,10 +4791,7 @@ fontgrid_select_previous_glyph(Fontgrid
+ return FALSE;
+ }
+
+- if (fw->orientation == GTK_ORIENTATION_VERTICAL)
+- code -= (fw->cell_rows * count);
+- else
+- code -= count;
++ code -= count;
+
+ if (code < 0)
+ code = 0;
diff --git a/x11-fonts/gbdfed/files/patch-glyphedit.c b/x11-fonts/gbdfed/files/patch-glyphedit.c
new file mode 100644
index 000000000000..33a39a66fc1a
--- /dev/null
+++ b/x11-fonts/gbdfed/files/patch-glyphedit.c
@@ -0,0 +1,11 @@
+--- glyphedit.c~ 2010-04-16 09:39:04.000000000 -0500
++++ glyphedit.c 2012-06-05 12:08:22.488759533 -0500
+@@ -114,7 +114,7 @@ enum {
+ **************************************************************************/
+
+ static GtkWidgetClass *parent_class = 0;
+-static guint glyphedit_signals[OPERATION_CHANGE + 1];
++static guint glyphedit_signals[COLOR_CHANGE + 1];
+
+ /**************************************************************************
+ *
diff --git a/x11-fonts/gbdfed/files/patch-gtkcompat.h b/x11-fonts/gbdfed/files/patch-gtkcompat.h
new file mode 100644
index 000000000000..8deeb2edb345
--- /dev/null
+++ b/x11-fonts/gbdfed/files/patch-gtkcompat.h
@@ -0,0 +1,11 @@
+--- gtkcompat.h~ 2010-04-16 09:39:05.000000000 -0500
++++ gtkcompat.h 2012-06-05 12:01:03.340069638 -0500
+@@ -24,7 +24,7 @@
+
+ #include <gtk/gtkversion.h>
+
+-#if GTK_MAJOR_VERSION >= (2) && GTK_MINOR_VERSION >= (20)
++#if 0
+ #define GTK_WIDGET_REALIZED gtk_widget_get_realized
+ #define GTK_WIDGET_STATE gtk_widget_get_state
+ #define GTK_WIDGET_HAS_FOCUS gtk_widget_has_focus
diff --git a/x11-fonts/gbdfed/pkg-descr b/x11-fonts/gbdfed/pkg-descr
new file mode 100644
index 000000000000..33033e48a0e2
--- /dev/null
+++ b/x11-fonts/gbdfed/pkg-descr
@@ -0,0 +1,9 @@
+gbdfed is a GTK-based BDF font editor. It can import:
+ - Metafont PK/GF fonts
+ - Han Bitmap Font Format (HBF) fonts
+ - Linux console (PSF, CP, and EGA/VGA) fonts
+ - Sun VF fonts, OpenType (OTF & TTF) fonts
+Alternatively it can load a font from the X server. Export is
+supported to PSF2 Linux console fonts and HEX fonts.
+
+WWW: http://sofia.nmsu.edu/~mleisher/Software/gbdfed/