aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2010-05-24 21:36:32 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2010-05-24 21:36:32 +0000
commita6e8431234bfc67d5ac218d4d14abdba603a1429 (patch)
tree8639c4fa9654bde1ca5ebf0cb0f377ae604d4c74 /x11-fonts
parent20778a8fedbdd7270c490cc64715687d8e9ecc75 (diff)
downloadports-a6e8431234bfc67d5ac218d4d14abdba603a1429.tar.gz
ports-a6e8431234bfc67d5ac218d4d14abdba603a1429.zip
Add new port x11-fonts/isabella:
This font is called Isabella because it is based on the calligraphic hand used in the Isabella Breviary, made around 1497, in Holland, for Isabella of Castille, the first queen of united Spain. WWW: http://www.thibault.org/fonts/isabella/ PR: based on ports/144624 Submitted by: Lowell Gilbert <lgfbsd at be-well.ilk.org>
Notes
Notes: svn path=/head/; revision=254996
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/isabella/Makefile40
-rw-r--r--x11-fonts/isabella/distinfo3
-rw-r--r--x11-fonts/isabella/pkg-descr5
-rw-r--r--x11-fonts/isabella/pkg-plist8
4 files changed, 56 insertions, 0 deletions
diff --git a/x11-fonts/isabella/Makefile b/x11-fonts/isabella/Makefile
new file mode 100644
index 000000000000..013f63718d06
--- /dev/null
+++ b/x11-fonts/isabella/Makefile
@@ -0,0 +1,40 @@
+# Ports collection makefile for: isabella-ttf
+# Date created: 2010-03-07
+# Whom: Lowell Gilbert <lgfbsd@be-well.ilk.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= isabella-ttf
+PORTVERSION= 1.2
+CATEGORIES= x11-fonts
+MASTER_SITES= http://www.thibault.org/fonts/isabella/
+DISTNAME= Isabella-${PORTVERSION}-ttf
+
+MAINTAINER= lgfbsd@be-well.ilk.org
+COMMENT= Font by John Stracke based on the Isabella Breviary
+
+BUILD_DEPENDS= ${MKFONTSCL_CMD}:${PORTSDIR}/x11-fonts/mkfontscale \
+ ${MKFONTDIR_CMD}:${PORTSDIR}/x11-fonts/mkfontdir
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/Isabella
+FONTDIR= ${PREFIX}/lib/X11/fonts/stracke
+PLIST_SUB= FONTDIR="${FONTDIR:S|${PREFIX}/||}" \
+ MKFONTSCL_CMD=${MKFONTSCL_CMD} \
+ MKFONTDIR_CMD=${MKFONTDIR_CMD}
+
+MKFONTSCL_CMD= ${LOCALBASE}/bin/mkfontscale
+MKFONTDIR_CMD= ${LOCALBASE}/bin/mkfontdir
+
+do-install:
+ ${MKDIR} ${FONTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/*.ttf ${FONTDIR}
+ cd ${FONTDIR} && ${MKFONTSCL_CMD} && ${MKFONTDIR_CMD}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/x11-fonts/isabella/distinfo b/x11-fonts/isabella/distinfo
new file mode 100644
index 000000000000..a41390feedd6
--- /dev/null
+++ b/x11-fonts/isabella/distinfo
@@ -0,0 +1,3 @@
+MD5 (Isabella-1.2-ttf.tar.gz) = ce294e22771606657df7feb41d6e6503
+SHA256 (Isabella-1.2-ttf.tar.gz) = ef67b3063ee0844b94d9d698ca7eb62c12a010f728a78a52008dccd0e9a5b37a
+SIZE (Isabella-1.2-ttf.tar.gz) = 220750
diff --git a/x11-fonts/isabella/pkg-descr b/x11-fonts/isabella/pkg-descr
new file mode 100644
index 000000000000..40ad31e84f78
--- /dev/null
+++ b/x11-fonts/isabella/pkg-descr
@@ -0,0 +1,5 @@
+This font is called Isabella because it is based on the calligraphic
+hand used in the Isabella Breviary, made around 1497, in Holland,
+for Isabella of Castille, the first queen of united Spain.
+
+WWW: http://www.thibault.org/fonts/isabella/
diff --git a/x11-fonts/isabella/pkg-plist b/x11-fonts/isabella/pkg-plist
new file mode 100644
index 000000000000..63ec36766a93
--- /dev/null
+++ b/x11-fonts/isabella/pkg-plist
@@ -0,0 +1,8 @@
+%%FONTDIR%%/Isabella.ttf
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec %%MKFONTSCL_CMD%% %D/%%FONTDIR%% && %%MKFONTDIR_CMD%% %D/%%FONTDIR%%
+@unexec cd %D/%%FONTDIR%% && if [ -f fonts.scale -a `head -1 fonts.scale` = 0 ]; then rm -f fonts.scale; fi
+@unexec cd %D/%%FONTDIR%% && if [ -f fonts.dir -a `head -1 fonts.dir` = 0 ]; then rm -f fonts.dir; fi
+@dirrmtry %%FONTDIR%%
+@exec %%MKFONTSCL_CMD%% %D/%%FONTDIR%% && %%MKFONTDIR_CMD%% %D/%%FONTDIR%%