aboutsummaryrefslogtreecommitdiff
path: root/x11-fonts
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-19 09:16:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-03-19 09:16:28 +0000
commit7f4a73e2e76f4ba00a41e0888cfc8f49f06e5876 (patch)
treebb745204bb1001e707a2ba7e3568e9b29da38092 /x11-fonts
parent2622e635a0c8ff5fa13df241cb6d947f8b15b353 (diff)
downloadports-7f4a73e2e76f4ba00a41e0888cfc8f49f06e5876.tar.gz
ports-7f4a73e2e76f4ba00a41e0888cfc8f49f06e5876.zip
Revert a portion of the font rendering code that enforces strict bitmap font
sizes. This was causing a problem loading certain fonts. This code is now equivalent to Xft-2.1.2.
Notes
Notes: svn path=/head/; revision=104604
Diffstat (limited to 'x11-fonts')
-rw-r--r--x11-fonts/libXft/Makefile1
-rw-r--r--x11-fonts/libXft/files/patch-xftfreetype.c57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-fonts/libXft/Makefile b/x11-fonts/libXft/Makefile
index 6cd3f26ffac7..26dc17fb1400 100644
--- a/x11-fonts/libXft/Makefile
+++ b/x11-fonts/libXft/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libXft
PORTVERSION= 2.1.5
+PORTREVISION= 1
CATEGORIES= x11-fonts
MASTER_SITES= http://pdx.freedesktop.org/~xlibs/release/
diff --git a/x11-fonts/libXft/files/patch-xftfreetype.c b/x11-fonts/libXft/files/patch-xftfreetype.c
new file mode 100644
index 000000000000..a3e878fd01b3
--- /dev/null
+++ b/x11-fonts/libXft/files/patch-xftfreetype.c
@@ -0,0 +1,57 @@
+--- xftfreetype.c.orig Fri Mar 19 04:11:09 2004
++++ xftfreetype.c Fri Mar 19 04:11:30 2004
+@@ -192,53 +192,9 @@
+ if (XftDebug() & XFT_DBG_GLYPH)
+ printf ("Set face size to %dx%d (%dx%d)\n",
+ (int) (xsize >> 6), (int) (ysize >> 6), (int) xsize, (int) ysize);
+- /*
+- * Bitmap only faces must match exactly, so find the closest
+- * one (height dominant search)
+- */
+- if (!(face->face_flags & FT_FACE_FLAG_SCALABLE))
+- {
+- FT_Short width = xsize >> 6;
+- FT_Short height = ysize >> 6;
+- int i, best = -1;
+-
+-#define xft_abs(a) ((a) < 0 ? -(a) : (a))
+-#define dist(a,b) (xft_abs((a)-(b)))
+-
+-#if !HAVE_FT_BITMAP_SIZE_Y_PPEM
+-#define y_ppem height
+-#define x_ppem width
+-#endif
+- for (i = 0; i < face->num_fixed_sizes; i++)
+- {
+- if (best == -1 ||
+- dist (height, face->available_sizes[i].y_ppem >> 6) <
+- dist (height, face->available_sizes[best].y_ppem >> 6) ||
+- (dist (height, face->available_sizes[i].y_ppem >> 6) ==
+- dist (height, face->available_sizes[best].y_ppem >> 6) &&
+- dist (width, face->available_sizes[i].x_ppem >> 6) <
+- dist (width, face->available_sizes[best].x_ppem >> 6)))
+- {
+- best = i;
+- }
+- }
+- if (FT_Set_Char_Size (face, face->available_sizes[best].x_ppem,
+- face->available_sizes[best].y_ppem, 0, 0) != 0)
+- {
+- return False;
+- }
+-#if !HAVE_FT_BITMAP_SIZE_Y_PPEM
+-#undef y_ppem
+-#undef x_ppem
+-#endif
+- }
+- else
+- {
+ if (FT_Set_Char_Size (face, xsize, ysize, 0, 0))
+- {
+ return False;
+- }
+- }
++
+ f->xsize = xsize;
+ f->ysize = ysize;
+ }